summaryrefslogtreecommitdiffstats
path: root/recipes-security
diff options
context:
space:
mode:
authorAndrew Davis <afd@ti.com>2022-08-04 21:49:28 -0500
committerRyan Eatmon <reatmon@ti.com>2022-08-06 19:04:37 -0500
commit1d9d7c6e4e1d2473bc4b41741cda13c07b691f69 (patch)
tree38df53d35fbe12b3e7ed77beedc0c71ae36708df /recipes-security
parent4e9b3f4744e79b216774304878304c14a129a95c (diff)
downloadmeta-ti-1d9d7c6e4e1d2473bc4b41741cda13c07b691f69.tar.gz
optee-os: Allow build to continue without TI_SECURE_DEV_PKG set
Signed-off-by: Andrew Davis <afd@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'recipes-security')
-rw-r--r--recipes-security/optee/optee-os_%.bbappend7
1 files changed, 6 insertions, 1 deletions
diff --git a/recipes-security/optee/optee-os_%.bbappend b/recipes-security/optee/optee-os_%.bbappend
index 7fe5f26e..5a25bd99 100644
--- a/recipes-security/optee/optee-os_%.bbappend
+++ b/recipes-security/optee/optee-os_%.bbappend
@@ -43,7 +43,12 @@ optee_sign_legacyhs() {
43# Signing procedure for K3 HS devices 43# Signing procedure for K3 HS devices
44optee_sign_k3hs() { 44optee_sign_k3hs() {
45 ( cd out/arm-plat-${OPTEEOUTPUTMACHINE}/core/; \ 45 ( cd out/arm-plat-${OPTEEOUTPUTMACHINE}/core/; \
46 ${TI_SECURE_DEV_PKG}/scripts/secure-binary-image.sh tee-pager_v2.bin tee-pager.bin.signed; \ 46 if [ -f ${TI_SECURE_DEV_PKG}/scripts/secure-binary-image.sh ]; then \
47 ${TI_SECURE_DEV_PKG}/scripts/secure-binary-image.sh tee-pager_v2.bin tee-pager.bin.signed; \
48 else \
49 echo "Warning: TI_SECURE_DEV_PKG not set, OP-TEE not signed."; \
50 cp tee-pager_v2.bin tee-pager.bin.signed; \
51 fi; \
47 mv tee-pager.bin.signed ${B}/bl32.bin; \ 52 mv tee-pager.bin.signed ${B}/bl32.bin; \
48 cp tee.elf ${B}/bl32.elf; \ 53 cp tee.elf ${B}/bl32.elf; \
49 ) 54 )