diff options
author | Andrew Davis <afd@ti.com> | 2022-06-16 11:42:14 -0500 |
---|---|---|
committer | Ryan Eatmon <reatmon@ti.com> | 2022-06-20 12:32:57 -0500 |
commit | f8182afdcfe427865707077d353359827f1ff6bf (patch) | |
tree | 7d28e75c925f472338765ae0d4f914afbdfc476e /recipes-security/optee | |
parent | 26998f43077ff665e93e571a8d3afae859a28f42 (diff) | |
download | meta-ti-f8182afdcfe427865707077d353359827f1ff6bf.tar.gz |
optee: Upgrade to upstream 3.17.0
Update to the latest upstream master which is 3.17.
We do this to add HUK and AM64x/AM62x support.
With this we need to also switch OPTEEMACHINE for AM64x/AM62x.
To build against the latest OP-TEE the support recipes need updated also.
Move these here into meta-ti so that builds will still work when not using
meta-arago-distro.
The fix patches do not look to be needed anymore.
While here switch to git checkout with https.
NOTE: The latest OP-TEE requires SYSFW 8.04+
Signed-off-by: Andrew Davis <afd@ti.com>
Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'recipes-security/optee')
6 files changed, 13 insertions, 73 deletions
diff --git a/recipes-security/optee/optee-client_%.bbappend b/recipes-security/optee/optee-client_%.bbappend new file mode 100644 index 00000000..5675570a --- /dev/null +++ b/recipes-security/optee/optee-client_%.bbappend | |||
@@ -0,0 +1,2 @@ | |||
1 | PV_ti-soc = "3.17.0+git${SRCPV}" | ||
2 | SRCREV_ti-soc = "a5c30b1277466a9bf85b62f45a6b00e79774e29c" | ||
diff --git a/recipes-security/optee/optee-examples_%.bbappend b/recipes-security/optee/optee-examples_%.bbappend new file mode 100644 index 00000000..19e32d9d --- /dev/null +++ b/recipes-security/optee/optee-examples_%.bbappend | |||
@@ -0,0 +1,2 @@ | |||
1 | PV_ti-soc = "3.17.0+git${SRCPV}" | ||
2 | SRCREV_ti-soc = "65fc74309e12189ad5b6ce3ffec37c8011088a5a" | ||
diff --git a/recipes-security/optee/optee-os/0006-allow-setting-sysroot-for-libgcc-lookup.patch b/recipes-security/optee/optee-os/0006-allow-setting-sysroot-for-libgcc-lookup.patch deleted file mode 100644 index 17005396..00000000 --- a/recipes-security/optee/optee-os/0006-allow-setting-sysroot-for-libgcc-lookup.patch +++ /dev/null | |||
@@ -1,34 +0,0 @@ | |||
1 | From 0bab935695ebcf0c533b49896ab18ff33d4a47d1 Mon Sep 17 00:00:00 2001 | ||
2 | From: Ross Burton <ross.burton@arm.com> | ||
3 | Date: Tue, 26 May 2020 14:38:02 -0500 | ||
4 | Subject: [PATCH] allow setting sysroot for libgcc lookup | ||
5 | |||
6 | Explicitly pass the new variable LIBGCC_LOCATE_CFLAGS variable when searching | ||
7 | for the compiler libraries as there's no easy way to reliably pass --sysroot | ||
8 | otherwise. | ||
9 | |||
10 | Upstream-Status: Pending [https://github.com/OP-TEE/optee_os/issues/4188] | ||
11 | Signed-off-by: Ross Burton <ross.burton@arm.com> | ||
12 | --- | ||
13 | mk/gcc.mk | 6 +++--- | ||
14 | 1 file changed, 3 insertions(+), 3 deletions(-) | ||
15 | |||
16 | diff --git a/mk/gcc.mk b/mk/gcc.mk | ||
17 | index adc77a24..81bfa78a 100644 | ||
18 | --- a/mk/gcc.mk | ||
19 | +++ b/mk/gcc.mk | ||
20 | @@ -13,11 +13,11 @@ nostdinc$(sm) := -nostdinc -isystem $(shell $(CC$(sm)) \ | ||
21 | -print-file-name=include 2> /dev/null) | ||
22 | |||
23 | # Get location of libgcc from gcc | ||
24 | -libgcc$(sm) := $(shell $(CC$(sm)) $(CFLAGS$(arch-bits-$(sm))) \ | ||
25 | +libgcc$(sm) := $(shell $(CC$(sm)) $(LIBGCC_LOCATE_CFLAGS) $(CFLAGS$(arch-bits-$(sm))) \ | ||
26 | -print-libgcc-file-name 2> /dev/null) | ||
27 | -libstdc++$(sm) := $(shell $(CXX$(sm)) $(CXXFLAGS$(arch-bits-$(sm))) $(comp-cxxflags$(sm)) \ | ||
28 | +libstdc++$(sm) := $(shell $(CXX$(sm)) $(LIBGCC_LOCATE_CFLAGS) $(CXXFLAGS$(arch-bits-$(sm))) $(comp-cxxflags$(sm)) \ | ||
29 | -print-file-name=libstdc++.a 2> /dev/null) | ||
30 | -libgcc_eh$(sm) := $(shell $(CXX$(sm)) $(CXXFLAGS$(arch-bits-$(sm))) $(comp-cxxflags$(sm)) \ | ||
31 | +libgcc_eh$(sm) := $(shell $(CXX$(sm)) $(LIBGCC_LOCATE_CFLAGS) $(CXXFLAGS$(arch-bits-$(sm))) $(comp-cxxflags$(sm)) \ | ||
32 | -print-file-name=libgcc_eh.a 2> /dev/null) | ||
33 | |||
34 | # Define these to something to discover accidental use | ||
diff --git a/recipes-security/optee/optee-os/0007-allow-setting-sysroot-for-clang.patch b/recipes-security/optee/optee-os/0007-allow-setting-sysroot-for-clang.patch deleted file mode 100644 index 5c0d0a56..00000000 --- a/recipes-security/optee/optee-os/0007-allow-setting-sysroot-for-clang.patch +++ /dev/null | |||
@@ -1,29 +0,0 @@ | |||
1 | From 3167f2c0dba4db59d61b60a8fe66f969d20aafa9 Mon Sep 17 00:00:00 2001 | ||
2 | From: Brett Warren <brett.warren@arm.com> | ||
3 | Date: Wed, 23 Sep 2020 09:27:34 +0100 | ||
4 | Subject: [PATCH] optee: enable clang support | ||
5 | |||
6 | When compiling with clang, the LIBGCC_LOCATE_CFLAG variable used | ||
7 | to provide a sysroot wasn't included, which results in not locating | ||
8 | compiler-rt. This is mitigated by including the variable as ammended. | ||
9 | |||
10 | Upstream-Status: Pending | ||
11 | ChangeId: 8ba69a4b2eb8ebaa047cb266c9aa6c2c3da45701 | ||
12 | Signed-off-by: Brett Warren <brett.warren@arm.com> | ||
13 | --- | ||
14 | mk/clang.mk | 2 +- | ||
15 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
16 | |||
17 | diff --git a/mk/clang.mk b/mk/clang.mk | ||
18 | index 0f48c836..47465523 100644 | ||
19 | --- a/mk/clang.mk | ||
20 | +++ b/mk/clang.mk | ||
21 | @@ -27,7 +27,7 @@ comp-cflags-warns-clang := -Wno-language-extension-token \ | ||
22 | |||
23 | # Note, use the compiler runtime library (libclang_rt.builtins.*.a) instead of | ||
24 | # libgcc for clang | ||
25 | -libgcc$(sm) := $(shell $(CC$(sm)) $(CFLAGS$(arch-bits-$(sm))) \ | ||
26 | +libgcc$(sm) := $(shell $(CC$(sm)) $(LIBGCC_LOCATE_CFLAGS) $(CFLAGS$(arch-bits-$(sm))) \ | ||
27 | -rtlib=compiler-rt -print-libgcc-file-name 2> /dev/null) | ||
28 | |||
29 | # Core ASLR relies on the executable being ready to run from its preferred load | ||
diff --git a/recipes-security/optee/optee-os_%.bbappend b/recipes-security/optee/optee-os_%.bbappend index e128da89..16c10979 100644 --- a/recipes-security/optee/optee-os_%.bbappend +++ b/recipes-security/optee/optee-os_%.bbappend | |||
@@ -1,14 +1,8 @@ | |||
1 | FILESEXTRAPATHS_prepend_ti-soc := "${THISDIR}/${PN}:" | 1 | PV_ti-soc = "3.17.0+git${SRCPV}" |
2 | SRCREV_ti-soc = "15a746d28d10df3d79d72bc9fe4a5a654b88bcca" | ||
3 | SRC_URI_ti-soc = "git://github.com/OP-TEE/optee_os.git;protocol=https" | ||
2 | 4 | ||
3 | PV_ti-soc = "3.12.0+git${SRCPV}" | 5 | DEPENDS_append_ti-soc = " python3-cryptography-native" |
4 | |||
5 | SRCREV_ti-soc = "3d47a131bca1d9ed511bfd516aa5e70269e12c1d" | ||
6 | |||
7 | SRC_URI_ti-soc = " \ | ||
8 | git://github.com/OP-TEE/optee_os.git \ | ||
9 | file://0006-allow-setting-sysroot-for-libgcc-lookup.patch \ | ||
10 | file://0007-allow-setting-sysroot-for-clang.patch \ | ||
11 | " | ||
12 | 6 | ||
13 | EXTRA_OEMAKE_append_k3 = "${@ 'CFG_CONSOLE_UART='+ d.getVar('OPTEE_K3_USART') if d.getVar('OPTEE_K3_USART') else ''}" | 7 | EXTRA_OEMAKE_append_k3 = "${@ 'CFG_CONSOLE_UART='+ d.getVar('OPTEE_K3_USART') if d.getVar('OPTEE_K3_USART') else ''}" |
14 | 8 | ||
diff --git a/recipes-security/optee/optee-test_%.bbappend b/recipes-security/optee/optee-test_%.bbappend new file mode 100644 index 00000000..d81ae521 --- /dev/null +++ b/recipes-security/optee/optee-test_%.bbappend | |||
@@ -0,0 +1,5 @@ | |||
1 | PV_ti-soc = "3.17.0+git${SRCPV}" | ||
2 | SRCREV_ti-soc = "8a698baf9e8e010e4d8d52e6aded42dfc31e5b25" | ||
3 | SRC_URI_ti-soc = "git://github.com/OP-TEE/optee_test.git;protocol=https" | ||
4 | |||
5 | DEPENDS_append_ti-soc = " python3-cryptography-native" | ||