summaryrefslogtreecommitdiffstats
path: root/recipes-security/optee
diff options
context:
space:
mode:
authorAndrew Davis <afd@ti.com>2022-06-27 15:40:42 -0500
committerRyan Eatmon <reatmon@ti.com>2022-06-30 12:43:30 -0500
commitb301f71f305e9c799113a999b36371b5dd12c48f (patch)
tree90cecf3cc33ee59db304bf19eb163957352f0dc4 /recipes-security/optee
parent1f3f4fe7e4fba96fc95c658aaeccf435ed21518d (diff)
downloadmeta-ti-b301f71f305e9c799113a999b36371b5dd12c48f.tar.gz
optee-os: Use software RNG on AM62x and J721s2
The TRNG driver is not currently functional for these two platforms. Disable the TRNG driver until fixed. Reported-by: Vignesh Raghavendra <vigneshr@ti.com> Signed-off-by: Andrew Davis <afd@ti.com> Reviewed-by: Praneeth Bajjuri <praneeth@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'recipes-security/optee')
-rw-r--r--recipes-security/optee/optee-os_%.bbappend4
1 files changed, 4 insertions, 0 deletions
diff --git a/recipes-security/optee/optee-os_%.bbappend b/recipes-security/optee/optee-os_%.bbappend
index 16c10979..7fe5f26e 100644
--- a/recipes-security/optee/optee-os_%.bbappend
+++ b/recipes-security/optee/optee-os_%.bbappend
@@ -6,6 +6,10 @@ DEPENDS_append_ti-soc = " python3-cryptography-native"
6 6
7EXTRA_OEMAKE_append_k3 = "${@ 'CFG_CONSOLE_UART='+ d.getVar('OPTEE_K3_USART') if d.getVar('OPTEE_K3_USART') else ''}" 7EXTRA_OEMAKE_append_k3 = "${@ 'CFG_CONSOLE_UART='+ d.getVar('OPTEE_K3_USART') if d.getVar('OPTEE_K3_USART') else ''}"
8 8
9EXTRA_OEMAKE_append_am62xx-evm = " CFG_WITH_SOFTWARE_PRNG=y"
10EXTRA_OEMAKE_append_j721s2-evm = " CFG_WITH_SOFTWARE_PRNG=y"
11EXTRA_OEMAKE_append_j721s2-hs-evm = " CFG_WITH_SOFTWARE_PRNG=y"
12
9do_compile_prepend_ti-soc() { 13do_compile_prepend_ti-soc() {
10 export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG} 14 export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG}
11} 15}