summaryrefslogtreecommitdiffstats
path: root/recipes-security/optee/optee-os/0007-allow-setting-sysroot-for-clang.patch
diff options
context:
space:
mode:
authorAndrew Davis <afd@ti.com>2022-06-16 11:42:14 -0500
committerRyan Eatmon <reatmon@ti.com>2022-06-20 12:32:57 -0500
commitf8182afdcfe427865707077d353359827f1ff6bf (patch)
tree7d28e75c925f472338765ae0d4f914afbdfc476e /recipes-security/optee/optee-os/0007-allow-setting-sysroot-for-clang.patch
parent26998f43077ff665e93e571a8d3afae859a28f42 (diff)
downloadmeta-ti-f8182afdcfe427865707077d353359827f1ff6bf.tar.gz
optee: Upgrade to upstream 3.17.0
Update to the latest upstream master which is 3.17. We do this to add HUK and AM64x/AM62x support. With this we need to also switch OPTEEMACHINE for AM64x/AM62x. To build against the latest OP-TEE the support recipes need updated also. Move these here into meta-ti so that builds will still work when not using meta-arago-distro. The fix patches do not look to be needed anymore. While here switch to git checkout with https. NOTE: The latest OP-TEE requires SYSFW 8.04+ Signed-off-by: Andrew Davis <afd@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'recipes-security/optee/optee-os/0007-allow-setting-sysroot-for-clang.patch')
-rw-r--r--recipes-security/optee/optee-os/0007-allow-setting-sysroot-for-clang.patch29
1 files changed, 0 insertions, 29 deletions
diff --git a/recipes-security/optee/optee-os/0007-allow-setting-sysroot-for-clang.patch b/recipes-security/optee/optee-os/0007-allow-setting-sysroot-for-clang.patch
deleted file mode 100644
index 5c0d0a56..00000000
--- a/recipes-security/optee/optee-os/0007-allow-setting-sysroot-for-clang.patch
+++ /dev/null
@@ -1,29 +0,0 @@
1From 3167f2c0dba4db59d61b60a8fe66f969d20aafa9 Mon Sep 17 00:00:00 2001
2From: Brett Warren <brett.warren@arm.com>
3Date: Wed, 23 Sep 2020 09:27:34 +0100
4Subject: [PATCH] optee: enable clang support
5
6When compiling with clang, the LIBGCC_LOCATE_CFLAG variable used
7to provide a sysroot wasn't included, which results in not locating
8compiler-rt. This is mitigated by including the variable as ammended.
9
10Upstream-Status: Pending
11ChangeId: 8ba69a4b2eb8ebaa047cb266c9aa6c2c3da45701
12Signed-off-by: Brett Warren <brett.warren@arm.com>
13---
14 mk/clang.mk | 2 +-
15 1 file changed, 1 insertion(+), 1 deletion(-)
16
17diff --git a/mk/clang.mk b/mk/clang.mk
18index 0f48c836..47465523 100644
19--- a/mk/clang.mk
20+++ b/mk/clang.mk
21@@ -27,7 +27,7 @@ comp-cflags-warns-clang := -Wno-language-extension-token \
22
23 # Note, use the compiler runtime library (libclang_rt.builtins.*.a) instead of
24 # libgcc for clang
25-libgcc$(sm) := $(shell $(CC$(sm)) $(CFLAGS$(arch-bits-$(sm))) \
26+libgcc$(sm) := $(shell $(CC$(sm)) $(LIBGCC_LOCATE_CFLAGS) $(CFLAGS$(arch-bits-$(sm))) \
27 -rtlib=compiler-rt -print-libgcc-file-name 2> /dev/null)
28
29 # Core ASLR relies on the executable being ready to run from its preferred load