summaryrefslogtreecommitdiffstats
path: root/recipes-kernel
diff options
context:
space:
mode:
authorChase Maupin <Chase.Maupin@ti.com>2013-03-29 09:37:51 -0500
committerDenys Dmytriyenko <denys@ti.com>2013-03-29 13:34:46 -0400
commitca0f68d71b08de156c4424324466aab0ebc7296f (patch)
tree42bcc9b21c9642c9b929635b98fa7f68db4025b2 /recipes-kernel
parent886bea2308bdd56ac7eae24436a84a7c863e72fa (diff)
downloadmeta-ti-ca0f68d71b08de156c4424324466aab0ebc7296f.tar.gz
linux: Use setup-defconfig in kernel recipes
* Now that the setup-defconfig.inc file has been moved to the meta-ti layer the kernel recipes should include this file. * This makes way to clear this inclusion from the bbappend files in meta-arago Signed-off-by: Chase Maupin <Chase.Maupin@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/linux/linux-am335x_3.2.0-psp04.06.00.08.bb3
-rw-r--r--recipes-kernel/linux/linux-omap-psp_2.6.37.bb3
-rw-r--r--recipes-kernel/linux/linux-omapl138-psp_2.6.37.bb3
-rw-r--r--recipes-kernel/linux/linux_3.3.7.bb3
4 files changed, 8 insertions, 4 deletions
diff --git a/recipes-kernel/linux/linux-am335x_3.2.0-psp04.06.00.08.bb b/recipes-kernel/linux/linux-am335x_3.2.0-psp04.06.00.08.bb
index 49d67342..74394a69 100644
--- a/recipes-kernel/linux/linux-am335x_3.2.0-psp04.06.00.08.bb
+++ b/recipes-kernel/linux/linux-am335x_3.2.0-psp04.06.00.08.bb
@@ -7,6 +7,7 @@ COMPATIBLE_MACHINE = "ti33x"
7DEFAULT_PREFERENCE = "-1" 7DEFAULT_PREFERENCE = "-1"
8 8
9inherit kernel 9inherit kernel
10require setup-defconfig.inc
10 11
11# Stage the power management firmware before building the kernel 12# Stage the power management firmware before building the kernel
12DEPENDS += "am33x-cm3" 13DEPENDS += "am33x-cm3"
@@ -14,7 +15,7 @@ DEPENDS += "am33x-cm3"
14KERNEL_IMAGETYPE = "uImage" 15KERNEL_IMAGETYPE = "uImage"
15 16
16# The main PR is now using MACHINE_KERNEL_PR, for ti33x see conf/machine/include/ti33x.inc 17# The main PR is now using MACHINE_KERNEL_PR, for ti33x see conf/machine/include/ti33x.inc
17MACHINE_KERNEL_PR_append = "a+gitr${SRCREV}" 18MACHINE_KERNEL_PR_append = "b+gitr${SRCREV}"
18 19
19BRANCH = "v3.2-staging" 20BRANCH = "v3.2-staging"
20 21
diff --git a/recipes-kernel/linux/linux-omap-psp_2.6.37.bb b/recipes-kernel/linux/linux-omap-psp_2.6.37.bb
index 9eacfc9b..5d72af58 100644
--- a/recipes-kernel/linux/linux-omap-psp_2.6.37.bb
+++ b/recipes-kernel/linux/linux-omap-psp_2.6.37.bb
@@ -1,4 +1,5 @@
1require linux.inc 1require linux.inc
2require setup-defconfig.inc
2 3
3DESCRIPTION = "Linux kernel for OMAP3 EVM from PSP, based on linux-omap3 kernel" 4DESCRIPTION = "Linux kernel for OMAP3 EVM from PSP, based on linux-omap3 kernel"
4 5
@@ -8,7 +9,7 @@ SRCREV= "20c003f2f024d9f50f59edf9f1b8f5f035fb15b8"
8 9
9# The main PR is now using MACHINE_KERNEL_PR, for omap3 devices 10# The main PR is now using MACHINE_KERNEL_PR, for omap3 devices
10# see conf/machine/include/omap3.inc 11# see conf/machine/include/omap3.inc
11MACHINE_KERNEL_PR_append = "a" 12MACHINE_KERNEL_PR_append = "b"
12 13
13SRC_URI = "git://arago-project.org/git/projects/linux-omap3.git;protocol=git \ 14SRC_URI = "git://arago-project.org/git/projects/linux-omap3.git;protocol=git \
14 file://defconfig" 15 file://defconfig"
diff --git a/recipes-kernel/linux/linux-omapl138-psp_2.6.37.bb b/recipes-kernel/linux/linux-omapl138-psp_2.6.37.bb
index 0b6c50db..e4a54513 100644
--- a/recipes-kernel/linux/linux-omapl138-psp_2.6.37.bb
+++ b/recipes-kernel/linux/linux-omapl138-psp_2.6.37.bb
@@ -5,8 +5,9 @@ KERNEL_IMAGETYPE = "uImage"
5 5
6require multi-kernel.inc 6require multi-kernel.inc
7require tipspkernel.inc 7require tipspkernel.inc
8require setup-defconfig.inc
8 9
9MACHINE_KERNEL_PR_append = "b" 10MACHINE_KERNEL_PR_append = "c"
10 11
11S = "${WORKDIR}/git" 12S = "${WORKDIR}/git"
12 13
diff --git a/recipes-kernel/linux/linux_3.3.7.bb b/recipes-kernel/linux/linux_3.3.7.bb
index 19280368..e38b6c2e 100644
--- a/recipes-kernel/linux/linux_3.3.7.bb
+++ b/recipes-kernel/linux/linux_3.3.7.bb
@@ -9,12 +9,13 @@ DEFAULT_PREFERENCE = "-1"
9COMPATIBLE_MACHINE = "beagleboard" 9COMPATIBLE_MACHINE = "beagleboard"
10 10
11inherit kernel 11inherit kernel
12require setup-defconfig.inc
12 13
13KERNEL_IMAGETYPE = "uImage" 14KERNEL_IMAGETYPE = "uImage"
14 15
15# The main PR is now using MACHINE_KERNEL_PR, for beagleboard see 16# The main PR is now using MACHINE_KERNEL_PR, for beagleboard see
16# conf/machine/include/omap3.inc 17# conf/machine/include/omap3.inc
17MACHINE_KERNEL_PR_append = "a+gitr${SRCREV}" 18MACHINE_KERNEL_PR_append = "b+gitr${SRCREV}"
18 19
19BRANCH = "linux-3.3.y" 20BRANCH = "linux-3.3.y"
20SRCREV = "v3.3.7" 21SRCREV = "v3.3.7"