summaryrefslogtreecommitdiffstats
path: root/recipes-kernel
diff options
context:
space:
mode:
authorChase Maupin <Chase.Maupin@ti.com>2013-03-11 15:03:35 -0500
committerDenys Dmytriyenko <denys@ti.com>2013-03-11 17:17:40 -0400
commitafa0c625717b1d8a43f6da6d760840e024378c4c (patch)
treea7b9bc5a04bca67c6d1ed9573513e89dcc2a68d1 /recipes-kernel
parent54d48a8dd27fa749aee4d7e2edd0ba288a7088de (diff)
downloadmeta-ti-afa0c625717b1d8a43f6da6d760840e024378c4c.tar.gz
linux-ti-staging: fix DTB deploy steps
* Until the permanent fix can be picked up in oe-core fix the do_deploy function to properly package the dtb files built as part of the kernel build. Signed-off-by: Chase Maupin <Chase.Maupin@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/linux/linux-ti-staging_git.bb18
1 files changed, 17 insertions, 1 deletions
diff --git a/recipes-kernel/linux/linux-ti-staging_git.bb b/recipes-kernel/linux/linux-ti-staging_git.bb
index f6fa6d21..9ce507bb 100644
--- a/recipes-kernel/linux/linux-ti-staging_git.bb
+++ b/recipes-kernel/linux/linux-ti-staging_git.bb
@@ -5,6 +5,22 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
5KERNEL_IMAGETYPE = "uImage" 5KERNEL_IMAGETYPE = "uImage"
6 6
7inherit kernel 7inherit kernel
8
9# This function must be here BEFORE the require of linux-dtb.inc below.
10# There is a "bug" in the base kernel.bbclass that after it's do_deploy
11# step it does not return back to the ${S} directory but stays in the
12# DEPLOY_DIR. However, the do_deploy_append defined in linux-dtb.inc
13# assumes that it is being run in the ${S} directory. A patch is
14# being submitted to fix this issue by either changing the do_deploy
15# in the kernel.bbclass to do "cd -" as the last step or to add
16# "cd ${S}" as the first line of do_deploy in linux-dtb.inc and this
17# function can be removed once that change is available.
18# If the function is not placed BEFORE the require then the change
19# directory is not appended before the linux-dtb.inc changes.
20do_deploy_append() {
21 cd ${S}
22}
23
8require recipes-kernel/linux/linux-dtb.inc 24require recipes-kernel/linux/linux-dtb.inc
9require recipes-kernel/linux/setup-defconfig.inc 25require recipes-kernel/linux/setup-defconfig.inc
10 26
@@ -27,7 +43,7 @@ SRCREV = "d26595a42220789b81a9d243e2fc0837c7776360"
27PV = "3.8.2" 43PV = "3.8.2"
28 44
29# Append to the MACHINE_KERNEL_PR so that a new SRCREV will cause a rebuild 45# Append to the MACHINE_KERNEL_PR so that a new SRCREV will cause a rebuild
30MACHINE_KERNEL_PR_append = "c+gitr${SRCPV}" 46MACHINE_KERNEL_PR_append = "d+gitr${SRCPV}"
31 47
32SRC_URI = "git://gitorious.ti.com/ti-linux-kernel/ti-linux-kernel.git;protocol=git;branch=${BRANCH} \ 48SRC_URI = "git://gitorious.ti.com/ti-linux-kernel/ti-linux-kernel.git;protocol=git;branch=${BRANCH} \
33 file://defconfig \ 49 file://defconfig \