summaryrefslogtreecommitdiffstats
path: root/recipes-kernel
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2012-03-05 17:20:53 -0500
committerDenys Dmytriyenko <denys@ti.com>2012-03-07 16:38:54 -0500
commitaa24c8ba605c38aaa48d2ca7252fc71bfae755ee (patch)
tree1bd33784049e6fca8315fcf1b8f06ced476ff3e0 /recipes-kernel
parent43956e56dba61709a4b01bb4ed6c4a28cef19d30 (diff)
downloadmeta-ti-aa24c8ba605c38aaa48d2ca7252fc71bfae755ee.tar.gz
linux-omap4 3.1.0: patch to workaround installing FW images w/o subdirs
This fixes below error found on some distros (Gentoo and Fedora): *** No rule to make target `lib/firmware/./', needed by `lib/firmware/ti_3410.fw'. Stop. Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/linux/linux-omap4-3.1.0/0001-Makefile.fwinst-fix-install-breakage-for-FW-images-r.patch30
-rw-r--r--recipes-kernel/linux/linux-omap4_3.1.0.bb3
2 files changed, 32 insertions, 1 deletions
diff --git a/recipes-kernel/linux/linux-omap4-3.1.0/0001-Makefile.fwinst-fix-install-breakage-for-FW-images-r.patch b/recipes-kernel/linux/linux-omap4-3.1.0/0001-Makefile.fwinst-fix-install-breakage-for-FW-images-r.patch
new file mode 100644
index 00000000..74559155
--- /dev/null
+++ b/recipes-kernel/linux/linux-omap4-3.1.0/0001-Makefile.fwinst-fix-install-breakage-for-FW-images-r.patch
@@ -0,0 +1,30 @@
1From f6a15304bc2730ba091eb747c413d4ef4124565e Mon Sep 17 00:00:00 2001
2From: Denys Dmytriyenko <denys@ti.com>
3Date: Mon, 5 Mar 2012 16:34:53 -0500
4Subject: [PATCH] Makefile.fwinst: fix install breakage for FW images residing
5 in firmware/ dir
6
7This fixes below error found on some distros (Gentoo and Fedora):
8*** No rule to make target `lib/firmware/./', needed by `lib/firmware/ti_3410.fw'. Stop.
9
10Signed-off-by: Denys Dmytriyenko <denys@ti.com>
11---
12 scripts/Makefile.fwinst | 2 +-
13 1 files changed, 1 insertions(+), 1 deletions(-)
14
15diff --git a/scripts/Makefile.fwinst b/scripts/Makefile.fwinst
16index 6bf8e87..4d908d1 100644
17--- a/scripts/Makefile.fwinst
18+++ b/scripts/Makefile.fwinst
19@@ -27,7 +27,7 @@ endif
20 installed-mod-fw := $(addprefix $(INSTALL_FW_PATH)/,$(mod-fw))
21
22 installed-fw := $(addprefix $(INSTALL_FW_PATH)/,$(fw-shipped-all))
23-installed-fw-dirs := $(sort $(dir $(installed-fw))) $(INSTALL_FW_PATH)/.
24+installed-fw-dirs := $(sort $(dir $(installed-fw))) $(INSTALL_FW_PATH)/./
25
26 # Workaround for make < 3.81, where .SECONDEXPANSION doesn't work.
27 PHONY += $(INSTALL_FW_PATH)/$$(%) install-all-dirs
28--
291.7.8.5
30
diff --git a/recipes-kernel/linux/linux-omap4_3.1.0.bb b/recipes-kernel/linux/linux-omap4_3.1.0.bb
index ea1c26a6..3cc48bec 100644
--- a/recipes-kernel/linux/linux-omap4_3.1.0.bb
+++ b/recipes-kernel/linux/linux-omap4_3.1.0.bb
@@ -5,7 +5,7 @@ DEFAULT_PREFERENCE = "-1"
5require linux.inc 5require linux.inc
6 6
7# The main PR is now using MACHINE_KERNEL_PR, for omap4 see conf/machine/include/omap4.inc 7# The main PR is now using MACHINE_KERNEL_PR, for omap4 see conf/machine/include/omap4.inc
8#MACHINE_KERNEL_PR_append = "a" 8MACHINE_KERNEL_PR_append = "a"
9 9
10CORTEXA8FIXUP = "no" 10CORTEXA8FIXUP = "no"
11 11
@@ -13,6 +13,7 @@ CORTEXA8FIXUP = "no"
13SRCREV = "a5c60c099296fcfc0c8fa8085c40883971486512" 13SRCREV = "a5c60c099296fcfc0c8fa8085c40883971486512"
14 14
15SRC_URI = "git://dev.omapzoom.org/pub/scm/integration/kernel-ubuntu.git;protocol=git;branch=ti-ubuntu-3.1-1282 \ 15SRC_URI = "git://dev.omapzoom.org/pub/scm/integration/kernel-ubuntu.git;protocol=git;branch=ti-ubuntu-3.1-1282 \
16 file://0001-Makefile.fwinst-fix-install-breakage-for-FW-images-r.patch \
16 file://defconfig \ 17 file://defconfig \
17 " 18 "
18 19