summaryrefslogtreecommitdiffstats
path: root/recipes-kernel
diff options
context:
space:
mode:
authorChase Maupin <Chase.Maupin@ti.com>2013-03-11 15:03:32 -0500
committerDenys Dmytriyenko <denys@ti.com>2013-03-11 17:17:10 -0400
commit9646393ed82fb11c762d6e0dd7f59f36b79c347e (patch)
treecd73eb96b8605e0ab58d82b1384b13fa98f3c185 /recipes-kernel
parentb2946775880fd6c6d7c5c9ce61b1d4b47ebe59e9 (diff)
downloadmeta-ti-9646393ed82fb11c762d6e0dd7f59f36b79c347e.tar.gz
linux-ti-staging: use setup-defconfig
* Use the setup-defconfig.inc functionality to specify the in kernel tree defconfig file to use rather than hard coding it in the do_configure step. * This is to make it easier to modify which configs are use by other layers as well as supporting additional machines which may not use omap2plus_defconfig as needed. Signed-off-by: Chase Maupin <Chase.Maupin@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/linux/linux-ti-staging/defconfig1
-rw-r--r--recipes-kernel/linux/linux-ti-staging_git.bb15
2 files changed, 6 insertions, 10 deletions
diff --git a/recipes-kernel/linux/linux-ti-staging/defconfig b/recipes-kernel/linux/linux-ti-staging/defconfig
new file mode 100644
index 00000000..926b35a5
--- /dev/null
+++ b/recipes-kernel/linux/linux-ti-staging/defconfig
@@ -0,0 +1 @@
use-kernel-config=omap2plus_defconfig
diff --git a/recipes-kernel/linux/linux-ti-staging_git.bb b/recipes-kernel/linux/linux-ti-staging_git.bb
index 8cc7206a..25814099 100644
--- a/recipes-kernel/linux/linux-ti-staging_git.bb
+++ b/recipes-kernel/linux/linux-ti-staging_git.bb
@@ -6,6 +6,7 @@ KERNEL_IMAGETYPE = "uImage"
6 6
7inherit kernel 7inherit kernel
8require recipes-kernel/linux/linux-dtb.inc 8require recipes-kernel/linux/linux-dtb.inc
9require recipes-kernel/linux/setup-defconfig.inc
9 10
10# Stage the power management firmware before building the kernel 11# Stage the power management firmware before building the kernel
11DEPENDS += "am33x-cm3" 12DEPENDS += "am33x-cm3"
@@ -23,17 +24,11 @@ SRCREV = "d26595a42220789b81a9d243e2fc0837c7776360"
23PV = "3.8.2" 24PV = "3.8.2"
24 25
25# Append to the MACHINE_KERNEL_PR so that a new SRCREV will cause a rebuild 26# Append to the MACHINE_KERNEL_PR so that a new SRCREV will cause a rebuild
26MACHINE_KERNEL_PR_append = "a+gitr${SRCPV}" 27MACHINE_KERNEL_PR_append = "b+gitr${SRCPV}"
27 28
28SRC_URI = "git://gitorious.ti.com/ti-linux-kernel/ti-linux-kernel.git;protocol=git;branch=${BRANCH}" 29SRC_URI = "git://gitorious.ti.com/ti-linux-kernel/ti-linux-kernel.git;protocol=git;branch=${BRANCH} \
29 30 file://defconfig \
30do_setup_defconfig() { 31 "
31 :
32}
33
34do_configure() {
35 oe_runmake omap2plus_defconfig
36}
37 32
38# Copy the am33x-cm3 firmware if it is available 33# Copy the am33x-cm3 firmware if it is available
39do_compile_prepend() { 34do_compile_prepend() {