summaryrefslogtreecommitdiffstats
path: root/recipes-kernel
diff options
context:
space:
mode:
authorFathi Boudra <fathi.boudra@linaro.org>2017-03-18 14:39:41 +0000
committerDenys Dmytriyenko <denys@ti.com>2017-03-21 21:20:44 -0400
commit9bf6cbfcf9600a177cf49a9d1199e7c4fec00007 (patch)
treeee20dca325c4a560d20866b3167521f83616cd20 /recipes-kernel
parent5ec1fd675329e8ab8a2b0fea1dc5bfee9cd8de40 (diff)
downloadmeta-ti-9bf6cbfcf9600a177cf49a9d1199e7c4fec00007.tar.gz
kselftests: fix futex functional tests build
Recursive makefile is broken because it's using the same TARGETS variable as selftests topdir and prevent to build futex functional tests: make[2]: Nothing to be done for `all'. Rename the variable to F_TARGETS in the futex functional tests Makefile. Signed-off-by: Fathi Boudra <fathi.boudra@linaro.org> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/kselftests/kselftests_4.9.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/recipes-kernel/kselftests/kselftests_4.9.bb b/recipes-kernel/kselftests/kselftests_4.9.bb
index 6e8c2143..39188b01 100644
--- a/recipes-kernel/kselftests/kselftests_4.9.bb
+++ b/recipes-kernel/kselftests/kselftests_4.9.bb
@@ -59,6 +59,7 @@ do_configure () {
59 sed "s|^CC = .*||g" -i ${S}/tools/testing/selftests/memfd/Makefile 59 sed "s|^CC = .*||g" -i ${S}/tools/testing/selftests/memfd/Makefile
60 sed "s|^CC := .*||g" -i ${S}/tools/testing/selftests/powerpc/switch_endian/Makefile 60 sed "s|^CC := .*||g" -i ${S}/tools/testing/selftests/powerpc/switch_endian/Makefile
61 sed "s|gcc|\$(CC)|g" -i ${S}/tools/testing/selftests/breakpoints/Makefile 61 sed "s|gcc|\$(CC)|g" -i ${S}/tools/testing/selftests/breakpoints/Makefile
62 sed "s|TARGETS|F_TARGETS|g" -i ${S}/tools/testing/selftests/futex/functional/Makefile
62 sed "s|^LDFLAGS += -lpthread|LDLIBS += -lpthread|g" -i ${S}/tools/testing/selftests/seccomp/Makefile 63 sed "s|^LDFLAGS += -lpthread|LDLIBS += -lpthread|g" -i ${S}/tools/testing/selftests/seccomp/Makefile
63 sed "s|^LDFLAGS += -lrt -lpthread|LDLIBS += -lrt -lpthread|g" -i ${S}/tools/testing/selftests/timers/Makefile 64 sed "s|^LDFLAGS += -lrt -lpthread|LDLIBS += -lrt -lpthread|g" -i ${S}/tools/testing/selftests/timers/Makefile
64 sed "s|BINARIES|TEST_PROGS|g" -i ${S}/tools/testing/selftests/sigaltstack/Makefile 65 sed "s|BINARIES|TEST_PROGS|g" -i ${S}/tools/testing/selftests/sigaltstack/Makefile