diff options
author | Koen Kooi <koen@dominion.thruhere.net> | 2011-10-10 14:29:25 +0200 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2011-10-10 14:29:25 +0200 |
commit | 7a45605f91536519a53e6f18dedee5f1f62d88e0 (patch) | |
tree | d0a657d02ee443ffffda3487b2e6c465ce80e0a4 /recipes-kernel | |
parent | 6f10600ca7c70d6e987f1e0d3a8f9560e52d5b01 (diff) | |
download | meta-ti-7a45605f91536519a53e6f18dedee5f1f62d88e0.tar.gz |
linux-am335x-joel 3.1rc: disable debug options like lockdep, switch to thumb2
Original: 3.7M /boot/uImage-3.1.0-rc3+
no debug: 3.4M /boot/uImage-3.1.0-rc3+
thumb2: 3.2M /boot/uImage-3.1.0-rc3+
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'recipes-kernel')
-rw-r--r-- | recipes-kernel/linux/linux-am335x-joel-3.1/defconfig | 67 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-am335x-joel_3.1.bb | 2 |
2 files changed, 27 insertions, 42 deletions
diff --git a/recipes-kernel/linux/linux-am335x-joel-3.1/defconfig b/recipes-kernel/linux/linux-am335x-joel-3.1/defconfig index 1fd6382b..93b060dd 100644 --- a/recipes-kernel/linux/linux-am335x-joel-3.1/defconfig +++ b/recipes-kernel/linux/linux-am335x-joel-3.1/defconfig | |||
@@ -66,7 +66,7 @@ CONFIG_GENERIC_HARDIRQS=y | |||
66 | CONFIG_HAVE_SPARSE_IRQ=y | 66 | CONFIG_HAVE_SPARSE_IRQ=y |
67 | CONFIG_GENERIC_IRQ_SHOW=y | 67 | CONFIG_GENERIC_IRQ_SHOW=y |
68 | CONFIG_GENERIC_IRQ_CHIP=y | 68 | CONFIG_GENERIC_IRQ_CHIP=y |
69 | # CONFIG_SPARSE_IRQ is not set | 69 | CONFIG_SPARSE_IRQ=y |
70 | 70 | ||
71 | # | 71 | # |
72 | # RCU Subsystem | 72 | # RCU Subsystem |
@@ -117,7 +117,7 @@ CONFIG_SYSCTL=y | |||
117 | CONFIG_ANON_INODES=y | 117 | CONFIG_ANON_INODES=y |
118 | CONFIG_EXPERT=y | 118 | CONFIG_EXPERT=y |
119 | CONFIG_UID16=y | 119 | CONFIG_UID16=y |
120 | # CONFIG_SYSCTL_SYSCALL is not set | 120 | CONFIG_SYSCTL_SYSCALL=y |
121 | CONFIG_KALLSYMS=y | 121 | CONFIG_KALLSYMS=y |
122 | CONFIG_KALLSYMS_ALL=y | 122 | CONFIG_KALLSYMS_ALL=y |
123 | CONFIG_HOTPLUG=y | 123 | CONFIG_HOTPLUG=y |
@@ -132,7 +132,7 @@ CONFIG_TIMERFD=y | |||
132 | CONFIG_EVENTFD=y | 132 | CONFIG_EVENTFD=y |
133 | CONFIG_SHMEM=y | 133 | CONFIG_SHMEM=y |
134 | CONFIG_AIO=y | 134 | CONFIG_AIO=y |
135 | # CONFIG_EMBEDDED is not set | 135 | CONFIG_EMBEDDED=y |
136 | CONFIG_HAVE_PERF_EVENTS=y | 136 | CONFIG_HAVE_PERF_EVENTS=y |
137 | CONFIG_PERF_USE_VMALLOC=y | 137 | CONFIG_PERF_USE_VMALLOC=y |
138 | 138 | ||
@@ -148,11 +148,9 @@ CONFIG_SLAB=y | |||
148 | # CONFIG_SLUB is not set | 148 | # CONFIG_SLUB is not set |
149 | # CONFIG_SLOB is not set | 149 | # CONFIG_SLOB is not set |
150 | CONFIG_PROFILING=y | 150 | CONFIG_PROFILING=y |
151 | CONFIG_TRACEPOINTS=y | ||
152 | CONFIG_OPROFILE=m | 151 | CONFIG_OPROFILE=m |
153 | CONFIG_HAVE_OPROFILE=y | 152 | CONFIG_HAVE_OPROFILE=y |
154 | CONFIG_KPROBES=y | 153 | # CONFIG_KPROBES is not set |
155 | CONFIG_KRETPROBES=y | ||
156 | CONFIG_HAVE_KPROBES=y | 154 | CONFIG_HAVE_KPROBES=y |
157 | CONFIG_HAVE_KRETPROBES=y | 155 | CONFIG_HAVE_KRETPROBES=y |
158 | CONFIG_HAVE_REGS_AND_STACK_ACCESS_API=y | 156 | CONFIG_HAVE_REGS_AND_STACK_ACCESS_API=y |
@@ -198,27 +196,27 @@ CONFIG_DEFAULT_IOSCHED="cfq" | |||
198 | # CONFIG_INLINE_SPIN_LOCK_BH is not set | 196 | # CONFIG_INLINE_SPIN_LOCK_BH is not set |
199 | # CONFIG_INLINE_SPIN_LOCK_IRQ is not set | 197 | # CONFIG_INLINE_SPIN_LOCK_IRQ is not set |
200 | # CONFIG_INLINE_SPIN_LOCK_IRQSAVE is not set | 198 | # CONFIG_INLINE_SPIN_LOCK_IRQSAVE is not set |
201 | # CONFIG_INLINE_SPIN_UNLOCK is not set | 199 | CONFIG_INLINE_SPIN_UNLOCK=y |
202 | # CONFIG_INLINE_SPIN_UNLOCK_BH is not set | 200 | # CONFIG_INLINE_SPIN_UNLOCK_BH is not set |
203 | # CONFIG_INLINE_SPIN_UNLOCK_IRQ is not set | 201 | CONFIG_INLINE_SPIN_UNLOCK_IRQ=y |
204 | # CONFIG_INLINE_SPIN_UNLOCK_IRQRESTORE is not set | 202 | # CONFIG_INLINE_SPIN_UNLOCK_IRQRESTORE is not set |
205 | # CONFIG_INLINE_READ_TRYLOCK is not set | 203 | # CONFIG_INLINE_READ_TRYLOCK is not set |
206 | # CONFIG_INLINE_READ_LOCK is not set | 204 | # CONFIG_INLINE_READ_LOCK is not set |
207 | # CONFIG_INLINE_READ_LOCK_BH is not set | 205 | # CONFIG_INLINE_READ_LOCK_BH is not set |
208 | # CONFIG_INLINE_READ_LOCK_IRQ is not set | 206 | # CONFIG_INLINE_READ_LOCK_IRQ is not set |
209 | # CONFIG_INLINE_READ_LOCK_IRQSAVE is not set | 207 | # CONFIG_INLINE_READ_LOCK_IRQSAVE is not set |
210 | # CONFIG_INLINE_READ_UNLOCK is not set | 208 | CONFIG_INLINE_READ_UNLOCK=y |
211 | # CONFIG_INLINE_READ_UNLOCK_BH is not set | 209 | # CONFIG_INLINE_READ_UNLOCK_BH is not set |
212 | # CONFIG_INLINE_READ_UNLOCK_IRQ is not set | 210 | CONFIG_INLINE_READ_UNLOCK_IRQ=y |
213 | # CONFIG_INLINE_READ_UNLOCK_IRQRESTORE is not set | 211 | # CONFIG_INLINE_READ_UNLOCK_IRQRESTORE is not set |
214 | # CONFIG_INLINE_WRITE_TRYLOCK is not set | 212 | # CONFIG_INLINE_WRITE_TRYLOCK is not set |
215 | # CONFIG_INLINE_WRITE_LOCK is not set | 213 | # CONFIG_INLINE_WRITE_LOCK is not set |
216 | # CONFIG_INLINE_WRITE_LOCK_BH is not set | 214 | # CONFIG_INLINE_WRITE_LOCK_BH is not set |
217 | # CONFIG_INLINE_WRITE_LOCK_IRQ is not set | 215 | # CONFIG_INLINE_WRITE_LOCK_IRQ is not set |
218 | # CONFIG_INLINE_WRITE_LOCK_IRQSAVE is not set | 216 | # CONFIG_INLINE_WRITE_LOCK_IRQSAVE is not set |
219 | # CONFIG_INLINE_WRITE_UNLOCK is not set | 217 | CONFIG_INLINE_WRITE_UNLOCK=y |
220 | # CONFIG_INLINE_WRITE_UNLOCK_BH is not set | 218 | # CONFIG_INLINE_WRITE_UNLOCK_BH is not set |
221 | # CONFIG_INLINE_WRITE_UNLOCK_IRQ is not set | 219 | CONFIG_INLINE_WRITE_UNLOCK_IRQ=y |
222 | # CONFIG_INLINE_WRITE_UNLOCK_IRQRESTORE is not set | 220 | # CONFIG_INLINE_WRITE_UNLOCK_IRQRESTORE is not set |
223 | # CONFIG_MUTEX_SPIN_ON_OWNER is not set | 221 | # CONFIG_MUTEX_SPIN_ON_OWNER is not set |
224 | CONFIG_FREEZER=y | 222 | CONFIG_FREEZER=y |
@@ -411,9 +409,10 @@ CONFIG_PREEMPT_NONE=y | |||
411 | # CONFIG_PREEMPT_VOLUNTARY is not set | 409 | # CONFIG_PREEMPT_VOLUNTARY is not set |
412 | # CONFIG_PREEMPT is not set | 410 | # CONFIG_PREEMPT is not set |
413 | CONFIG_HZ=100 | 411 | CONFIG_HZ=100 |
414 | # CONFIG_THUMB2_KERNEL is not set | 412 | CONFIG_THUMB2_KERNEL=y |
413 | CONFIG_THUMB2_AVOID_R_ARM_THM_JUMP11=y | ||
414 | CONFIG_ARM_ASM_UNIFIED=y | ||
415 | CONFIG_AEABI=y | 415 | CONFIG_AEABI=y |
416 | # CONFIG_OABI_COMPAT is not set | ||
417 | CONFIG_ARCH_HAS_HOLES_MEMORYMODEL=y | 416 | CONFIG_ARCH_HAS_HOLES_MEMORYMODEL=y |
418 | # CONFIG_ARCH_SPARSEMEM_DEFAULT is not set | 417 | # CONFIG_ARCH_SPARSEMEM_DEFAULT is not set |
419 | # CONFIG_ARCH_SELECT_MEMORY_MODEL is not set | 418 | # CONFIG_ARCH_SELECT_MEMORY_MODEL is not set |
@@ -425,7 +424,7 @@ CONFIG_FLATMEM=y | |||
425 | CONFIG_FLAT_NODE_MEM_MAP=y | 424 | CONFIG_FLAT_NODE_MEM_MAP=y |
426 | CONFIG_HAVE_MEMBLOCK=y | 425 | CONFIG_HAVE_MEMBLOCK=y |
427 | CONFIG_PAGEFLAGS_EXTENDED=y | 426 | CONFIG_PAGEFLAGS_EXTENDED=y |
428 | CONFIG_SPLIT_PTLOCK_CPUS=999999 | 427 | CONFIG_SPLIT_PTLOCK_CPUS=4 |
429 | # CONFIG_COMPACTION is not set | 428 | # CONFIG_COMPACTION is not set |
430 | # CONFIG_PHYS_ADDR_T_64BIT is not set | 429 | # CONFIG_PHYS_ADDR_T_64BIT is not set |
431 | CONFIG_ZONE_DMA_FLAG=0 | 430 | CONFIG_ZONE_DMA_FLAG=0 |
@@ -453,10 +452,9 @@ CONFIG_CMDLINE_FROM_BOOTLOADER=y | |||
453 | # CONFIG_CMDLINE_EXTEND is not set | 452 | # CONFIG_CMDLINE_EXTEND is not set |
454 | # CONFIG_CMDLINE_FORCE is not set | 453 | # CONFIG_CMDLINE_FORCE is not set |
455 | # CONFIG_XIP_KERNEL is not set | 454 | # CONFIG_XIP_KERNEL is not set |
456 | CONFIG_KEXEC=y | 455 | # CONFIG_KEXEC is not set |
457 | CONFIG_ATAGS_PROC=y | ||
458 | # CONFIG_CRASH_DUMP is not set | 456 | # CONFIG_CRASH_DUMP is not set |
459 | # CONFIG_AUTO_ZRELADDR is not set | 457 | CONFIG_AUTO_ZRELADDR=y |
460 | 458 | ||
461 | # | 459 | # |
462 | # CPU Power Management | 460 | # CPU Power Management |
@@ -707,8 +705,6 @@ CONFIG_DNS_RESOLVER=y | |||
707 | # Network testing | 705 | # Network testing |
708 | # | 706 | # |
709 | # CONFIG_NET_PKTGEN is not set | 707 | # CONFIG_NET_PKTGEN is not set |
710 | # CONFIG_NET_TCPPROBE is not set | ||
711 | # CONFIG_NET_DROP_MONITOR is not set | ||
712 | # CONFIG_HAMRADIO is not set | 708 | # CONFIG_HAMRADIO is not set |
713 | # CONFIG_CAN is not set | 709 | # CONFIG_CAN is not set |
714 | CONFIG_IRDA=m | 710 | CONFIG_IRDA=m |
@@ -3143,7 +3139,10 @@ CONFIG_DEBUG_KERNEL=y | |||
3143 | # CONFIG_DEBUG_SHIRQ is not set | 3139 | # CONFIG_DEBUG_SHIRQ is not set |
3144 | # CONFIG_LOCKUP_DETECTOR is not set | 3140 | # CONFIG_LOCKUP_DETECTOR is not set |
3145 | # CONFIG_HARDLOCKUP_DETECTOR is not set | 3141 | # CONFIG_HARDLOCKUP_DETECTOR is not set |
3146 | # CONFIG_DETECT_HUNG_TASK is not set | 3142 | CONFIG_DETECT_HUNG_TASK=y |
3143 | CONFIG_DEFAULT_HUNG_TASK_TIMEOUT=120 | ||
3144 | # CONFIG_BOOTPARAM_HUNG_TASK_PANIC is not set | ||
3145 | CONFIG_BOOTPARAM_HUNG_TASK_PANIC_VALUE=0 | ||
3147 | CONFIG_SCHED_DEBUG=y | 3146 | CONFIG_SCHED_DEBUG=y |
3148 | CONFIG_SCHEDSTATS=y | 3147 | CONFIG_SCHEDSTATS=y |
3149 | CONFIG_TIMER_STATS=y | 3148 | CONFIG_TIMER_STATS=y |
@@ -3152,24 +3151,18 @@ CONFIG_TIMER_STATS=y | |||
3152 | # CONFIG_DEBUG_KMEMLEAK is not set | 3151 | # CONFIG_DEBUG_KMEMLEAK is not set |
3153 | # CONFIG_DEBUG_RT_MUTEXES is not set | 3152 | # CONFIG_DEBUG_RT_MUTEXES is not set |
3154 | # CONFIG_RT_MUTEX_TESTER is not set | 3153 | # CONFIG_RT_MUTEX_TESTER is not set |
3155 | CONFIG_DEBUG_SPINLOCK=y | 3154 | # CONFIG_DEBUG_SPINLOCK is not set |
3156 | CONFIG_DEBUG_MUTEXES=y | 3155 | # CONFIG_DEBUG_MUTEXES is not set |
3157 | CONFIG_DEBUG_LOCK_ALLOC=y | 3156 | # CONFIG_DEBUG_LOCK_ALLOC is not set |
3158 | CONFIG_PROVE_LOCKING=y | 3157 | # CONFIG_PROVE_LOCKING is not set |
3159 | # CONFIG_PROVE_RCU is not set | ||
3160 | # CONFIG_SPARSE_RCU_POINTER is not set | 3158 | # CONFIG_SPARSE_RCU_POINTER is not set |
3161 | CONFIG_LOCKDEP=y | ||
3162 | # CONFIG_LOCK_STAT is not set | 3159 | # CONFIG_LOCK_STAT is not set |
3163 | # CONFIG_DEBUG_LOCKDEP is not set | ||
3164 | CONFIG_TRACE_IRQFLAGS=y | ||
3165 | # CONFIG_DEBUG_ATOMIC_SLEEP is not set | 3160 | # CONFIG_DEBUG_ATOMIC_SLEEP is not set |
3166 | # CONFIG_DEBUG_LOCKING_API_SELFTESTS is not set | 3161 | # CONFIG_DEBUG_LOCKING_API_SELFTESTS is not set |
3167 | CONFIG_STACKTRACE=y | ||
3168 | # CONFIG_DEBUG_STACK_USAGE is not set | 3162 | # CONFIG_DEBUG_STACK_USAGE is not set |
3169 | # CONFIG_DEBUG_KOBJECT is not set | 3163 | # CONFIG_DEBUG_KOBJECT is not set |
3170 | # CONFIG_DEBUG_BUGVERBOSE is not set | 3164 | # CONFIG_DEBUG_BUGVERBOSE is not set |
3171 | CONFIG_DEBUG_INFO=y | 3165 | # CONFIG_DEBUG_INFO is not set |
3172 | # CONFIG_DEBUG_INFO_REDUCED is not set | ||
3173 | # CONFIG_DEBUG_VM is not set | 3166 | # CONFIG_DEBUG_VM is not set |
3174 | # CONFIG_DEBUG_WRITECOUNT is not set | 3167 | # CONFIG_DEBUG_WRITECOUNT is not set |
3175 | # CONFIG_DEBUG_MEMORY_INIT is not set | 3168 | # CONFIG_DEBUG_MEMORY_INIT is not set |
@@ -3180,7 +3173,6 @@ CONFIG_DEBUG_INFO=y | |||
3180 | # CONFIG_DEBUG_CREDENTIALS is not set | 3173 | # CONFIG_DEBUG_CREDENTIALS is not set |
3181 | # CONFIG_BOOT_PRINTK_DELAY is not set | 3174 | # CONFIG_BOOT_PRINTK_DELAY is not set |
3182 | # CONFIG_RCU_TORTURE_TEST is not set | 3175 | # CONFIG_RCU_TORTURE_TEST is not set |
3183 | # CONFIG_KPROBES_SANITY_TEST is not set | ||
3184 | # CONFIG_BACKTRACE_SELF_TEST is not set | 3176 | # CONFIG_BACKTRACE_SELF_TEST is not set |
3185 | # CONFIG_DEBUG_BLOCK_EXT_DEVT is not set | 3177 | # CONFIG_DEBUG_BLOCK_EXT_DEVT is not set |
3186 | # CONFIG_DEBUG_FORCE_WEAK_PER_CPU is not set | 3178 | # CONFIG_DEBUG_FORCE_WEAK_PER_CPU is not set |
@@ -3189,18 +3181,12 @@ CONFIG_DEBUG_INFO=y | |||
3189 | # CONFIG_LATENCYTOP is not set | 3181 | # CONFIG_LATENCYTOP is not set |
3190 | # CONFIG_SYSCTL_SYSCALL_CHECK is not set | 3182 | # CONFIG_SYSCTL_SYSCALL_CHECK is not set |
3191 | # CONFIG_DEBUG_PAGEALLOC is not set | 3183 | # CONFIG_DEBUG_PAGEALLOC is not set |
3192 | CONFIG_NOP_TRACER=y | ||
3193 | CONFIG_HAVE_FUNCTION_TRACER=y | 3184 | CONFIG_HAVE_FUNCTION_TRACER=y |
3194 | CONFIG_HAVE_FUNCTION_GRAPH_TRACER=y | ||
3195 | CONFIG_HAVE_DYNAMIC_FTRACE=y | 3185 | CONFIG_HAVE_DYNAMIC_FTRACE=y |
3196 | CONFIG_HAVE_FTRACE_MCOUNT_RECORD=y | 3186 | CONFIG_HAVE_FTRACE_MCOUNT_RECORD=y |
3197 | CONFIG_HAVE_C_RECORDMCOUNT=y | 3187 | CONFIG_HAVE_C_RECORDMCOUNT=y |
3198 | CONFIG_RING_BUFFER=y | 3188 | CONFIG_RING_BUFFER=y |
3199 | CONFIG_EVENT_TRACING=y | ||
3200 | CONFIG_EVENT_POWER_TRACING_DEPRECATED=y | ||
3201 | CONFIG_CONTEXT_SWITCH_TRACER=y | ||
3202 | CONFIG_RING_BUFFER_ALLOW_SWAP=y | 3189 | CONFIG_RING_BUFFER_ALLOW_SWAP=y |
3203 | CONFIG_TRACING=y | ||
3204 | CONFIG_TRACING_SUPPORT=y | 3190 | CONFIG_TRACING_SUPPORT=y |
3205 | CONFIG_FTRACE=y | 3191 | CONFIG_FTRACE=y |
3206 | # CONFIG_FUNCTION_TRACER is not set | 3192 | # CONFIG_FUNCTION_TRACER is not set |
@@ -3212,7 +3198,6 @@ CONFIG_BRANCH_PROFILE_NONE=y | |||
3212 | # CONFIG_PROFILE_ALL_BRANCHES is not set | 3198 | # CONFIG_PROFILE_ALL_BRANCHES is not set |
3213 | # CONFIG_STACK_TRACER is not set | 3199 | # CONFIG_STACK_TRACER is not set |
3214 | # CONFIG_BLK_DEV_IO_TRACE is not set | 3200 | # CONFIG_BLK_DEV_IO_TRACE is not set |
3215 | CONFIG_KPROBE_EVENT=y | ||
3216 | # CONFIG_RING_BUFFER_BENCHMARK is not set | 3201 | # CONFIG_RING_BUFFER_BENCHMARK is not set |
3217 | # CONFIG_DYNAMIC_DEBUG is not set | 3202 | # CONFIG_DYNAMIC_DEBUG is not set |
3218 | # CONFIG_DMA_API_DEBUG is not set | 3203 | # CONFIG_DMA_API_DEBUG is not set |
@@ -3354,7 +3339,7 @@ CONFIG_CRYPTO_LZO=y | |||
3354 | CONFIG_CRYPTO_HW=y | 3339 | CONFIG_CRYPTO_HW=y |
3355 | # CONFIG_CRYPTO_DEV_OMAP_SHAM is not set | 3340 | # CONFIG_CRYPTO_DEV_OMAP_SHAM is not set |
3356 | # CONFIG_CRYPTO_DEV_OMAP_AES is not set | 3341 | # CONFIG_CRYPTO_DEV_OMAP_AES is not set |
3357 | CONFIG_BINARY_PRINTF=y | 3342 | # CONFIG_BINARY_PRINTF is not set |
3358 | 3343 | ||
3359 | # | 3344 | # |
3360 | # Library routines | 3345 | # Library routines |
diff --git a/recipes-kernel/linux/linux-am335x-joel_3.1.bb b/recipes-kernel/linux/linux-am335x-joel_3.1.bb index 75c2553c..fe99dd23 100644 --- a/recipes-kernel/linux/linux-am335x-joel_3.1.bb +++ b/recipes-kernel/linux/linux-am335x-joel_3.1.bb | |||
@@ -8,7 +8,7 @@ COMPATIBLE_MACHINE = "beaglebone" | |||
8 | SRCREV = "d3a2a2a1426ec59fcba80bf400e3261b2a3108c2" | 8 | SRCREV = "d3a2a2a1426ec59fcba80bf400e3261b2a3108c2" |
9 | 9 | ||
10 | # The main PR is now using MACHINE_KERNEL_PR, for omap3 see conf/machine/include/omap3.inc | 10 | # The main PR is now using MACHINE_KERNEL_PR, for omap3 see conf/machine/include/omap3.inc |
11 | MACHINE_KERNEL_PR_append = "c+gitr${SRCREV}" | 11 | MACHINE_KERNEL_PR_append = "d+gitr${SRCREV}" |
12 | 12 | ||
13 | SRC_URI = "git://github.com/joelagnel/linux-omap-2.6.git;branch=kernel-3.1-psp \ | 13 | SRC_URI = "git://github.com/joelagnel/linux-omap-2.6.git;branch=kernel-3.1-psp \ |
14 | file://0001-f_rndis-HACK-around-undefined-variables.patch \ | 14 | file://0001-f_rndis-HACK-around-undefined-variables.patch \ |