diff options
author | Koen Kooi <koen@dominion.thruhere.net> | 2011-07-27 13:44:48 +0200 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2011-07-27 13:45:13 +0200 |
commit | f9d0cf6e84f099d2f102a412ab168311956196f9 (patch) | |
tree | 6486759665f8b40fbbc2d538ac38bf1de65d76af /recipes-kernel | |
parent | 93fa61d9be18f644137864def4d4dc68a5f6e400 (diff) | |
download | meta-ti-f9d0cf6e84f099d2f102a412ab168311956196f9.tar.gz |
linux 3.0: add patch to fix SGX driver
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'recipes-kernel')
-rw-r--r-- | recipes-kernel/linux/linux-3.0/sgx/0001-ARM-L2-Add-and-export-outer_clean_all.patch | 67 | ||||
-rw-r--r-- | recipes-kernel/linux/linux_3.0.bb | 4 |
2 files changed, 70 insertions, 1 deletions
diff --git a/recipes-kernel/linux/linux-3.0/sgx/0001-ARM-L2-Add-and-export-outer_clean_all.patch b/recipes-kernel/linux/linux-3.0/sgx/0001-ARM-L2-Add-and-export-outer_clean_all.patch new file mode 100644 index 00000000..e6ce25bd --- /dev/null +++ b/recipes-kernel/linux/linux-3.0/sgx/0001-ARM-L2-Add-and-export-outer_clean_all.patch | |||
@@ -0,0 +1,67 @@ | |||
1 | From b230bde61ea3cf8e1a55b031d08d173417337a64 Mon Sep 17 00:00:00 2001 | ||
2 | From: Vikram Pandita <vikram.pandita@ti.com> | ||
3 | Date: Tue, 31 May 2011 09:24:58 +0100 | ||
4 | Subject: [PATCH] ARM: L2: Add and export outer_clean_all | ||
5 | |||
6 | The Errata 588369 and 539766 demands that clean all operation be done | ||
7 | as clean each way at a time | ||
8 | |||
9 | This patch also raps the implementation under the CONFIG errata | ||
10 | macro so that for non-errata version silicon it can be disabled | ||
11 | |||
12 | Signed-off-by: Vikram Pandita <vikram.pandita@ti.com> | ||
13 | Cc: Santosh Shilimkar <santosh.shilimkar@ti.com> | ||
14 | Cc: Woodruff, Richard <r-woodruff2@ti.com> | ||
15 | --- | ||
16 | arch/arm/include/asm/outercache.h | 8 ++++++++ | ||
17 | arch/arm/mm/cache-l2x0.c | 1 + | ||
18 | 2 files changed, 9 insertions(+), 0 deletions(-) | ||
19 | |||
20 | diff --git a/arch/arm/include/asm/outercache.h b/arch/arm/include/asm/outercache.h | ||
21 | index d838743..fa8cbd8 100644 | ||
22 | --- a/arch/arm/include/asm/outercache.h | ||
23 | +++ b/arch/arm/include/asm/outercache.h | ||
24 | @@ -28,6 +28,7 @@ struct outer_cache_fns { | ||
25 | void (*clean_range)(unsigned long, unsigned long); | ||
26 | void (*flush_range)(unsigned long, unsigned long); | ||
27 | void (*flush_all)(void); | ||
28 | + void (*clean_all)(void); | ||
29 | void (*inv_all)(void); | ||
30 | void (*disable)(void); | ||
31 | #ifdef CONFIG_OUTER_CACHE_SYNC | ||
32 | @@ -61,6 +62,11 @@ static inline void outer_flush_all(void) | ||
33 | if (outer_cache.flush_all) | ||
34 | outer_cache.flush_all(); | ||
35 | } | ||
36 | +static inline void outer_clean_all(void) | ||
37 | +{ | ||
38 | + if (outer_cache.clean_all) | ||
39 | + outer_cache.clean_all(); | ||
40 | +} | ||
41 | |||
42 | static inline void outer_inv_all(void) | ||
43 | { | ||
44 | @@ -97,6 +103,8 @@ static inline void outer_sync(void) | ||
45 | #else | ||
46 | static inline void outer_sync(void) | ||
47 | { } | ||
48 | +static inline void outer_clean_all(void) | ||
49 | +{ } | ||
50 | #endif | ||
51 | |||
52 | #endif /* __ASM_OUTERCACHE_H */ | ||
53 | diff --git a/arch/arm/mm/cache-l2x0.c b/arch/arm/mm/cache-l2x0.c | ||
54 | index 44c0867..10b79d6 100644 | ||
55 | --- a/arch/arm/mm/cache-l2x0.c | ||
56 | +++ b/arch/arm/mm/cache-l2x0.c | ||
57 | @@ -346,6 +346,7 @@ void __init l2x0_init(void __iomem *base, __u32 aux_val, __u32 aux_mask) | ||
58 | outer_cache.inv_all = l2x0_inv_all; | ||
59 | outer_cache.disable = l2x0_disable; | ||
60 | outer_cache.set_debug = l2x0_set_debug; | ||
61 | + outer_cache.clean_all = l2x0_clean_all; | ||
62 | |||
63 | printk(KERN_INFO "%s cache controller enabled\n", type); | ||
64 | printk(KERN_INFO "l2x0: %d ways, CACHE_ID 0x%08x, AUX_CTRL 0x%08x, Cache size: %d B\n", | ||
65 | -- | ||
66 | 1.6.6.1 | ||
67 | |||
diff --git a/recipes-kernel/linux/linux_3.0.bb b/recipes-kernel/linux/linux_3.0.bb index 9244d5b2..ebca1267 100644 --- a/recipes-kernel/linux/linux_3.0.bb +++ b/recipes-kernel/linux/linux_3.0.bb | |||
@@ -9,7 +9,7 @@ COMPATIBLE_MACHINE = "(beagleboard)" | |||
9 | SRCREV_pn-${PN} = "02f8c6aee8df3cdc935e9bdd4f2d020306035dbe" | 9 | SRCREV_pn-${PN} = "02f8c6aee8df3cdc935e9bdd4f2d020306035dbe" |
10 | 10 | ||
11 | # The main PR is now using MACHINE_KERNEL_PR, for omap3 see conf/machine/include/omap3.inc | 11 | # The main PR is now using MACHINE_KERNEL_PR, for omap3 see conf/machine/include/omap3.inc |
12 | MACHINE_KERNEL_PR_append = "g" | 12 | MACHINE_KERNEL_PR_append = "h" |
13 | 13 | ||
14 | FILESPATHPKG_prepend = "linux-3.0:" | 14 | FILESPATHPKG_prepend = "linux-3.0:" |
15 | 15 | ||
@@ -199,6 +199,8 @@ SRC_URI += "git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git;pro | |||
199 | file://madc/0002-mfd-twl-core-enable-madc-clock.patch \ | 199 | file://madc/0002-mfd-twl-core-enable-madc-clock.patch \ |
200 | \ | 200 | \ |
201 | file://sakoman/0001-mmc-don-t-display-single-block-read-console-messages.patch \ | 201 | file://sakoman/0001-mmc-don-t-display-single-block-read-console-messages.patch \ |
202 | \ | ||
203 | file://sgx/0001-ARM-L2-Add-and-export-outer_clean_all.patch \ | ||
202 | file://defconfig" | 204 | file://defconfig" |
203 | 205 | ||
204 | SRC_URI_append_beagleboard = " file://logo_linux_clut224.ppm \ | 206 | SRC_URI_append_beagleboard = " file://logo_linux_clut224.ppm \ |