diff options
author | Koen Kooi <koen@dominion.thruhere.net> | 2011-08-22 22:41:18 +0200 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2011-08-22 22:41:18 +0200 |
commit | 1e58e809753a45191c1e99c207598a461e75488e (patch) | |
tree | 6d90ade470f6d2c664f15a682c2abcc151e13853 /recipes-kernel | |
parent | f374a3ec157a62f3d8bf126779db056efa20d6ed (diff) | |
download | meta-ti-1e58e809753a45191c1e99c207598a461e75488e.tar.gz |
linux 3.0: fix uLCD poweron for beagleboard
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'recipes-kernel')
-rw-r--r-- | recipes-kernel/linux/linux-3.0/ulcd/0001-omap2-displays-Add-support-for-ThreeFiveCorp-S9700-D.patch | 4 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-3.0/ulcd/0002-omap3-beagle-added-lcd-driver.patch | 4 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-3.0/ulcd/0003-lcd-Set-LCD-power-enable-GPIO-in-board-file.patch | 49 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-3.0/ulcd/0004-Make-fbset-show-correct-timing-values.patch (renamed from recipes-kernel/linux/linux-3.0/ulcd/0003-Make-fbset-show-correct-timing-values.patch) | 4 | ||||
-rw-r--r-- | recipes-kernel/linux/linux_3.0.bb | 5 |
5 files changed, 58 insertions, 8 deletions
diff --git a/recipes-kernel/linux/linux-3.0/ulcd/0001-omap2-displays-Add-support-for-ThreeFiveCorp-S9700-D.patch b/recipes-kernel/linux/linux-3.0/ulcd/0001-omap2-displays-Add-support-for-ThreeFiveCorp-S9700-D.patch index 6912aa21..926398d1 100644 --- a/recipes-kernel/linux/linux-3.0/ulcd/0001-omap2-displays-Add-support-for-ThreeFiveCorp-S9700-D.patch +++ b/recipes-kernel/linux/linux-3.0/ulcd/0001-omap2-displays-Add-support-for-ThreeFiveCorp-S9700-D.patch | |||
@@ -1,7 +1,7 @@ | |||
1 | From 1890f67c9114d6fdf7696d6fa4eef62b1d7f74c4 Mon Sep 17 00:00:00 2001 | 1 | From 364e5e30ff9257f1bac68d7f30f3e7f51e8b1bfc Mon Sep 17 00:00:00 2001 |
2 | From: Roger Monk <r-monk@ti.com> | 2 | From: Roger Monk <r-monk@ti.com> |
3 | Date: Wed, 10 Aug 2011 16:54:34 +0200 | 3 | Date: Wed, 10 Aug 2011 16:54:34 +0200 |
4 | Subject: [PATCH 1/3] omap2-displays: Add support for ThreeFiveCorp S9700 Display | 4 | Subject: [PATCH 1/4] omap2-displays: Add support for ThreeFiveCorp S9700 Display |
5 | 5 | ||
6 | * Add support for s9700rtwv35tr01b display panel | 6 | * Add support for s9700rtwv35tr01b display panel |
7 | * This is used on BeagleBoardToys ULCD/-lite daugtercards | 7 | * This is used on BeagleBoardToys ULCD/-lite daugtercards |
diff --git a/recipes-kernel/linux/linux-3.0/ulcd/0002-omap3-beagle-added-lcd-driver.patch b/recipes-kernel/linux/linux-3.0/ulcd/0002-omap3-beagle-added-lcd-driver.patch index 8eea97df..a0d3b3c1 100644 --- a/recipes-kernel/linux/linux-3.0/ulcd/0002-omap3-beagle-added-lcd-driver.patch +++ b/recipes-kernel/linux/linux-3.0/ulcd/0002-omap3-beagle-added-lcd-driver.patch | |||
@@ -1,7 +1,7 @@ | |||
1 | From 807d261326e06903007c95457d6934588a483be0 Mon Sep 17 00:00:00 2001 | 1 | From 6b0587615fd0099261d049be17f12eae9f92ae85 Mon Sep 17 00:00:00 2001 |
2 | From: Jason Kridner <jkridner@beagleboard.org> | 2 | From: Jason Kridner <jkridner@beagleboard.org> |
3 | Date: Fri, 5 Aug 2011 18:07:09 +0000 | 3 | Date: Fri, 5 Aug 2011 18:07:09 +0000 |
4 | Subject: [PATCH 2/3] omap3: beagle: added lcd driver | 4 | Subject: [PATCH 2/4] omap3: beagle: added lcd driver |
5 | 5 | ||
6 | This enables the tfc_s9700_panel by default. Needs to be extended to | 6 | This enables the tfc_s9700_panel by default. Needs to be extended to |
7 | redefine the driver name at boot time. | 7 | redefine the driver name at boot time. |
diff --git a/recipes-kernel/linux/linux-3.0/ulcd/0003-lcd-Set-LCD-power-enable-GPIO-in-board-file.patch b/recipes-kernel/linux/linux-3.0/ulcd/0003-lcd-Set-LCD-power-enable-GPIO-in-board-file.patch new file mode 100644 index 00000000..ccc510f0 --- /dev/null +++ b/recipes-kernel/linux/linux-3.0/ulcd/0003-lcd-Set-LCD-power-enable-GPIO-in-board-file.patch | |||
@@ -0,0 +1,49 @@ | |||
1 | From 4b175ec2e08d1fa4a0bbaeb79ee2381164572fba Mon Sep 17 00:00:00 2001 | ||
2 | From: Joel A Fernandes <agnel.joel@gmail.com> | ||
3 | Date: Thu, 18 Aug 2011 16:19:40 -0500 | ||
4 | Subject: [PATCH 3/4] lcd: Set LCD power-enable GPIO in board file | ||
5 | |||
6 | With this, the ULCD-lite display works with the 3.0 kernel | ||
7 | |||
8 | v2 changes: | ||
9 | Fixed the beagle_config structure | ||
10 | |||
11 | Signed-off-by: Joel A Fernandes <agnel.joel@gmail.com> | ||
12 | --- | ||
13 | arch/arm/mach-omap2/board-omap3beagle.c | 7 +++++++ | ||
14 | 1 files changed, 7 insertions(+), 0 deletions(-) | ||
15 | |||
16 | diff --git a/arch/arm/mach-omap2/board-omap3beagle.c b/arch/arm/mach-omap2/board-omap3beagle.c | ||
17 | index b525a5e..6b0afda 100644 | ||
18 | --- a/arch/arm/mach-omap2/board-omap3beagle.c | ||
19 | +++ b/arch/arm/mach-omap2/board-omap3beagle.c | ||
20 | @@ -85,12 +85,14 @@ static struct { | ||
21 | int reset_gpio; | ||
22 | int usr_button_gpio; | ||
23 | char *lcd_driver_name; | ||
24 | + int lcd_pwren; | ||
25 | } beagle_config = { | ||
26 | .mmc1_gpio_wp = -EINVAL, | ||
27 | .usb_pwr_level = GPIOF_OUT_INIT_LOW, | ||
28 | .reset_gpio = 129, | ||
29 | .usr_button_gpio = 4, | ||
30 | .lcd_driver_name = "", | ||
31 | + .lcd_pwren = 156 | ||
32 | }; | ||
33 | |||
34 | static struct gpio omap3_beagle_rev_gpios[] __initdata = { | ||
35 | @@ -423,6 +425,11 @@ static void __init beagle_display_init(void) | ||
36 | { | ||
37 | int r; | ||
38 | |||
39 | + r = gpio_request_one(beagle_config.lcd_pwren, GPIOF_OUT_INIT_LOW, | ||
40 | + "LCD power"); | ||
41 | + if (r < 0) | ||
42 | + printk(KERN_ERR "Unable to get LCD power enable GPIO\n"); | ||
43 | + | ||
44 | r = gpio_request_one(beagle_dvi_device.reset_gpio, GPIOF_OUT_INIT_LOW, | ||
45 | "DVI reset"); | ||
46 | if (r < 0) | ||
47 | -- | ||
48 | 1.6.6.1 | ||
49 | |||
diff --git a/recipes-kernel/linux/linux-3.0/ulcd/0003-Make-fbset-show-correct-timing-values.patch b/recipes-kernel/linux/linux-3.0/ulcd/0004-Make-fbset-show-correct-timing-values.patch index e362c595..fb37e96a 100644 --- a/recipes-kernel/linux/linux-3.0/ulcd/0003-Make-fbset-show-correct-timing-values.patch +++ b/recipes-kernel/linux/linux-3.0/ulcd/0004-Make-fbset-show-correct-timing-values.patch | |||
@@ -1,7 +1,7 @@ | |||
1 | From cddc76248e1bec4d8cd345c72fcb0ff7c0e22054 Mon Sep 17 00:00:00 2001 | 1 | From 1d70480dca0c7648f5f51fad5ffb0e191212615a Mon Sep 17 00:00:00 2001 |
2 | From: Joel A Fernandes <agnel.joel@gmail.com> | 2 | From: Joel A Fernandes <agnel.joel@gmail.com> |
3 | Date: Wed, 17 Aug 2011 00:28:49 -0500 | 3 | Date: Wed, 17 Aug 2011 00:28:49 -0500 |
4 | Subject: [PATCH 3/3] Make fbset show correct timing values | 4 | Subject: [PATCH 4/4] Make fbset show correct timing values |
5 | 5 | ||
6 | Signed-off-by: Joel A Fernandes <agnel.joel@gmail.com> | 6 | Signed-off-by: Joel A Fernandes <agnel.joel@gmail.com> |
7 | Cc: "Monk, Roger" <r-monk@ti.com> | 7 | Cc: "Monk, Roger" <r-monk@ti.com> |
diff --git a/recipes-kernel/linux/linux_3.0.bb b/recipes-kernel/linux/linux_3.0.bb index 5d559553..18f0b384 100644 --- a/recipes-kernel/linux/linux_3.0.bb +++ b/recipes-kernel/linux/linux_3.0.bb | |||
@@ -10,7 +10,7 @@ PV = "3.0.3" | |||
10 | SRCREV_pn-${PN} = "d31bf2883542cd3414674238f94123bd1d9c0b9f" | 10 | SRCREV_pn-${PN} = "d31bf2883542cd3414674238f94123bd1d9c0b9f" |
11 | 11 | ||
12 | # The main PR is now using MACHINE_KERNEL_PR, for omap3 see conf/machine/include/omap3.inc | 12 | # The main PR is now using MACHINE_KERNEL_PR, for omap3 see conf/machine/include/omap3.inc |
13 | MACHINE_KERNEL_PR_append = "a" | 13 | MACHINE_KERNEL_PR_append = "b" |
14 | 14 | ||
15 | FILESPATH =. "${FILE_DIRNAME}/linux-3.0:${FILE_DIRNAME}/linux-3.0/${MACHINE}:" | 15 | FILESPATH =. "${FILE_DIRNAME}/linux-3.0:${FILE_DIRNAME}/linux-3.0/${MACHINE}:" |
16 | 16 | ||
@@ -219,7 +219,8 @@ SRC_URI += "git://git.kernel.org/pub/scm/linux/kernel/git/stable/linux-3.0.y.git | |||
219 | \ | 219 | \ |
220 | file://ulcd/0001-omap2-displays-Add-support-for-ThreeFiveCorp-S9700-D.patch \ | 220 | file://ulcd/0001-omap2-displays-Add-support-for-ThreeFiveCorp-S9700-D.patch \ |
221 | file://ulcd/0002-omap3-beagle-added-lcd-driver.patch \ | 221 | file://ulcd/0002-omap3-beagle-added-lcd-driver.patch \ |
222 | file://ulcd/0003-Make-fbset-show-correct-timing-values.patch \ | 222 | file://ulcd/0003-lcd-Set-LCD-power-enable-GPIO-in-board-file.patch \ |
223 | file://ulcd/0004-Make-fbset-show-correct-timing-values.patch \ | ||
223 | \ | 224 | \ |
224 | file://omap4/0001-OMAP-Fix-linking-error-in-twl-common.c-for-OMAP2-3-4.patch \ | 225 | file://omap4/0001-OMAP-Fix-linking-error-in-twl-common.c-for-OMAP2-3-4.patch \ |
225 | \ | 226 | \ |