summaryrefslogtreecommitdiffstats
path: root/recipes-kernel
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2016-04-02 01:20:36 +0000
committerDenys Dmytriyenko <denys@ti.com>2016-04-01 15:22:53 -0400
commitc012770e13bd8aacda60d101b4fc4f33b910a3b4 (patch)
treec307bd83dc0940c3cd0e7b66088233cd18213ff2 /recipes-kernel
parent8bb3fd849c8a43a9f9a4b26b820fd8553e01e0c7 (diff)
downloadmeta-ti-c012770e13bd8aacda60d101b4fc4f33b910a3b4.tar.gz
linux-ti-staging: add latest 4.4 version
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/linux/linux-ti-staging-4.4/defconfig1
-rw-r--r--recipes-kernel/linux/linux-ti-staging-4.4/keystone/defconfig1
-rw-r--r--recipes-kernel/linux/linux-ti-staging-rt-4.4/defconfig1
-rw-r--r--recipes-kernel/linux/linux-ti-staging-rt-4.4/keystone/defconfig1
-rw-r--r--recipes-kernel/linux/linux-ti-staging-rt_4.4.bb9
-rw-r--r--recipes-kernel/linux/linux-ti-staging-systest-4.4/defconfig1
-rw-r--r--recipes-kernel/linux/linux-ti-staging-systest-4.4/keystone/defconfig1
-rw-r--r--recipes-kernel/linux/linux-ti-staging-systest_4.4.bb5
-rw-r--r--recipes-kernel/linux/linux-ti-staging_4.4.bb91
9 files changed, 111 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-ti-staging-4.4/defconfig b/recipes-kernel/linux/linux-ti-staging-4.4/defconfig
new file mode 100644
index 00000000..990e7f79
--- /dev/null
+++ b/recipes-kernel/linux/linux-ti-staging-4.4/defconfig
@@ -0,0 +1 @@
use-combined-config=ti_config_fragments/defconfig_fragment
diff --git a/recipes-kernel/linux/linux-ti-staging-4.4/keystone/defconfig b/recipes-kernel/linux/linux-ti-staging-4.4/keystone/defconfig
new file mode 100644
index 00000000..470cf114
--- /dev/null
+++ b/recipes-kernel/linux/linux-ti-staging-4.4/keystone/defconfig
@@ -0,0 +1 @@
use-combined-config=ti_config_fragments/multi_core_defconfig_fragment
diff --git a/recipes-kernel/linux/linux-ti-staging-rt-4.4/defconfig b/recipes-kernel/linux/linux-ti-staging-rt-4.4/defconfig
new file mode 100644
index 00000000..2091fca5
--- /dev/null
+++ b/recipes-kernel/linux/linux-ti-staging-rt-4.4/defconfig
@@ -0,0 +1 @@
use-combined-config=ti_config_fragments/rt_defconfig_fragment
diff --git a/recipes-kernel/linux/linux-ti-staging-rt-4.4/keystone/defconfig b/recipes-kernel/linux/linux-ti-staging-rt-4.4/keystone/defconfig
new file mode 100644
index 00000000..6d287533
--- /dev/null
+++ b/recipes-kernel/linux/linux-ti-staging-rt-4.4/keystone/defconfig
@@ -0,0 +1 @@
use-combined-config=ti_config_fragments/rt_multi_core_defconfig_fragment
diff --git a/recipes-kernel/linux/linux-ti-staging-rt_4.4.bb b/recipes-kernel/linux/linux-ti-staging-rt_4.4.bb
new file mode 100644
index 00000000..21b4392a
--- /dev/null
+++ b/recipes-kernel/linux/linux-ti-staging-rt_4.4.bb
@@ -0,0 +1,9 @@
1require linux-ti-staging_4.4.bb
2
3# Look in the generic major.minor directory for files
4# This will have priority over generic non-rt path
5FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}-4.4:"
6
7BRANCH = "ti-rt-linux-4.4.y"
8
9SRCREV = "0d355dc80c8c72d048c603c5e23d29a3d018c58b"
diff --git a/recipes-kernel/linux/linux-ti-staging-systest-4.4/defconfig b/recipes-kernel/linux/linux-ti-staging-systest-4.4/defconfig
new file mode 100644
index 00000000..cfe4f991
--- /dev/null
+++ b/recipes-kernel/linux/linux-ti-staging-systest-4.4/defconfig
@@ -0,0 +1 @@
use-combined-config=ti_config_fragments/system_test_defconfig_fragment
diff --git a/recipes-kernel/linux/linux-ti-staging-systest-4.4/keystone/defconfig b/recipes-kernel/linux/linux-ti-staging-systest-4.4/keystone/defconfig
new file mode 100644
index 00000000..68cfc252
--- /dev/null
+++ b/recipes-kernel/linux/linux-ti-staging-systest-4.4/keystone/defconfig
@@ -0,0 +1 @@
use-combined-config=ti_config_fragments/multi_core_system_test_defconfig_fragment
diff --git a/recipes-kernel/linux/linux-ti-staging-systest_4.4.bb b/recipes-kernel/linux/linux-ti-staging-systest_4.4.bb
new file mode 100644
index 00000000..d8e9779b
--- /dev/null
+++ b/recipes-kernel/linux/linux-ti-staging-systest_4.4.bb
@@ -0,0 +1,5 @@
1require linux-ti-staging_4.4.bb
2
3# Look in the generic major.minor directory for files
4# This will have priority over generic non-rt path
5FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}-4.4:"
diff --git a/recipes-kernel/linux/linux-ti-staging_4.4.bb b/recipes-kernel/linux/linux-ti-staging_4.4.bb
new file mode 100644
index 00000000..ffd074a0
--- /dev/null
+++ b/recipes-kernel/linux/linux-ti-staging_4.4.bb
@@ -0,0 +1,91 @@
1SECTION = "kernel"
2DESCRIPTION = "Linux kernel for TI devices"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
5
6inherit kernel
7
8require recipes-kernel/linux/linux-dtb.inc
9require recipes-kernel/linux/setup-defconfig.inc
10require recipes-kernel/linux/cmem.inc
11require recipes-kernel/linux/ti-uio.inc
12
13# Look in the generic major.minor directory for files
14FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}-4.4:"
15
16# Pull in the devicetree files into the rootfs
17RDEPENDS_kernel-base += "kernel-devicetree"
18
19# Add a run-time dependency for the PM firmware to be installed
20# on the target file system.
21RDEPENDS_kernel-base_append_ti33x = " amx3-cm3"
22RDEPENDS_kernel-base_append_ti43x = " amx3-cm3"
23
24# Add a run-time dependency for the VPE VPDMA firmware to be installed
25# on the target file system.
26RDEPENDS_kernel-base_append_dra7xx = " vpdma-fw"
27
28# Install boot-monitor skern file into /boot dir of rootfs
29RDEPENDS_kernel-base_append_keystone = " boot-monitor"
30
31# Install ti-sci-fw into /boot dir of rootfs
32RDEPENDS_kernel-base_append_k2g-evm = " ti-sci-fw"
33
34# Add run-time dependency for SerDes firmware to the rootfs
35RDEPENDS_kernel-base_append_keystone = " serdes-fw"
36
37# Add run-time dependency for NETCP PA firmware to the rootfs
38RDEPENDS_kernel-base_append_k2hk-evm = " netcp-pa-fw"
39RDEPENDS_kernel-base_append_k2e-evm = " netcp-pa-fw"
40RDEPENDS_kernel-base_append_k2l-evm = " netcp-pa-fw"
41
42# Add run-time dependency for PRU Ethernet firmware to the rootfs
43RDEPENDS_kernel-base_append_am57xx-evm = " prueth-fw"
44
45# Default is to package all dtb files for ti33x devices unless building
46# for the specific beaglebone machine.
47KERNEL_DEVICETREE_ti33x = "am335x-evm.dtb am335x-evmsk.dtb am335x-bone.dtb am335x-boneblack.dtb am335x-bonegreen.dtb"
48KERNEL_DEVICETREE_ti43x = "am43x-epos-evm.dtb am43x-epos-evm-hdmi.dtb am437x-gp-evm.dtb am437x-gp-evm-hdmi.dtb am437x-sk-evm.dtb am437x-idk-evm.dtb"
49KERNEL_DEVICETREE_beaglebone = "am335x-bone.dtb am335x-boneblack.dtb am335x-bonegreen.dtb"
50KERNEL_DEVICETREE_omap5-evm = "omap5-uevm.dtb"
51KERNEL_DEVICETREE_dra7xx-evm = "dra7-evm.dtb dra7-evm-lcd-lg.dtb dra7-evm-lcd-osd.dtb dra72-evm.dtb dra72-evm-revc.dtb dra72-evm-lcd-lg.dtb dra72-evm-lcd-osd.dtb"
52KERNEL_DEVICETREE_dra7xx-hs-evm = "${KERNEL_DEVICETREE_dra7xx-evm}"
53KERNEL_DEVICETREE_am57xx-evm = "am57xx-beagle-x15.dtb am57xx-beagle-x15-revb1.dtb am57xx-evm.dtb am57xx-evm-reva3.dtb am571x-idk.dtb am572x-idk.dtb"
54KERNEL_DEVICETREE_omap3 = "omap3-beagle.dtb omap3-beagle-xm.dtb omap3-beagle-xm-ab.dtb omap3-evm.dtb omap3-evm-37xx.dtb am3517-evm.dtb"
55KERNEL_DEVICETREE_am3517-evm = "am3517-evm.dtb"
56KERNEL_DEVICETREE_am37x-evm = "omap3-evm-37xx.dtb"
57KERNEL_DEVICETREE_beagleboard = "omap3-beagle.dtb omap3-beagle-xm.dtb omap3-beagle-xm-ab.dtb"
58KERNEL_DEVICETREE_pandaboard = "omap4-panda.dtb omap4-panda-a4.dtb omap4-panda-es.dtb"
59KERNEL_DEVICETREE_k2hk-evm = "keystone-k2hk-evm.dtb"
60KERNEL_DEVICETREE_k2e-evm = "keystone-k2e-evm.dtb"
61KERNEL_DEVICETREE_k2g-evm = "keystone-k2g-evm.dtb"
62KERNEL_DEVICETREE_k2l-evm = "keystone-k2l-evm.dtb"
63
64KERNEL_EXTRA_ARGS += "LOADADDR=${UBOOT_ENTRYPOINT}"
65
66COMPATIBLE_MACHINE = "ti33x|ti43x|omap-a15|omap3|omap4|keystone"
67
68S = "${WORKDIR}/git"
69
70BRANCH = "ti-lsk-linux-4.4.y"
71
72SRCREV = "08b8a2e93fac2471992ea3e110a3683a00f39d74"
73PV = "4.4.6+git${SRCPV}"
74
75# Append to the MACHINE_KERNEL_PR so that a new SRCREV will cause a rebuild
76MACHINE_KERNEL_PR_append = "a"
77PR = "${MACHINE_KERNEL_PR}"
78
79KERNEL_CONFIG_DIR = "${S}/ti_config_fragments"
80
81# SoC specific config fragments are not enabled yet
82KERNEL_CONFIG_FRAGMENTS_append_ti33x = " ${KERNEL_CONFIG_DIR}/am33xx_only.cfg"
83KERNEL_CONFIG_FRAGMENTS_append_ti43x = " ${KERNEL_CONFIG_DIR}/am43xx_only.cfg"
84KERNEL_CONFIG_FRAGMENTS_append_dra7xx = " ${KERNEL_CONFIG_DIR}/dra7_only.cfg"
85
86MULTI_CONFIG_BASE_SUFFIX = ""
87
88KERNEL_GIT_URI = "git://git.ti.com/ti-linux-kernel/ti-linux-kernel.git"
89KERNEL_GIT_PROTOCOL = "git"
90SRC_URI += "${KERNEL_GIT_URI};protocol=${KERNEL_GIT_PROTOCOL};branch=${BRANCH} \
91 file://defconfig"