summaryrefslogtreecommitdiffstats
path: root/recipes-kernel
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2012-01-18 19:30:43 -0800
committerKoen Kooi <koen@dominion.thruhere.net>2012-01-20 12:15:37 +0100
commit3b9c2d238b95f0f6e9da1036dc19daccdd152ad6 (patch)
tree05cf6a457fa9c964ec42576b2a7aff0b63eb97ae /recipes-kernel
parent8c36bbe1505559b9f7d46e6fd6e2cb606c99350a (diff)
downloadmeta-ti-3b9c2d238b95f0f6e9da1036dc19daccdd152ad6.tar.gz
linux-3.0: Fix perf compile failure with eglibc 2.15
There is a conflict with eglibc headers since new headers added the defines that compiler.h was redefining without undefining them Signed-off-by: Khem Raj <raj.khem@gmail.com> Acked-by: Denys Dmytriyenko <denys@ti.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/linux/linux-3.0/misc/0001-compiler.h-Undef-before-redefining-__attribute_const.patch31
-rwxr-xr-xrecipes-kernel/linux/linux-3.0/patch.sh2
-rw-r--r--recipes-kernel/linux/linux_3.0.bb4
3 files changed, 35 insertions, 2 deletions
diff --git a/recipes-kernel/linux/linux-3.0/misc/0001-compiler.h-Undef-before-redefining-__attribute_const.patch b/recipes-kernel/linux/linux-3.0/misc/0001-compiler.h-Undef-before-redefining-__attribute_const.patch
new file mode 100644
index 00000000..bf2f6e77
--- /dev/null
+++ b/recipes-kernel/linux/linux-3.0/misc/0001-compiler.h-Undef-before-redefining-__attribute_const.patch
@@ -0,0 +1,31 @@
1From 6f92ab6de9d8daeb575949bbbcbc7bcdcebc60af Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Thu, 5 Jan 2012 11:42:35 -0800
4Subject: [PATCH] compiler.h: Undef before redefining __attribute_const__
5
6This is required to avoid warnings like
7util/include/linux/compiler.h:8:0: error: "__attribute_const__" redefined [-Werror]
8
9Signed-off-by: Khem Raj <raj.khem@gmail.com>
10
11Upstream-Status: Pending
12
13---
14 tools/perf/util/include/linux/compiler.h | 4 +++-
15 1 files changed, 3 insertions(+), 1 deletions(-)
16
17--- a/tools/perf/util/include/linux/compiler.h
18+++ b/tools/perf/util/include/linux/compiler.h
19@@ -4,9 +4,11 @@
20 #ifndef __always_inline
21 #define __always_inline inline
22 #endif
23+#undef __user
24 #define __user
25+#undef __attribute_const__
26 #define __attribute_const__
27-
28+#undef __used
29 #define __used __attribute__((__unused__))
30
31 #endif
diff --git a/recipes-kernel/linux/linux-3.0/patch.sh b/recipes-kernel/linux/linux-3.0/patch.sh
index 885db093..dc19a9e5 100755
--- a/recipes-kernel/linux/linux-3.0/patch.sh
+++ b/recipes-kernel/linux/linux-3.0/patch.sh
@@ -13,7 +13,7 @@ git reset --hard ${TAG}
13rm export -rf 13rm export -rf
14 14
15previous=${TAG} 15previous=${TAG}
16PATCHSET="pm-wip/voltdm pm-wip/cpufreq beagle madc sakoman sgx ulcd omap4" 16PATCHSET="pm-wip/voltdm pm-wip/cpufreq beagle madc sakoman sgx ulcd omap4 misc"
17 17
18# apply patches 18# apply patches
19for patchset in ${PATCHSET} ; do 19for patchset in ${PATCHSET} ; do
diff --git a/recipes-kernel/linux/linux_3.0.bb b/recipes-kernel/linux/linux_3.0.bb
index 27963048..70ca7cc9 100644
--- a/recipes-kernel/linux/linux_3.0.bb
+++ b/recipes-kernel/linux/linux_3.0.bb
@@ -10,7 +10,7 @@ PV = "3.0.17"
10SRCREV_pn-${PN} = "e9d23be2708477feeaec78e707c80441520c1ef6" 10SRCREV_pn-${PN} = "e9d23be2708477feeaec78e707c80441520c1ef6"
11 11
12# The main PR is now using MACHINE_KERNEL_PR, for omap3 see conf/machine/include/omap3.inc 12# The main PR is now using MACHINE_KERNEL_PR, for omap3 see conf/machine/include/omap3.inc
13MACHINE_KERNEL_PR_append = "a" 13MACHINE_KERNEL_PR_append = "b"
14 14
15FILESPATH =. "${FILE_DIRNAME}/linux-3.0:${FILE_DIRNAME}/linux-3.0/${MACHINE}:" 15FILESPATH =. "${FILE_DIRNAME}/linux-3.0:${FILE_DIRNAME}/linux-3.0/${MACHINE}:"
16 16
@@ -221,6 +221,8 @@ SRC_URI += "git://git.kernel.org/pub/scm/linux/kernel/git/stable/linux-stable.gi
221 \ 221 \
222 file://omap4/0001-OMAP-Fix-linking-error-in-twl-common.c-for-OMAP2-3-4.patch \ 222 file://omap4/0001-OMAP-Fix-linking-error-in-twl-common.c-for-OMAP2-3-4.patch \
223 \ 223 \
224 file://misc/0001-compiler.h-Undef-before-redefining-__attribute_const.patch \
225 \
224 file://defconfig" 226 file://defconfig"
225 227
226SRC_URI_append_beagleboard = " file://logo_linux_clut224.ppm \ 228SRC_URI_append_beagleboard = " file://logo_linux_clut224.ppm \