diff options
author | Koen Kooi <koen@dominion.thruhere.net> | 2011-12-20 16:30:22 +0100 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2011-12-20 17:39:48 +0100 |
commit | c84b0511b3a1278ce6ea8efd423ce032f715a639 (patch) | |
tree | 9dd8e2367c739a653eb71e83b857dd3f750f5aa9 /recipes-kernel | |
parent | bf3813c19b824e75f3fddd5f24d06c59339c5e17 (diff) | |
download | meta-ti-c84b0511b3a1278ce6ea8efd423ce032f715a639.tar.gz |
linux-ti81xx-psp 2.6.37: update to match latest *SDK
Boot Tested on DM8148 EVM
Acked-by: Roger Monk <r-monk@ti.com>
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'recipes-kernel')
-rw-r--r-- | recipes-kernel/linux/linux-ti81xx-psp-2.6.37/0001-ti814x-added-code-for-disabling-the-least-significan.patch | 45 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-ti81xx-psp_2.6.37.bb | 9 |
2 files changed, 49 insertions, 5 deletions
diff --git a/recipes-kernel/linux/linux-ti81xx-psp-2.6.37/0001-ti814x-added-code-for-disabling-the-least-significan.patch b/recipes-kernel/linux/linux-ti81xx-psp-2.6.37/0001-ti814x-added-code-for-disabling-the-least-significan.patch new file mode 100644 index 00000000..c1f368d3 --- /dev/null +++ b/recipes-kernel/linux/linux-ti81xx-psp-2.6.37/0001-ti814x-added-code-for-disabling-the-least-significan.patch | |||
@@ -0,0 +1,45 @@ | |||
1 | From 1d43359e415cada4607d0d21b7de07c740616386 Mon Sep 17 00:00:00 2001 | ||
2 | From: Amarinder Bindra <a-bindra@ti.com> | ||
3 | Date: Wed, 7 Dec 2011 20:54:56 +0530 | ||
4 | Subject: [PATCH] ti814x: added code for disabling the least significant bit of TI814x_HDMI_MUX_ADDR before vps init | ||
5 | |||
6 | |||
7 | Signed-off-by: Amarinder Bindra <a-bindra@ti.com> | ||
8 | --- | ||
9 | drivers/video/ti81xx/vpss/core.c | 13 ++++++++++++- | ||
10 | 1 files changed, 12 insertions(+), 1 deletions(-) | ||
11 | |||
12 | diff --git a/drivers/video/ti81xx/vpss/core.c b/drivers/video/ti81xx/vpss/core.c | ||
13 | index eb9c074..80008b9 100644 | ||
14 | --- a/drivers/video/ti81xx/vpss/core.c | ||
15 | +++ b/drivers/video/ti81xx/vpss/core.c | ||
16 | @@ -41,7 +41,7 @@ | ||
17 | |||
18 | #define VPS_DRIVER_NAME "vpss" | ||
19 | |||
20 | - | ||
21 | +#define TI814x_HDMI_MUX_ADDR (0x481C52C8) | ||
22 | |||
23 | #ifdef DEBUG | ||
24 | unsigned int vpss_debug; | ||
25 | @@ -148,6 +148,17 @@ static int __init vps_init(void) | ||
26 | { | ||
27 | VPSSDBG("core init\n"); | ||
28 | |||
29 | + /* This mux is for configuring the pixel clock to Venc through HDMI or PLL*/ | ||
30 | + u32 reg_value; | ||
31 | + u32 reg_base; | ||
32 | + | ||
33 | + reg_base = (u32)ioremap(TI814x_HDMI_MUX_ADDR, 0x10); | ||
34 | + reg_value = __raw_readl(reg_base); | ||
35 | + reg_value &= 0xFFFFFFFE; | ||
36 | + | ||
37 | + __raw_writel(reg_value, reg_base); | ||
38 | + iounmap((u32 *)TI814x_HDMI_MUX_ADDR); | ||
39 | + | ||
40 | if (platform_driver_probe(&vps_driver, vps_probe)) { | ||
41 | VPSSERR("failed to register ti81xx-vpss driver\n"); | ||
42 | return -ENODEV; | ||
43 | -- | ||
44 | 1.7.1 | ||
45 | |||
diff --git a/recipes-kernel/linux/linux-ti81xx-psp_2.6.37.bb b/recipes-kernel/linux/linux-ti81xx-psp_2.6.37.bb index bae58b99..e5a38363 100644 --- a/recipes-kernel/linux/linux-ti81xx-psp_2.6.37.bb +++ b/recipes-kernel/linux/linux-ti81xx-psp_2.6.37.bb | |||
@@ -6,15 +6,14 @@ KERNEL_IMAGETYPE = "uImage" | |||
6 | COMPATIBLE_MACHINE = "am387x-evm|am389x-evm|c6a814x-evm|c6a816x-evm|dm814x-evm" | 6 | COMPATIBLE_MACHINE = "am387x-evm|am389x-evm|c6a814x-evm|c6a816x-evm|dm814x-evm" |
7 | 7 | ||
8 | # This is on the ti81xx-master branch | 8 | # This is on the ti81xx-master branch |
9 | SRCREV = "a02ce6137c1647009a17ecac35d846fe9479dded" | 9 | SRCREV = "745a06cb913ad7a9ab44855aa36d8c012cd5793b" |
10 | |||
11 | # requires .28 hdvpss: d686b2da5d2e7337c9759f910c3a665c27b0ec31 | ||
12 | 10 | ||
13 | # The main PR is now using MACHINE_KERNEL_PR, for omap3 see conf/machine/include/omap3.inc | 11 | # The main PR is now using MACHINE_KERNEL_PR, for omap3 see conf/machine/include/omap3.inc |
14 | MACHINE_KERNEL_PR_append = "d+gitr${SRCREV}" | 12 | MACHINE_KERNEL_PR_append = "a+gitr${SRCREV}" |
15 | 13 | ||
16 | SRC_URI += "git://arago-project.org/git/projects/linux-omap3.git;protocol=git;branch=ti81xx-master \ | 14 | SRC_URI += "git://arago-project.org/git/projects/linux-omap3.git;protocol=git;branch=ti81xx-master \ |
17 | file://defconfig" | 15 | file://0001-ti814x-added-code-for-disabling-the-least-significan.patch \ |
16 | file://defconfig" | ||
18 | 17 | ||
19 | S = "${WORKDIR}/git" | 18 | S = "${WORKDIR}/git" |
20 | 19 | ||