diff options
author | Denys Dmytriyenko <denys@ti.com> | 2014-04-26 05:41:01 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2014-05-06 18:10:26 -0400 |
commit | 788da6f205f69c959d03df390612f6c906caa1f4 (patch) | |
tree | a17132f0ea9942be9a7707a14f4ba4c46fc9c844 /recipes-kernel | |
parent | 58f0ba756b822a55975147f8d91e617c02dda0f1 (diff) | |
download | meta-ti-788da6f205f69c959d03df390612f6c906caa1f4.tar.gz |
linux-ti-staging: add baseport, connectivity, ipc and systest config fragments
Do not apply systest fragment by default on the production build.
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Reviewed-by: Chase Maupin <chase.maupin@ti.com>
Diffstat (limited to 'recipes-kernel')
-rw-r--r-- | recipes-kernel/linux/linux-ti-staging/baseport.cfg | 8 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-ti-staging/connectivity.cfg | 14 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-ti-staging/ipc.cfg | 18 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-ti-staging/systest.cfg | 20 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-ti-staging_3.12.bb | 8 |
5 files changed, 67 insertions, 1 deletions
diff --git a/recipes-kernel/linux/linux-ti-staging/baseport.cfg b/recipes-kernel/linux/linux-ti-staging/baseport.cfg new file mode 100644 index 00000000..8dc24af4 --- /dev/null +++ b/recipes-kernel/linux/linux-ti-staging/baseport.cfg | |||
@@ -0,0 +1,8 @@ | |||
1 | ################################################## | ||
2 | # Baseport Config Options | ||
3 | ################################################## | ||
4 | CONFIG_CRYPTO_HW=y | ||
5 | CONFIG_CRYPTO_DEV_OMAP_AES=y | ||
6 | CONFIG_CRYPTO_DEV_OMAP_SHAM=y | ||
7 | CONFIG_CRYPTO_TEST=m | ||
8 | CONFIG_CRYPTO_MANAGER_DISABLE_TESTS=n | ||
diff --git a/recipes-kernel/linux/linux-ti-staging/connectivity.cfg b/recipes-kernel/linux/linux-ti-staging/connectivity.cfg new file mode 100644 index 00000000..bf18daeb --- /dev/null +++ b/recipes-kernel/linux/linux-ti-staging/connectivity.cfg | |||
@@ -0,0 +1,14 @@ | |||
1 | ################################################## | ||
2 | # Connectivity Configs | ||
3 | ################################################## | ||
4 | CONFIG_MTD_NAND_OMAP_BCH=y | ||
5 | CONFIG_MTD_TESTS=m | ||
6 | CONFIG_SPI_SPIDEV=y | ||
7 | CONFIG_USB_TEST=m | ||
8 | CONFIG_USB_ACM=y | ||
9 | CONFIG_USB_SERIAL_PL2303=y | ||
10 | CONFIG_USB_PRINTER=y | ||
11 | CONFIG_USB_NET_AX8817X=y | ||
12 | CONFIG_USB_G_MULTI=m | ||
13 | CONFIG_USB_G_MULTI_RNDIS=y | ||
14 | CONFIG_USB_G_MULTI_CDC=y | ||
diff --git a/recipes-kernel/linux/linux-ti-staging/ipc.cfg b/recipes-kernel/linux/linux-ti-staging/ipc.cfg new file mode 100644 index 00000000..645dfdfa --- /dev/null +++ b/recipes-kernel/linux/linux-ti-staging/ipc.cfg | |||
@@ -0,0 +1,18 @@ | |||
1 | ################################################## | ||
2 | # IPC config options | ||
3 | ################################################## | ||
4 | CONFIG_IOMMU_API=y | ||
5 | CONFIG_IOMMU_SUPPORT=y | ||
6 | CONFIG_OF_IOMMU=y | ||
7 | CONFIG_OMAP_IOMMU=y | ||
8 | CONFIG_OMAP_IOVMM=y | ||
9 | CONFIG_OMAP_IOMMU_DEBUG=y | ||
10 | CONFIG_VIRTIO=m | ||
11 | CONFIG_RPMSG=m | ||
12 | CONFIG_RPMSG_RPC=m | ||
13 | CONFIG_REMOTEPROC=m | ||
14 | CONFIG_OMAP_REMOTEPROC=m | ||
15 | CONFIG_OMAP_REMOTEPROC_IPU=y | ||
16 | CONFIG_OMAP_REMOTEPROC_DSP=y | ||
17 | CONFIG_OMAP_REMOTEPROC_IPU1=y | ||
18 | CONFIG_OMAP_REMOTEPROC_DSP2=y | ||
diff --git a/recipes-kernel/linux/linux-ti-staging/systest.cfg b/recipes-kernel/linux/linux-ti-staging/systest.cfg new file mode 100644 index 00000000..e21602f4 --- /dev/null +++ b/recipes-kernel/linux/linux-ti-staging/systest.cfg | |||
@@ -0,0 +1,20 @@ | |||
1 | ################################################## | ||
2 | # Systest config options | ||
3 | ################################################## | ||
4 | CONFIG_DEBUG_SPINLOCK=y | ||
5 | CONFIG_DEBUG_MUTEXES=y | ||
6 | CONFIG_DEBUG_KMEMLEAK=y | ||
7 | CONFIG_DEVKMEM=y | ||
8 | CONFIG_HAVE_DEBUG_KMEMLEAK=y | ||
9 | CONFIG_DEBUG_KMEMLEAK_EARLY_LOG_SIZE=400 | ||
10 | CONFIG_DEBUG_KMEMLEAK_TEST=n | ||
11 | CONFIG_DEBUG_KMEMLEAK_DEFAULT_OFF=n | ||
12 | CONFIG_DEBUG_LOCK_ALLOC=y | ||
13 | CONFIG_DEBUG_INFO=y | ||
14 | CONFIG_DEBUG_FS=y | ||
15 | CONFIG_DEBUG_KERNEL=y | ||
16 | CONFIG_PM_DEBUG=y | ||
17 | CONFIG_DEBUG_GPIO=y | ||
18 | CONFIG_USB_DEBUG=y | ||
19 | CONFIG_SND_DEBUG=y | ||
20 | CONFIG_RTC_DEBUG=y | ||
diff --git a/recipes-kernel/linux/linux-ti-staging_3.12.bb b/recipes-kernel/linux/linux-ti-staging_3.12.bb index 96be6217..154d2fc2 100644 --- a/recipes-kernel/linux/linux-ti-staging_3.12.bb +++ b/recipes-kernel/linux/linux-ti-staging_3.12.bb | |||
@@ -40,11 +40,17 @@ SRCREV = "f0d4672333685697320f4907d5b4d3919121c299" | |||
40 | PV = "3.12.17" | 40 | PV = "3.12.17" |
41 | 41 | ||
42 | # Append to the MACHINE_KERNEL_PR so that a new SRCREV will cause a rebuild | 42 | # Append to the MACHINE_KERNEL_PR so that a new SRCREV will cause a rebuild |
43 | MACHINE_KERNEL_PR_append = "a+gitr${SRCPV}" | 43 | MACHINE_KERNEL_PR_append = "b+gitr${SRCPV}" |
44 | PR = "${MACHINE_KERNEL_PR}" | 44 | PR = "${MACHINE_KERNEL_PR}" |
45 | 45 | ||
46 | KERNEL_CONFIG_FRAGMENTS = "baseport.cfg connectivity.cfg ipc.cfg" | ||
47 | |||
46 | SRC_URI = "git://git.ti.com/ti-linux-kernel/ti-linux-kernel.git;protocol=git;branch=${BRANCH} \ | 48 | SRC_URI = "git://git.ti.com/ti-linux-kernel/ti-linux-kernel.git;protocol=git;branch=${BRANCH} \ |
47 | file://defconfig \ | 49 | file://defconfig \ |
50 | file://baseport.cfg \ | ||
51 | file://connectivity.cfg \ | ||
52 | file://ipc.cfg \ | ||
53 | file://systest.cfg \ | ||
48 | " | 54 | " |
49 | 55 | ||
50 | # Disable SMP in defconfig on single-core platforms to reduce overhead | 56 | # Disable SMP in defconfig on single-core platforms to reduce overhead |