summaryrefslogtreecommitdiffstats
path: root/recipes-kernel
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2014-08-05 12:12:14 +0000
committerDenys Dmytriyenko <denys@ti.com>2014-08-05 13:06:29 -0400
commit68b5408693f2a398a88ecc40956003ce68d2c76d (patch)
tree26c1f354e35af50ab177c11188285c8d1b38f9a8 /recipes-kernel
parentbb6c9bf5c15172c4b3ffe4c61ed8482407bc80ec (diff)
downloadmeta-ti-68b5408693f2a398a88ecc40956003ce68d2c76d.tar.gz
linux-ti-staging 3.14: update to latest 3.14.15
Update SGX patching, as now being partially upstreamed to the kernel. Signed-off-by: Denys Dmytriyenko <denys@ti.com> Acked-by: Franklin Cooper Jr. <fcooper@ti.com>
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/linux/linux-ti-staging-3.14/sgx.cfg24
-rw-r--r--recipes-kernel/linux/linux-ti-staging-3.14/sgx/0004-ARM-OMAP2-Use-pdata-quirks-for-sgx-deassert_hardrese.patch86
-rw-r--r--recipes-kernel/linux/linux-ti-staging-3.14/sgx/0005-ARM-dts-am437x-add-SGX-node.patch41
-rw-r--r--recipes-kernel/linux/linux-ti-staging-3.14/sgx/0006-ARM-dts-am33xx-add-DT-node-for-gpu.patch42
-rw-r--r--recipes-kernel/linux/linux-ti-staging_3.14.bb16
5 files changed, 6 insertions, 203 deletions
diff --git a/recipes-kernel/linux/linux-ti-staging-3.14/sgx.cfg b/recipes-kernel/linux/linux-ti-staging-3.14/sgx.cfg
deleted file mode 100644
index 02917798..00000000
--- a/recipes-kernel/linux/linux-ti-staging-3.14/sgx.cfg
+++ /dev/null
@@ -1,24 +0,0 @@
1##################################################
2# SGX Graphics config options
3##################################################
4CONFIG_DMA_SHARED_BUFFER=y
5CONFIG_TI_ST=n
6CONFIG_INPUT_TOUCHSCREEN=y
7CONFIG_TOUCHSCREEN_ADS7846=y
8CONFIG_I2C_ALGOBIT=y
9CONFIG_MFD_TPS65218=n
10CONFIG_DRM=y
11CONFIG_DRM_KMS_HELPER=y
12CONFIG_DRM_KMS_FB_HELPER=y
13CONFIG_DRM_GEM_CMA_HELPER=y
14CONFIG_DRM_KMS_CMA_HELPER=y
15CONFIG_DRM_I2C_NXP_TDA998X=y
16CONFIG_DRM_TILCDC=y
17CONFIG_FB_SYS_FILLRECT=y
18CONFIG_FB_SYS_COPYAREA=y
19CONFIG_FB_SYS_IMAGEBLIT=y
20CONFIG_BACKLIGHT_CLASS_DEVICE=y
21CONFIG_HDMI=y
22CONFIG_FRAMEBUFFER_CONSOLE_DETECT_PRIMARY=y
23CONFIG_SND_DAVINCI_SOC=m
24CONFIG_SND_SIMPLE_CARD=n
diff --git a/recipes-kernel/linux/linux-ti-staging-3.14/sgx/0004-ARM-OMAP2-Use-pdata-quirks-for-sgx-deassert_hardrese.patch b/recipes-kernel/linux/linux-ti-staging-3.14/sgx/0004-ARM-OMAP2-Use-pdata-quirks-for-sgx-deassert_hardrese.patch
deleted file mode 100644
index b0d5d405..00000000
--- a/recipes-kernel/linux/linux-ti-staging-3.14/sgx/0004-ARM-OMAP2-Use-pdata-quirks-for-sgx-deassert_hardrese.patch
+++ /dev/null
@@ -1,86 +0,0 @@
1From 761dbda366d46ff007e04c09dd2deeee5073d090 Mon Sep 17 00:00:00 2001
2From: Darren Etheridge <detheridge@ti.com>
3Date: Fri, 25 Jul 2014 16:09:53 -0500
4Subject: [PATCH 4/6] ARM: OMAP2+: Use pdata-quirks for sgx deassert_hardreset
5
6Use pdata_quirks to provide platform data to the sgx driver.
7The data that is provided includes:
8
91) Function pointers for the driver to use to reset the h/w block.
102) The reset name that matches with what is used in hwmod.
11
12Signed-off-by: Darren Etheridge <detheridge@ti.com>
13---
14 arch/arm/mach-omap2/pdata-quirks.c | 12 ++++++++++++
15 include/linux/platform_data/gfx-sgx.h | 22 ++++++++++++++++++++++
16 2 files changed, 34 insertions(+)
17 create mode 100644 include/linux/platform_data/gfx-sgx.h
18
19diff --git a/arch/arm/mach-omap2/pdata-quirks.c b/arch/arm/mach-omap2/pdata-quirks.c
20index a1fb5aa..945dd61 100644
21--- a/arch/arm/mach-omap2/pdata-quirks.c
22+++ b/arch/arm/mach-omap2/pdata-quirks.c
23@@ -17,6 +17,7 @@
24
25 #include <linux/platform_data/pinctrl-single.h>
26 #include <linux/platform_data/iommu-omap.h>
27+#include <linux/platform_data/gfx-sgx.h>
28
29 #include "am35xx.h"
30 #include "common.h"
31@@ -63,6 +64,13 @@ static inline void legacy_init_wl12xx(unsigned ref_clock,
32 }
33 #endif
34
35+#if defined(CONFIG_SOC_AM33XX) || defined(CONFIG_SOC_AM43XX)
36+static struct gfx_sgx_platform_data gfx_pdata = {
37+ .reset_name = "gfx",
38+ .deassert_reset = omap_device_deassert_hardreset,
39+};
40+#endif
41+
42 #ifdef CONFIG_MACH_NOKIA_N8X0
43 static void __init omap2420_n8x0_legacy_init(void)
44 {
45@@ -270,6 +278,10 @@ struct of_dev_auxdata omap_auxdata_lookup[] __initdata = {
46 OF_DEV_AUXDATA("ti,am3517-emac", 0x5c000000, "davinci_emac.0",
47 &am35xx_emac_pdata),
48 #endif
49+#if defined(CONFIG_SOC_AM33XX) || defined(CONFIG_SOC_AM43XX)
50+ OF_DEV_AUXDATA("ti,sgx", 0x56000000, "56000000.sgx",
51+ &gfx_pdata),
52+#endif
53 #ifdef CONFIG_ARCH_OMAP4
54 OF_DEV_AUXDATA("ti,omap4-padconf", 0x4a100040, "4a100040.pinmux", &pcs_pdata),
55 OF_DEV_AUXDATA("ti,omap4-padconf", 0x4a31e040, "4a31e040.pinmux", &pcs_pdata),
56diff --git a/include/linux/platform_data/gfx-sgx.h b/include/linux/platform_data/gfx-sgx.h
57new file mode 100644
58index 0000000..aa59b2c
59--- /dev/null
60+++ b/include/linux/platform_data/gfx-sgx.h
61@@ -0,0 +1,22 @@
62+/*
63+ * SGX Graphics Driver Platform Data
64+ *
65+ * Copyright (C) 2014 Texas Instruments Incorporated - http://www.ti.com/
66+ * Darren Etheridge <detheridge@ti.com>
67+ *
68+ * This program is free software; you can redistribute it and/or modify
69+ * it under the terms of the GNU General Public License version 2 as
70+ * published by the Free Software Foundation.
71+ *
72+ * This program is distributed "as is" WITHOUT ANY WARRANTY of any
73+ * kind, whether express or implied; without even the implied warranty
74+ * of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
75+ * GNU General Public License for more details.
76+ */
77+#include <linux/platform_device.h>
78+
79+struct gfx_sgx_platform_data {
80+ const char *reset_name;
81+
82+ int (*deassert_reset)(struct platform_device *pdev, const char *name);
83+};
84--
851.9.1
86
diff --git a/recipes-kernel/linux/linux-ti-staging-3.14/sgx/0005-ARM-dts-am437x-add-SGX-node.patch b/recipes-kernel/linux/linux-ti-staging-3.14/sgx/0005-ARM-dts-am437x-add-SGX-node.patch
deleted file mode 100644
index e18581ad..00000000
--- a/recipes-kernel/linux/linux-ti-staging-3.14/sgx/0005-ARM-dts-am437x-add-SGX-node.patch
+++ /dev/null
@@ -1,41 +0,0 @@
1From c921fe043facef3bd6649170fb6130f18e9367b7 Mon Sep 17 00:00:00 2001
2From: Darren Etheridge <detheridge@ti.com>
3Date: Tue, 29 Jul 2014 16:27:59 -0500
4Subject: [PATCH 5/6] ARM: dts: am437x: add SGX node
5
6Add dt node to enable SGX PowerVR driver.
7
8Signed-off-by: Darren Etheridge <detheridge@ti.com>
9---
10 arch/arm/boot/dts/am4372.dtsi | 8 ++++++++
11 1 file changed, 8 insertions(+)
12
13diff --git a/arch/arm/boot/dts/am4372.dtsi b/arch/arm/boot/dts/am4372.dtsi
14index d36af42..d963a60 100644
15--- a/arch/arm/boot/dts/am4372.dtsi
16+++ b/arch/arm/boot/dts/am4372.dtsi
17@@ -707,6 +707,13 @@
18 dma-names = "tx", "rx";
19 };
20
21+ sgx@0x56000000 {
22+ compatible = "ti,sgx";
23+ ti,hwmods = "gfx";
24+ reg = <0x56000000 0x1000000>;
25+ interrupts = <GIC_SPI 37 IRQ_TYPE_LEVEL_HIGH>;
26+ };
27+
28 mcasp1: mcasp@4803C000 {
29 compatible = "ti,am33xx-mcasp-audio";
30 ti,hwmods = "mcasp1";
31@@ -891,6 +898,7 @@
32 clocks = <&disp_clk>;
33 clock-names = "fck";
34 };
35+
36 };
37 };
38 };
39--
401.9.1
41
diff --git a/recipes-kernel/linux/linux-ti-staging-3.14/sgx/0006-ARM-dts-am33xx-add-DT-node-for-gpu.patch b/recipes-kernel/linux/linux-ti-staging-3.14/sgx/0006-ARM-dts-am33xx-add-DT-node-for-gpu.patch
deleted file mode 100644
index d4d0f137..00000000
--- a/recipes-kernel/linux/linux-ti-staging-3.14/sgx/0006-ARM-dts-am33xx-add-DT-node-for-gpu.patch
+++ /dev/null
@@ -1,42 +0,0 @@
1From 0ef34332c3400b211a047eaca751d00c97f5104c Mon Sep 17 00:00:00 2001
2From: Darren Etheridge <detheridge@ti.com>
3Date: Fri, 18 Jul 2014 16:19:54 -0500
4Subject: [PATCH 6/6] ARM: dts: am33xx: add DT node for gpu
5
6Add the node into the am33xx.dtsi file for the SGX GPU
7that is found in some variants of the SoC.
8
9Signed-off-by: Darren Etheridge <detheridge@ti.com>
10---
11 arch/arm/boot/dts/am33xx.dtsi | 8 +++++++-
12 1 file changed, 7 insertions(+), 1 deletion(-)
13
14diff --git a/arch/arm/boot/dts/am33xx.dtsi b/arch/arm/boot/dts/am33xx.dtsi
15index 2cfd694..df6ae9c 100644
16--- a/arch/arm/boot/dts/am33xx.dtsi
17+++ b/arch/arm/boot/dts/am33xx.dtsi
18@@ -109,7 +109,6 @@
19 prcm: prcm@44e00000 {
20 compatible = "ti,am3-prcm";
21 reg = <0x44e00000 0x4000>;
22-
23 prcm_clocks: clocks {
24 #address-cells = <1>;
25 #size-cells = <0>;
26@@ -822,6 +821,13 @@
27 reg = <0x48310000 0x2000>;
28 interrupts = <111>;
29 };
30+
31+ sgx@0x56000000 {
32+ compatible = "ti,sgx";
33+ ti,hwmods = "gfx";
34+ reg = <0x56000000 0x1000000>;
35+ interrupts = <37>;
36+ };
37 };
38 };
39
40--
411.9.1
42
diff --git a/recipes-kernel/linux/linux-ti-staging_3.14.bb b/recipes-kernel/linux/linux-ti-staging_3.14.bb
index c223c880..6088bee5 100644
--- a/recipes-kernel/linux/linux-ti-staging_3.14.bb
+++ b/recipes-kernel/linux/linux-ti-staging_3.14.bb
@@ -43,11 +43,11 @@ S = "${WORKDIR}/git"
43 43
44BRANCH = "ti-linux-3.14.y" 44BRANCH = "ti-linux-3.14.y"
45 45
46SRCREV = "b0fa4f08d72c8723219b5174b5749151b5acaee0" 46SRCREV = "780f0589876618911eb9cd7ad5a83db249ad1638"
47PV = "3.14.14" 47PV = "3.14.15"
48 48
49# Append to the MACHINE_KERNEL_PR so that a new SRCREV will cause a rebuild 49# Append to the MACHINE_KERNEL_PR so that a new SRCREV will cause a rebuild
50MACHINE_KERNEL_PR_append = "b+gitr${SRCPV}" 50MACHINE_KERNEL_PR_append = "a+gitr${SRCPV}"
51PR = "${MACHINE_KERNEL_PR}" 51PR = "${MACHINE_KERNEL_PR}"
52 52
53KERNEL_CONFIG_DIR = "${S}/ti_config_fragments" 53KERNEL_CONFIG_DIR = "${S}/ti_config_fragments"
@@ -55,21 +55,17 @@ KERNEL_CONFIG_FRAGMENTS = "${KERNEL_CONFIG_DIR}/audio_display.cfg ${KERNEL_CONFI
55 ${KERNEL_CONFIG_DIR}/connectivity.cfg ${KERNEL_CONFIG_DIR}/ipc.cfg \ 55 ${KERNEL_CONFIG_DIR}/connectivity.cfg ${KERNEL_CONFIG_DIR}/ipc.cfg \
56 ${KERNEL_CONFIG_DIR}/power.cfg" 56 ${KERNEL_CONFIG_DIR}/power.cfg"
57 57
58KERNEL_CONFIG_FRAGMENTS_append_ti33x = " ${WORKDIR}/non-smp.cfg ${WORKDIR}/sgx.cfg" 58KERNEL_CONFIG_FRAGMENTS_append_ti33x = " ${WORKDIR}/non-smp.cfg"
59KERNEL_CONFIG_FRAGMENTS_append_ti43x = " ${WORKDIR}/non-smp.cfg ${WORKDIR}/sgx.cfg" 59KERNEL_CONFIG_FRAGMENTS_append_ti43x = " ${WORKDIR}/non-smp.cfg"
60 60
61# Patches necessary to make SGX graphics work with this kernel version 61# Patches necessary to make SGX graphics work with this kernel version
62SGX_PATCHES = "file://sgx/0001-HACK-drm-fb_helper-enable-panning-support.patch \ 62SGX_PATCHES = "file://sgx/0001-HACK-drm-fb_helper-enable-panning-support.patch \
63 file://sgx/0002-HACK-drm-tilcdc-add-vsync-callback-for-use-in-omaplf.patch \ 63 file://sgx/0002-HACK-drm-tilcdc-add-vsync-callback-for-use-in-omaplf.patch \
64 file://sgx/0003-drm-tilcdc-fix-the-ping-pong-dma-tearing-issue-seen-.patch \ 64 file://sgx/0003-drm-tilcdc-fix-the-ping-pong-dma-tearing-issue-seen-.patch"
65 file://sgx/0004-ARM-OMAP2-Use-pdata-quirks-for-sgx-deassert_hardrese.patch \
66 file://sgx/0005-ARM-dts-am437x-add-SGX-node.patch \
67 file://sgx/0006-ARM-dts-am33xx-add-DT-node-for-gpu.patch"
68 65
69SRC_URI = "git://git.ti.com/ti-linux-kernel/ti-linux-kernel.git;protocol=git;branch=${BRANCH} \ 66SRC_URI = "git://git.ti.com/ti-linux-kernel/ti-linux-kernel.git;protocol=git;branch=${BRANCH} \
70 file://defconfig \ 67 file://defconfig \
71 file://non-smp.cfg \ 68 file://non-smp.cfg \
72 file://sgx.cfg \
73 " 69 "
74 70
75SRC_URI_append_ti33x = " ${SGX_PATCHES}" 71SRC_URI_append_ti33x = " ${SGX_PATCHES}"