diff options
author | Koen Kooi <koen@dominion.thruhere.net> | 2012-01-26 18:38:04 +0100 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2012-01-27 09:05:03 +0100 |
commit | bfbb1cc110671ec18947f602f2293dfda1d54c6e (patch) | |
tree | 7e044ff7ed13eed32906d6dcd878f8581d484d60 /recipes-kernel | |
parent | 23b0213494bbcbd89acaef585bc58f1a064cbfba (diff) | |
download | meta-ti-bfbb1cc110671ec18947f602f2293dfda1d54c6e.tar.gz |
linux-ti33x-psp 3.1: add dto patch to fix problems with various sd cards
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'recipes-kernel')
-rw-r--r-- | recipes-kernel/linux/linux-ti33x-psp-3.1/0038-omap_hsmmc-Set-dto-to-max-value-of-14-to-avoid-SD-Ca.patch | 34 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-ti33x-psp_3.1.bb | 3 |
2 files changed, 36 insertions, 1 deletions
diff --git a/recipes-kernel/linux/linux-ti33x-psp-3.1/0038-omap_hsmmc-Set-dto-to-max-value-of-14-to-avoid-SD-Ca.patch b/recipes-kernel/linux/linux-ti33x-psp-3.1/0038-omap_hsmmc-Set-dto-to-max-value-of-14-to-avoid-SD-Ca.patch new file mode 100644 index 00000000..4fe037e4 --- /dev/null +++ b/recipes-kernel/linux/linux-ti33x-psp-3.1/0038-omap_hsmmc-Set-dto-to-max-value-of-14-to-avoid-SD-Ca.patch | |||
@@ -0,0 +1,34 @@ | |||
1 | From d12058d27dddf60b36f5b2142ee999e55bddfff6 Mon Sep 17 00:00:00 2001 | ||
2 | From: Steve Sakoman <steve@sakoman.com> | ||
3 | Date: Mon, 18 Jul 2011 23:13:41 -0500 | ||
4 | Subject: [PATCH 38/38] omap_hsmmc: Set dto to max value of 14 to avoid SD | ||
5 | Card timeouts | ||
6 | |||
7 | This fixes MMC errors due to timeouts on certain SD Cards following suggestions | ||
8 | to set dto to 14 by Jason Kridner and Steven Kipisz | ||
9 | |||
10 | Details of the issue: | ||
11 | http://talk.maemo.org/showthread.php?p=1000707#post1000707 | ||
12 | |||
13 | This fix was originally proposed by Sukumar Ghoral of TI. | ||
14 | --- | ||
15 | drivers/mmc/host/omap_hsmmc.c | 3 +++ | ||
16 | 1 files changed, 3 insertions(+), 0 deletions(-) | ||
17 | |||
18 | diff --git a/drivers/mmc/host/omap_hsmmc.c b/drivers/mmc/host/omap_hsmmc.c | ||
19 | index 35505bd..0be77ec 100644 | ||
20 | --- a/drivers/mmc/host/omap_hsmmc.c | ||
21 | +++ b/drivers/mmc/host/omap_hsmmc.c | ||
22 | @@ -1574,6 +1574,9 @@ static void set_data_timeout(struct omap_hsmmc_host *host, | ||
23 | dto = 14; | ||
24 | } | ||
25 | |||
26 | + /* Set dto to max value of 14 to avoid SD Card timeouts */ | ||
27 | + dto = 14; | ||
28 | + | ||
29 | reg &= ~DTO_MASK; | ||
30 | reg |= dto << DTO_SHIFT; | ||
31 | OMAP_HSMMC_WRITE(host->base, SYSCTL, reg); | ||
32 | -- | ||
33 | 1.7.7.5 | ||
34 | |||
diff --git a/recipes-kernel/linux/linux-ti33x-psp_3.1.bb b/recipes-kernel/linux/linux-ti33x-psp_3.1.bb index 84e5c3ba..591731c8 100644 --- a/recipes-kernel/linux/linux-ti33x-psp_3.1.bb +++ b/recipes-kernel/linux/linux-ti33x-psp_3.1.bb | |||
@@ -11,7 +11,7 @@ MULTI_CONFIG_BASE_SUFFIX = "" | |||
11 | 11 | ||
12 | BRANCH = "v3.1-meta-ti-r1r+gitr1d84d8853fa30cf3db2571a5aec572accca4e29d" | 12 | BRANCH = "v3.1-meta-ti-r1r+gitr1d84d8853fa30cf3db2571a5aec572accca4e29d" |
13 | SRCREV = "1d84d8853fa30cf3db2571a5aec572accca4e29d" | 13 | SRCREV = "1d84d8853fa30cf3db2571a5aec572accca4e29d" |
14 | MACHINE_KERNEL_PR_append = "k+gitr${SRCREV}" | 14 | MACHINE_KERNEL_PR_append = "l+gitr${SRCREV}" |
15 | 15 | ||
16 | COMPATIBLE_MACHINE = "(ti33x)" | 16 | COMPATIBLE_MACHINE = "(ti33x)" |
17 | 17 | ||
@@ -62,6 +62,7 @@ PATCHES_OVER_PSP = " \ | |||
62 | file://0035-beaglebone-add-structs-for-DVI-cape-LEDs.patch\ | 62 | file://0035-beaglebone-add-structs-for-DVI-cape-LEDs.patch\ |
63 | file://0036-beaglebone-update-LCD-cape-partnumber.patch \ | 63 | file://0036-beaglebone-update-LCD-cape-partnumber.patch \ |
64 | file://0037-beaglebone-compare-complete-partnumber-not-the-first.patch \ | 64 | file://0037-beaglebone-compare-complete-partnumber-not-the-first.patch \ |
65 | file://0038-omap_hsmmc-Set-dto-to-max-value-of-14-to-avoid-SD-Ca.patch \ | ||
65 | " | 66 | " |
66 | 67 | ||
67 | SRC_URI += "${@base_contains('DISTRO_FEATURES', 'tipspkernel', "", "${PATCHES_OVER_PSP}", d)}" | 68 | SRC_URI += "${@base_contains('DISTRO_FEATURES', 'tipspkernel', "", "${PATCHES_OVER_PSP}", d)}" |