diff options
author | Denys Dmytriyenko <denys@ti.com> | 2013-02-25 23:42:28 -0500 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2013-03-18 14:28:13 -0400 |
commit | 0a42d9cf21ba0edceb390a9e289d7226876d9dbe (patch) | |
tree | 7ddb016bdb8f8ca08191a1f724917ada6c32dc7f /recipes-kernel | |
parent | 4f21d3b86badd88b99d19c225292a9bfa55fbaec (diff) | |
download | meta-ti-0a42d9cf21ba0edceb390a9e289d7226876d9dbe.tar.gz |
linux-omap-psp: fix alignment issue of 2.6.37 kernel with gcc-4.7
Patch by Steve Sakoman
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-kernel')
-rw-r--r-- | recipes-kernel/linux/files/0001-arm-fix-builds-with-gcc-4.7.patch | 26 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-omap-psp_2.6.37.bb | 9 |
2 files changed, 35 insertions, 0 deletions
diff --git a/recipes-kernel/linux/files/0001-arm-fix-builds-with-gcc-4.7.patch b/recipes-kernel/linux/files/0001-arm-fix-builds-with-gcc-4.7.patch new file mode 100644 index 00000000..db701e21 --- /dev/null +++ b/recipes-kernel/linux/files/0001-arm-fix-builds-with-gcc-4.7.patch | |||
@@ -0,0 +1,26 @@ | |||
1 | From 0d12debe917269a013f8eddd42da8d3de5e3174e Mon Sep 17 00:00:00 2001 | ||
2 | From: Steve Sakoman <steve@sakoman.com> | ||
3 | Date: Thu, 24 Jan 2013 15:42:01 -0800 | ||
4 | Subject: [PATCH] arm: fix builds with gcc 4.7 | ||
5 | |||
6 | new unaligned access support in GCC was triggering an alignment fault at boot | ||
7 | --- | ||
8 | arch/arm/kernel/head.S | 2 +- | ||
9 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
10 | |||
11 | diff --git a/arch/arm/kernel/head.S b/arch/arm/kernel/head.S | ||
12 | index 6bd82d2..56b02cd 100644 | ||
13 | --- a/arch/arm/kernel/head.S | ||
14 | +++ b/arch/arm/kernel/head.S | ||
15 | @@ -336,7 +336,7 @@ __secondary_data: | ||
16 | * r13 = *virtual* address to jump to upon completion | ||
17 | */ | ||
18 | __enable_mmu: | ||
19 | -#ifdef CONFIG_ALIGNMENT_TRAP | ||
20 | +#if defined(CONFIG_ALIGNMENT_TRAP) && __LINUX_ARM_ARCH__ < 6 | ||
21 | orr r0, r0, #CR_A | ||
22 | #else | ||
23 | bic r0, r0, #CR_A | ||
24 | -- | ||
25 | 1.8.1.2 | ||
26 | |||
diff --git a/recipes-kernel/linux/linux-omap-psp_2.6.37.bb b/recipes-kernel/linux/linux-omap-psp_2.6.37.bb index bafeba5d..9eacfc9b 100644 --- a/recipes-kernel/linux/linux-omap-psp_2.6.37.bb +++ b/recipes-kernel/linux/linux-omap-psp_2.6.37.bb | |||
@@ -6,6 +6,10 @@ COMPATIBLE_MACHINE = "omap3" | |||
6 | 6 | ||
7 | SRCREV= "20c003f2f024d9f50f59edf9f1b8f5f035fb15b8" | 7 | SRCREV= "20c003f2f024d9f50f59edf9f1b8f5f035fb15b8" |
8 | 8 | ||
9 | # The main PR is now using MACHINE_KERNEL_PR, for omap3 devices | ||
10 | # see conf/machine/include/omap3.inc | ||
11 | MACHINE_KERNEL_PR_append = "a" | ||
12 | |||
9 | SRC_URI = "git://arago-project.org/git/projects/linux-omap3.git;protocol=git \ | 13 | SRC_URI = "git://arago-project.org/git/projects/linux-omap3.git;protocol=git \ |
10 | file://defconfig" | 14 | file://defconfig" |
11 | 15 | ||
@@ -83,6 +87,11 @@ SRC_URI += " \ | |||
83 | file://0002-usb-musb-am35x-fix-role-switching-issue.patch \ | 87 | file://0002-usb-musb-am35x-fix-role-switching-issue.patch \ |
84 | " | 88 | " |
85 | 89 | ||
90 | # Fix alignment issue with gcc-4.7 | ||
91 | SRC_URI += " \ | ||
92 | file://0001-arm-fix-builds-with-gcc-4.7.patch \ | ||
93 | " | ||
94 | |||
86 | # Updated PIO mode for MUSB help description | 95 | # Updated PIO mode for MUSB help description |
87 | SRC_URI_append_am3517-evm = " file://0001-musb-update-PIO-mode-help-information-in-Kconfig.patch" | 96 | SRC_URI_append_am3517-evm = " file://0001-musb-update-PIO-mode-help-information-in-Kconfig.patch" |
88 | 97 | ||