summaryrefslogtreecommitdiffstats
path: root/recipes-kernel
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2020-10-13 05:31:17 +0000
committerDan Murphy <dmurphy@ti.com>2020-10-14 10:40:40 -0500
commit9b10b8144caa1de74f3749e296a551160f83d3f1 (patch)
treeaf31a47479544c2fd9a679e6b55e4e1a7773d1f8 /recipes-kernel
parentb5cb0c8f45bbde50788a48e7898bcc39d1cc25cb (diff)
downloadmeta-ti-9b10b8144caa1de74f3749e296a551160f83d3f1.tar.gz
linux-ti-staging: extract common rdepends, pass defconfig_builder.sh via variable
Signed-off-by: Denys Dmytriyenko <denys@ti.com> Signed-off-by: Dan Murphy <dmurphy@ti.com>
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/linux/kernel-rdepends.inc40
-rw-r--r--recipes-kernel/linux/linux-ti-staging_5.4.bb45
-rw-r--r--recipes-kernel/linux/setup-defconfig.inc2
3 files changed, 44 insertions, 43 deletions
diff --git a/recipes-kernel/linux/kernel-rdepends.inc b/recipes-kernel/linux/kernel-rdepends.inc
new file mode 100644
index 00000000..56dfe4b2
--- /dev/null
+++ b/recipes-kernel/linux/kernel-rdepends.inc
@@ -0,0 +1,40 @@
1# Pull in the devicetree files into the rootfs
2RDEPENDS_${KERNEL_PACKAGE_NAME}-base += "kernel-devicetree"
3
4# Add run-time dependency for PM firmware to the rootfs
5RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_ti33x = " amx3-cm3"
6RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_ti43x = " amx3-cm3"
7
8# Add run-time dependency for VPE VPDMA firmware to the rootfs
9RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_dra7xx = " vpdma-fw"
10
11# Add run-time dependency for Goodix firmware to the rootfs
12RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_dra7xx = " goodix-fw"
13
14# Install boot-monitor skern file into /boot dir of rootfs
15RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_keystone = " boot-monitor"
16
17# Install ti-sci-fw into /boot dir of rootfs
18RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_k2g = " ti-sci-fw"
19
20# Add run-time dependency for SerDes firmware to the rootfs
21RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_keystone = " serdes-fw"
22
23# Add run-time dependency for QMSS PDSP firmware to the rootfs
24RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_keystone = " qmss-pdsp-fw"
25
26# Add run-time dependency for NETCP PA firmware to the rootfs
27RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_k2hk = " netcp-pa-fw"
28RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_k2e = " netcp-pa-fw"
29RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_k2l = " netcp-pa-fw"
30
31# Add run-time dependency for PRU Ethernet firmware to the rootfs
32RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_am57xx-evm = " prueth-fw prusw-fw pruhsr-fw pruprp-fw"
33RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_am57xx-hs-evm = " prueth-fw prusw-fw pruhsr-fw pruprp-fw"
34RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_ti43x = " prueth-fw pruhsr-fw pruprp-fw"
35RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_ti33x = " prueth-fw pruhsr-fw pruprp-fw"
36RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_am65xx = " prueth-fw-am65x"
37RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_am65xx-evm = " prueth-fw-am65x-sr2"
38
39# Add run-time dependency for Cadence MHDP firmware to the rootfs
40RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_j7 = " cadence-mhdp-fw"
diff --git a/recipes-kernel/linux/linux-ti-staging_5.4.bb b/recipes-kernel/linux/linux-ti-staging_5.4.bb
index 2b4557d9..eaf40388 100644
--- a/recipes-kernel/linux/linux-ti-staging_5.4.bb
+++ b/recipes-kernel/linux/linux-ti-staging_5.4.bb
@@ -1,59 +1,20 @@
1SECTION = "kernel" 1SECTION = "kernel"
2DESCRIPTION = "Linux kernel for TI devices" 2SUMMARY = "Linux kernel for TI devices"
3LICENSE = "GPLv2" 3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814" 4LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
5 5
6inherit kernel 6inherit kernel
7 7
8DEFCONFIG_BUILDER = "${S}/ti_config_fragments/defconfig_builder.sh"
8require recipes-kernel/linux/setup-defconfig.inc 9require recipes-kernel/linux/setup-defconfig.inc
9require recipes-kernel/linux/cmem.inc 10require recipes-kernel/linux/cmem.inc
10require recipes-kernel/linux/ti-uio.inc 11require recipes-kernel/linux/ti-uio.inc
11require recipes-kernel/linux/bundle-devicetree.inc 12require recipes-kernel/linux/bundle-devicetree.inc
13require recipes-kernel/linux/kernel-rdepends.inc
12 14
13# Look in the generic major.minor directory for files 15# Look in the generic major.minor directory for files
14FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}-5.4:" 16FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}-5.4:"
15 17
16# Pull in the devicetree files into the rootfs
17RDEPENDS_${KERNEL_PACKAGE_NAME}-base += "kernel-devicetree"
18
19# Add run-time dependency for PM firmware to the rootfs
20RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_ti33x = " amx3-cm3"
21RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_ti43x = " amx3-cm3"
22
23# Add run-time dependency for VPE VPDMA firmware to the rootfs
24RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_dra7xx = " vpdma-fw"
25
26# Add run-time dependency for Goodix firmware to the rootfs
27RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_dra7xx = " goodix-fw"
28
29# Install boot-monitor skern file into /boot dir of rootfs
30RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_keystone = " boot-monitor"
31
32# Install ti-sci-fw into /boot dir of rootfs
33RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_k2g = " ti-sci-fw"
34
35# Add run-time dependency for SerDes firmware to the rootfs
36RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_keystone = " serdes-fw"
37
38# Add run-time dependency for QMSS PDSP firmware to the rootfs
39RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_keystone = " qmss-pdsp-fw"
40
41# Add run-time dependency for NETCP PA firmware to the rootfs
42RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_k2hk = " netcp-pa-fw"
43RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_k2e = " netcp-pa-fw"
44RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_k2l = " netcp-pa-fw"
45
46# Add run-time dependency for PRU Ethernet firmware to the rootfs
47RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_am57xx-evm = " prueth-fw prusw-fw pruhsr-fw pruprp-fw"
48RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_am57xx-hs-evm = " prueth-fw prusw-fw pruhsr-fw pruprp-fw"
49RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_ti43x = " prueth-fw pruhsr-fw pruprp-fw"
50RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_ti33x = " prueth-fw pruhsr-fw pruprp-fw"
51RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_am65xx = " prueth-fw-am65x"
52RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_am65xx-evm = " prueth-fw-am65x-sr2"
53
54# Add run-time dependency for Cadence MHDP firmware to the rootfs
55RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_j7 = " cadence-mhdp-fw"
56
57KERNEL_EXTRA_ARGS += "LOADADDR=${UBOOT_ENTRYPOINT}" 18KERNEL_EXTRA_ARGS += "LOADADDR=${UBOOT_ENTRYPOINT}"
58 19
59S = "${WORKDIR}/git" 20S = "${WORKDIR}/git"
diff --git a/recipes-kernel/linux/setup-defconfig.inc b/recipes-kernel/linux/setup-defconfig.inc
index dcf2adae..850a1dd8 100644
--- a/recipes-kernel/linux/setup-defconfig.inc
+++ b/recipes-kernel/linux/setup-defconfig.inc
@@ -28,7 +28,7 @@ do_configure() {
28 config=`cat ${B}/.config | grep use-tisdk-config | cut -d= -f2` 28 config=`cat ${B}/.config | grep use-tisdk-config | cut -d= -f2`
29 if [ -n "$config" ] 29 if [ -n "$config" ]
30 then 30 then
31 ${S}/ti_config_fragments/defconfig_builder.sh -w ${S} -t $config 31 ${DEFCONFIG_BUILDER} -w ${S} -t $config
32 oe_runmake -C ${S} O=${B} "$config"_defconfig 32 oe_runmake -C ${S} O=${B} "$config"_defconfig
33 else 33 else
34 # First, check if pointing to a combined config with config fragments 34 # First, check if pointing to a combined config with config fragments