diff options
author | Denys Dmytriyenko <denys@ti.com> | 2020-01-30 04:38:16 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2020-01-31 22:31:50 +0000 |
commit | aecb431a600c122487e6eccdfe30251eafb14d99 (patch) | |
tree | c3143611e3a3de17bc9f7d1189afc2e988c4ff73 /recipes-kernel | |
parent | 823ddbf9e5e2db66a09b70b7dbba559d798e5ee1 (diff) | |
download | meta-ti-aecb431a600c122487e6eccdfe30251eafb14d99.tar.gz |
jailhouse: switch to Python3 dependencies
python-argparse is not available in oe-core, but meta-python provides a
drop-in replacement python3-configargparse, if needed. meta-ti does not
depend on meta-python for now - can be adjusted in the distro layer.
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-kernel')
-rw-r--r-- | recipes-kernel/jailhouse/jailhouse_git.bb | 22 |
1 files changed, 11 insertions, 11 deletions
diff --git a/recipes-kernel/jailhouse/jailhouse_git.bb b/recipes-kernel/jailhouse/jailhouse_git.bb index 4186dc3a..ed23cdec 100644 --- a/recipes-kernel/jailhouse/jailhouse_git.bb +++ b/recipes-kernel/jailhouse/jailhouse_git.bb | |||
@@ -18,18 +18,18 @@ SRC_URI = " \ | |||
18 | git://git.ti.com/jailhouse/ti-jailhouse.git;protocol=git;branch=${BRANCH} \ | 18 | git://git.ti.com/jailhouse/ti-jailhouse.git;protocol=git;branch=${BRANCH} \ |
19 | " | 19 | " |
20 | 20 | ||
21 | DEPENDS = "virtual/kernel dtc-native python-mako-native python-mako make-native" | 21 | DEPENDS = "virtual/kernel dtc-native python3-mako-native python3-mako make-native" |
22 | RDEPENDS_${PN} += "\ | 22 | RDEPENDS_${PN} += "\ |
23 | python-curses\ | 23 | python3-curses\ |
24 | python-datetime\ | 24 | python3-datetime\ |
25 | python-argparse\ | 25 | python3-mmap\ |
26 | python-mmap\ | ||
27 | " | 26 | " |
28 | 27 | ||
29 | S = "${WORKDIR}/git" | ||
30 | |||
31 | require jailhouse-arch.inc | 28 | require jailhouse-arch.inc |
32 | inherit module pythonnative bash-completion deploy setuptools | 29 | inherit module python3native bash-completion deploy setuptools3 |
30 | |||
31 | S = "${WORKDIR}/git" | ||
32 | B = "${S}" | ||
33 | 33 | ||
34 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 34 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
35 | COMPATIBLE_MACHINE = "(ti-soc)" | 35 | COMPATIBLE_MACHINE = "(ti-soc)" |
@@ -88,7 +88,7 @@ do_compile() { | |||
88 | 88 | ||
89 | do_install() { | 89 | do_install() { |
90 | # Install pyjailhouse python modules needed by the tools | 90 | # Install pyjailhouse python modules needed by the tools |
91 | distutils_do_install | 91 | distutils3_do_install |
92 | 92 | ||
93 | # We want to install the python tools, but we do not want to use pip... | 93 | # We want to install the python tools, but we do not want to use pip... |
94 | # At least with v0.10, we can work around this with | 94 | # At least with v0.10, we can work around this with |
@@ -141,8 +141,8 @@ FILES_${PN} = "${base_libdir}/firmware ${libexecdir} ${sbindir} ${JH_DATADIR} /b | |||
141 | FILES_pyjailhouse = "${PYTHON_SITEPACKAGES_DIR}" | 141 | FILES_pyjailhouse = "${PYTHON_SITEPACKAGES_DIR}" |
142 | FILES_${PN}-tools = "${libexecdir}/${BPN}/${BPN}-*" | 142 | FILES_${PN}-tools = "${libexecdir}/${BPN}/${BPN}-*" |
143 | 143 | ||
144 | RDEPENDS_${PN}-tools = "pyjailhouse python-mmap python-math python-argparse python-datetime python-curses python-compression" | 144 | RDEPENDS_${PN}-tools = "pyjailhouse python3-mmap python3-math python3-datetime python3-curses python3-compression" |
145 | RDEPENDS_pyjailhouse = "python-core python-ctypes python-fcntl python-shell" | 145 | RDEPENDS_pyjailhouse = "python3-core python3-ctypes python3-fcntl python3-shell" |
146 | 146 | ||
147 | RRECOMMENDS_${PN} = "${PN}-tools" | 147 | RRECOMMENDS_${PN} = "${PN}-tools" |
148 | 148 | ||