summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2012-04-19 17:33:34 +0200
committerDenys Dmytriyenko <denys@ti.com>2012-04-20 20:06:08 -0400
commit2585c8864b5ba85c9aa1fe81e21e771173125b97 (patch)
treec435172927079caab4bfdac42e6386d4dced5e05 /recipes-kernel/linux
parentbb6f1bad7fce0e9217b1747138bc71de354b3a79 (diff)
downloadmeta-ti-2585c8864b5ba85c9aa1fe81e21e771173125b97.tar.gz
linux-ti33x-psp 3.2: fix VGA cape detection for beaglebone
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-kernel/linux')
-rw-r--r--recipes-kernel/linux/linux-ti33x-psp-3.2/beaglebone/0030-beaglebone-don-t-compare-undefined-characters-it-mak.patch26
-rw-r--r--recipes-kernel/linux/linux-ti33x-psp_3.2.bb3
2 files changed, 28 insertions, 1 deletions
diff --git a/recipes-kernel/linux/linux-ti33x-psp-3.2/beaglebone/0030-beaglebone-don-t-compare-undefined-characters-it-mak.patch b/recipes-kernel/linux/linux-ti33x-psp-3.2/beaglebone/0030-beaglebone-don-t-compare-undefined-characters-it-mak.patch
new file mode 100644
index 00000000..48e8c53b
--- /dev/null
+++ b/recipes-kernel/linux/linux-ti33x-psp-3.2/beaglebone/0030-beaglebone-don-t-compare-undefined-characters-it-mak.patch
@@ -0,0 +1,26 @@
1From 6e14ab85bd71ec3831169d665c4e79f646a60df8 Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Thu, 19 Apr 2012 07:55:55 +0200
4Subject: [PATCH 30/30] beaglebone: don't compare undefined characters, it makes strncomp fail
5
6Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
7---
8 arch/arm/mach-omap2/board-am335xevm.c | 2 +-
9 1 files changed, 1 insertions(+), 1 deletions(-)
10
11diff --git a/arch/arm/mach-omap2/board-am335xevm.c b/arch/arm/mach-omap2/board-am335xevm.c
12index bfcccd9..08a0425 100644
13--- a/arch/arm/mach-omap2/board-am335xevm.c
14+++ b/arch/arm/mach-omap2/board-am335xevm.c
15@@ -2152,7 +2152,7 @@ static void beaglebone_cape_setup(struct memory_accessor *mem_acc, void *context
16 beaglebone_lcd3_keys_init(0,0);
17 }
18
19- if (!strncmp("BB-BONE-VGA-01", cape_config.partnumber, 15)) {
20+ if (!strncmp("BB-BONE-VGA-01", cape_config.partnumber, 14)) {
21 pr_info("BeagleBone cape: initializing VGA cape\n");
22 dvi_init(0,0);
23 }
24--
251.7.2.5
26
diff --git a/recipes-kernel/linux/linux-ti33x-psp_3.2.bb b/recipes-kernel/linux/linux-ti33x-psp_3.2.bb
index d3a2f2ee..f560a1d1 100644
--- a/recipes-kernel/linux/linux-ti33x-psp_3.2.bb
+++ b/recipes-kernel/linux/linux-ti33x-psp_3.2.bb
@@ -12,7 +12,7 @@ MULTI_CONFIG_BASE_SUFFIX = ""
12 12
13BRANCH = "v3.2-staging" 13BRANCH = "v3.2-staging"
14SRCREV = "e8004dad869568692ca2a45c04e8464ce48cc4d7" 14SRCREV = "e8004dad869568692ca2a45c04e8464ce48cc4d7"
15MACHINE_KERNEL_PR_append = "c+gitr${SRCREV}" 15MACHINE_KERNEL_PR_append = "d+gitr${SRCREV}"
16 16
17COMPATIBLE_MACHINE = "(ti33x)" 17COMPATIBLE_MACHINE = "(ti33x)"
18 18
@@ -825,4 +825,5 @@ PATCHES_OVER_PSP = " \
825 file://beaglebone/0027-beaglebone-decrease-PWM-frequency-to-old-value-LCD7-.patch \ 825 file://beaglebone/0027-beaglebone-decrease-PWM-frequency-to-old-value-LCD7-.patch \
826 file://beaglebone/0028-beaglebone-fix-ehrpwm-backlight.patch \ 826 file://beaglebone/0028-beaglebone-fix-ehrpwm-backlight.patch \
827 file://beaglebone/0029-beaglebone-also-report-cape-revision.patch \ 827 file://beaglebone/0029-beaglebone-also-report-cape-revision.patch \
828 file://beaglebone/0030-beaglebone-don-t-compare-undefined-characters-it-mak.patch \
828" 829"