summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2012-03-29 00:25:14 -0400
committerDenys Dmytriyenko <denys@ti.com>2012-03-29 00:25:14 -0400
commita0dc3b8afc592b39c7948783952cd371c693640f (patch)
tree88951b3a3e59d1dd58a5b0fc39d266660f8b139c /recipes-kernel/linux
parent246cb75a970e9aab0a3974a55e72c6d90f1df151 (diff)
downloadmeta-ti-a0dc3b8afc592b39c7948783952cd371c693640f.tar.gz
multi-kernel: fix get_kernelversion returns None for do_compileconfigs
The function get_kernelversion uses generated header files to extract the version number. But those files are not available until do_compile, and do_compileconfigs is injected before that, hence the version becomes None and breaks in several places. Introduce a new task do_preparekernel that calls "make prepare" in the kernel tree to generate all the necessary files. It's also safer to call do_configure early on. Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-kernel/linux')
-rw-r--r--recipes-kernel/linux/linux-omap-psp_2.6.32.bb4
-rw-r--r--recipes-kernel/linux/multi-kernel.inc11
2 files changed, 12 insertions, 3 deletions
diff --git a/recipes-kernel/linux/linux-omap-psp_2.6.32.bb b/recipes-kernel/linux/linux-omap-psp_2.6.32.bb
index 212a6e31..61fc24f0 100644
--- a/recipes-kernel/linux/linux-omap-psp_2.6.32.bb
+++ b/recipes-kernel/linux/linux-omap-psp_2.6.32.bb
@@ -1,5 +1,7 @@
1require multi-kernel.inc 1require multi-kernel.inc
2 2
3MULTI_CONFIG_BASE_SUFFIX = ""
4
3DESCRIPTION = "Linux kernel for OMAP processors" 5DESCRIPTION = "Linux kernel for OMAP processors"
4KERNEL_IMAGETYPE = "uImage" 6KERNEL_IMAGETYPE = "uImage"
5 7
@@ -9,7 +11,7 @@ COMPATIBLE_MACHINE = "am3517-crane|beagleboard|omap3evm|am3517-evm|dm37x-evm|am3
9SRCREV = "5fc29e7b2a76a64a739f857858ef0b98294aa155" 11SRCREV = "5fc29e7b2a76a64a739f857858ef0b98294aa155"
10 12
11# The main PR is now using MACHINE_KERNEL_PR, for omap3 see conf/machine/include/omap3.inc 13# The main PR is now using MACHINE_KERNEL_PR, for omap3 see conf/machine/include/omap3.inc
12MACHINE_KERNEL_PR_append = "b+gitr${SRCREV}" 14MACHINE_KERNEL_PR_append = "c+gitr${SRCREV}"
13 15
14SRC_URI += "git://arago-project.org/git/projects/linux-omap3.git;protocol=git;branch=master \ 16SRC_URI += "git://arago-project.org/git/projects/linux-omap3.git;protocol=git;branch=master \
15 file://0001-Revert-omap3-beagle-Fix-compile-time-errors.patch \ 17 file://0001-Revert-omap3-beagle-Fix-compile-time-errors.patch \
diff --git a/recipes-kernel/linux/multi-kernel.inc b/recipes-kernel/linux/multi-kernel.inc
index 53144541..056adb97 100644
--- a/recipes-kernel/linux/multi-kernel.inc
+++ b/recipes-kernel/linux/multi-kernel.inc
@@ -16,6 +16,14 @@ SRC_URI += " \
16 file://configs " 16 file://configs "
17 17
18MULTI_CONFIG_BASE_SUFFIX = "multi-config-" 18MULTI_CONFIG_BASE_SUFFIX = "multi-config-"
19MODULES_IMAGE_BASE_NAME = "modules-${PV}-${PR}-${MACHINE}"
20
21do_preparekernel () {
22 unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS MACHINE
23 oe_runmake prepare CC="${KERNEL_CC}" LD="${KERNEL_LD}"
24}
25
26addtask preparekernel after do_configure before do_compile
19 27
20do_compileconfigs () { 28do_compileconfigs () {
21 29
@@ -100,5 +108,4 @@ do_deploy_append () {
100} 108}
101 109
102do_compileconfigs[depends] += "u-boot-mkimage-native:do_populate_sysroot virtual/${TARGET_PREFIX}gcc:do_populate_sysroot virtual/${TARGET_PREFIX}gcc${KERNEL_CCSUFFIX}:do_populate_sysroot" 110do_compileconfigs[depends] += "u-boot-mkimage-native:do_populate_sysroot virtual/${TARGET_PREFIX}gcc:do_populate_sysroot virtual/${TARGET_PREFIX}gcc${KERNEL_CCSUFFIX}:do_populate_sysroot"
103addtask compileconfigs after do_patch before do_configure 111addtask compileconfigs after do_preparekernel before do_compile
104