summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-10-21 16:15:36 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-10-21 16:15:36 +0200
commitab07a0ea4be961a7e8c7b8b64a56ce6c730cd6e0 (patch)
tree7bec31c55178f256de7b1f52758306971d096a8d /recipes-kernel/linux
parent77dbc42e7a64452c4e87c0ee8e3040758d2e6ea6 (diff)
downloadmeta-ti-ab07a0ea4be961a7e8c7b8b64a56ce6c730cd6e0.tar.gz
linux-ti33x-psp 3.1rc8: include latest MUSB code, remove machine ID patches
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'recipes-kernel/linux')
-rw-r--r--recipes-kernel/linux/linux-ti33x-psp-3.0+3.1rc/beaglebone/defconfig8
-rw-r--r--recipes-kernel/linux/linux-ti33x-psp_3.0+3.1rc.bb7
2 files changed, 6 insertions, 9 deletions
diff --git a/recipes-kernel/linux/linux-ti33x-psp-3.0+3.1rc/beaglebone/defconfig b/recipes-kernel/linux/linux-ti33x-psp-3.0+3.1rc/beaglebone/defconfig
index 7adcefc1..fad92d70 100644
--- a/recipes-kernel/linux/linux-ti33x-psp-3.0+3.1rc/beaglebone/defconfig
+++ b/recipes-kernel/linux/linux-ti33x-psp-3.0+3.1rc/beaglebone/defconfig
@@ -345,7 +345,6 @@ CONFIG_MACH_IGEP0020=y
345CONFIG_MACH_TI8168EVM=y 345CONFIG_MACH_TI8168EVM=y
346CONFIG_MACH_AM335XEVM=y 346CONFIG_MACH_AM335XEVM=y
347CONFIG_MACH_AM335XIAEVM=y 347CONFIG_MACH_AM335XIAEVM=y
348CONFIG_MACH_BEAGLEBONE=y
349# CONFIG_OMAP3_EMU is not set 348# CONFIG_OMAP3_EMU is not set
350# CONFIG_OMAP3_SDRC_AC_TIMING is not set 349# CONFIG_OMAP3_SDRC_AC_TIMING is not set
351CONFIG_OMAP3_EDMA=y 350CONFIG_OMAP3_EDMA=y
@@ -2591,8 +2590,6 @@ CONFIG_USB_GADGET=y
2591# CONFIG_USB_GADGET_DEBUG_FS is not set 2590# CONFIG_USB_GADGET_DEBUG_FS is not set
2592CONFIG_USB_GADGET_VBUS_DRAW=2 2591CONFIG_USB_GADGET_VBUS_DRAW=2
2593CONFIG_USB_GADGET_STORAGE_NUM_BUFFERS=2 2592CONFIG_USB_GADGET_STORAGE_NUM_BUFFERS=2
2594CONFIG_USB_GADGET_PORT_USB1=y
2595# CONFIG_USB_GADGET_PORT_USB0 is not set
2596# CONFIG_USB_FUSB300 is not set 2593# CONFIG_USB_FUSB300 is not set
2597# CONFIG_USB_OMAP is not set 2594# CONFIG_USB_OMAP is not set
2598# CONFIG_USB_R8A66597 is not set 2595# CONFIG_USB_R8A66597 is not set
@@ -2601,6 +2598,10 @@ CONFIG_USB_GADGET_MUSB_HDRC=y
2601# CONFIG_USB_NET2272 is not set 2598# CONFIG_USB_NET2272 is not set
2602# CONFIG_USB_DUMMY_HCD is not set 2599# CONFIG_USB_DUMMY_HCD is not set
2603CONFIG_USB_GADGET_DUALSPEED=y 2600CONFIG_USB_GADGET_DUALSPEED=y
2601CONFIG_USB_G_DBGP=y
2602CONFIG_USB_G_DBGP_PRINTK=y
2603CONFIG_USB_GADGET_PORT_USB1=y
2604# CONFIG_USB_GADGET_PORT_USB0 is not set
2604CONFIG_USB_ZERO=m 2605CONFIG_USB_ZERO=m
2605CONFIG_USB_AUDIO=m 2606CONFIG_USB_AUDIO=m
2606CONFIG_USB_ETH=m 2607CONFIG_USB_ETH=m
@@ -2623,7 +2624,6 @@ CONFIG_USB_G_MULTI=m
2623CONFIG_USB_G_MULTI_RNDIS=y 2624CONFIG_USB_G_MULTI_RNDIS=y
2624# CONFIG_USB_G_MULTI_CDC is not set 2625# CONFIG_USB_G_MULTI_CDC is not set
2625CONFIG_USB_G_HID=m 2626CONFIG_USB_G_HID=m
2626# CONFIG_USB_G_DBGP is not set
2627CONFIG_USB_G_WEBCAM=m 2627CONFIG_USB_G_WEBCAM=m
2628 2628
2629# 2629#
diff --git a/recipes-kernel/linux/linux-ti33x-psp_3.0+3.1rc.bb b/recipes-kernel/linux/linux-ti33x-psp_3.0+3.1rc.bb
index d91e8e3c..9672153c 100644
--- a/recipes-kernel/linux/linux-ti33x-psp_3.0+3.1rc.bb
+++ b/recipes-kernel/linux/linux-ti33x-psp_3.0+3.1rc.bb
@@ -10,8 +10,8 @@ S = "${WORKDIR}/git"
10MULTI_CONFIG_BASE_SUFFIX = "" 10MULTI_CONFIG_BASE_SUFFIX = ""
11 11
12BRANCH = "master" 12BRANCH = "master"
13SRCREV = "a95ceb11b5858feae89895d14d7f7bc41cca9fd6" 13SRCREV = "c7fc664a6a36a4721b43dc287e410a2453f0b782"
14MACHINE_KERNEL_PR_append = "h+gitr${SRCREV}" 14MACHINE_KERNEL_PR_append = "i+gitr${SRCREV}"
15 15
16COMPATIBLE_MACHINE = "(ti33x)" 16COMPATIBLE_MACHINE = "(ti33x)"
17 17
@@ -27,9 +27,6 @@ SRC_URI += "git://arago-project.org/git/projects/linux-am33x.git;protocol=git;br
27PATCHES_OVER_PSP = " \ 27PATCHES_OVER_PSP = " \
28 file://0001-f_rndis-HACK-around-undefined-variables.patch \ 28 file://0001-f_rndis-HACK-around-undefined-variables.patch \
29 file://0001-am335x-Add-pin-mux-and-init-for-beaglebone-specific-.patch \ 29 file://0001-am335x-Add-pin-mux-and-init-for-beaglebone-specific-.patch \
30 file://0001-mach-types-Add-new-machine-type-beaglebone-to-mach-t.patch \
31 file://0002-Kconfig-Add-support-for-beaglebone-machine-id.patch \
32 file://0003-am335xevm-Use-new-beaglebone-machine-id.patch \
33 " 30 "
34 31
35SRC_URI += "${@base_contains('DISTRO_FEATURES', 'tipspkernel', "", "${PATCHES_OVER_PSP}", d)}" 32SRC_URI += "${@base_contains('DISTRO_FEATURES', 'tipspkernel', "", "${PATCHES_OVER_PSP}", d)}"