summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/jailhouse
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2019-07-15 19:45:04 +0000
committerDenys Dmytriyenko <denys@ti.com>2019-07-16 12:44:05 +0000
commit99d3ac64957842a94fdf45f0380d0075ff37781a (patch)
tree116f2f9f2fd5bd3abc632ee0c13d1ecb954867b1 /recipes-kernel/jailhouse
parent63c85b64df0b8a5cb33c920a543ea1a6eae64eaf (diff)
downloadmeta-ti-99d3ac64957842a94fdf45f0380d0075ff37781a.tar.gz
jailhouse: combine 2 __anonymous() functions, clean tabs
Fixes WARNING: python should use 4 spaces indentation, but found tabs in jailhouse_git.bb, line 85 Reported-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-kernel/jailhouse')
-rw-r--r--recipes-kernel/jailhouse/jailhouse_git.bb15
1 files changed, 6 insertions, 9 deletions
diff --git a/recipes-kernel/jailhouse/jailhouse_git.bb b/recipes-kernel/jailhouse/jailhouse_git.bb
index 753664ed..dc35262c 100644
--- a/recipes-kernel/jailhouse/jailhouse_git.bb
+++ b/recipes-kernel/jailhouse/jailhouse_git.bb
@@ -81,13 +81,6 @@ do_compile() {
81 oe_runmake V=1 ARCH=${JH_ARCH} CROSS_COMPILE=${TARGET_PREFIX} KDIR=${STAGING_KERNEL_BUILDDIR} 81 oe_runmake V=1 ARCH=${JH_ARCH} CROSS_COMPILE=${TARGET_PREFIX} KDIR=${STAGING_KERNEL_BUILDDIR}
82} 82}
83 83
84python __anonymous () {
85 d.appendVarFlag('do_install', 'depends', ' virtual/kernel:do_deploy')
86 initrd = d.getVar('INITRAMFS_IMAGE', True)
87 if initrd:
88 d.appendVarFlag('do_install', 'depends', ' ${INITRAMFS_IMAGE}:do_image_complete')
89}
90
91do_install() { 84do_install() {
92 oe_runmake ARCH=${JH_ARCH} CROSS_COMPILE=${TARGET_PREFIX} KDIR=${STAGING_KERNEL_BUILDDIR} DESTDIR=${D} install 85 oe_runmake ARCH=${JH_ARCH} CROSS_COMPILE=${TARGET_PREFIX} KDIR=${STAGING_KERNEL_BUILDDIR} DESTDIR=${D} install
93 86
@@ -121,7 +114,6 @@ do_install() {
121 fi 114 fi
122} 115}
123 116
124
125PACKAGE_BEFORE_PN = "kernel-module-jailhouse" 117PACKAGE_BEFORE_PN = "kernel-module-jailhouse"
126FILES_${PN} = "${base_libdir}/firmware ${libexecdir} ${sbindir} ${JH_DATADIR} /boot" 118FILES_${PN} = "${base_libdir}/firmware ${libexecdir} ${sbindir} ${JH_DATADIR} /boot"
127 119
@@ -133,7 +125,12 @@ KERNEL_MODULE_AUTOLOAD += "jailhouse"
133CELLS = "" 125CELLS = ""
134 126
135python __anonymous () { 127python __anonymous () {
136 # Setup DEPENDS and RDEPENDS to included cells" 128 d.appendVarFlag('do_install', 'depends', ' virtual/kernel:do_deploy')
129 initrd = d.getVar('INITRAMFS_IMAGE', True)
130 if initrd:
131 d.appendVarFlag('do_install', 'depends', ' ${INITRAMFS_IMAGE}:do_image_complete')
132
133 # Setup DEPENDS and RDEPENDS to included cells
137 cells = d.getVar('CELLS', True) or "" 134 cells = d.getVar('CELLS', True) or ""
138 for cell in cells.split(): 135 for cell in cells.split():
139 d.appendVar('DEPENDS', ' ' + cell) 136 d.appendVar('DEPENDS', ' ' + cell)