diff options
author | Denys Dmytriyenko <denys@ti.com> | 2018-08-29 06:12:42 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2018-08-29 19:12:33 +0000 |
commit | 471e024b3992ff8c56483010edfe11d1bc3565d4 (patch) | |
tree | 701c0bb320266d3863cece9ea4145f6e6ff03138 /recipes-graphics | |
parent | e50774b4139beb4020130d7c3e938011aa801b05 (diff) | |
download | meta-ti-471e024b3992ff8c56483010edfe11d1bc3565d4.tar.gz |
libgbm: fix undefined minor/major symbols with new glibc
glibc 2.28+ now requires this.
https://sourceware.org/bugzilla/show_bug.cgi?id=19239
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-graphics')
-rw-r--r-- | recipes-graphics/gbm/libgbm/0001-gbm.c-include-sys-sysmacros.h-for-minor-major-in-new.patch | 28 | ||||
-rw-r--r-- | recipes-graphics/gbm/libgbm_10.0.0.bb | 3 |
2 files changed, 30 insertions, 1 deletions
diff --git a/recipes-graphics/gbm/libgbm/0001-gbm.c-include-sys-sysmacros.h-for-minor-major-in-new.patch b/recipes-graphics/gbm/libgbm/0001-gbm.c-include-sys-sysmacros.h-for-minor-major-in-new.patch new file mode 100644 index 00000000..31134ab6 --- /dev/null +++ b/recipes-graphics/gbm/libgbm/0001-gbm.c-include-sys-sysmacros.h-for-minor-major-in-new.patch | |||
@@ -0,0 +1,28 @@ | |||
1 | From ea5fc8da36886490d0ee40d475733cd98e38c2ec Mon Sep 17 00:00:00 2001 | ||
2 | From: Denys Dmytriyenko <denys@ti.com> | ||
3 | Date: Tue, 28 Aug 2018 18:35:55 -0400 | ||
4 | Subject: [PATCH] gbm.c: include <sys/sysmacros.h> for minor/major in new glibc | ||
5 | |||
6 | glibc 2.28+ now requires this. | ||
7 | https://sourceware.org/bugzilla/show_bug.cgi?id=19239 | ||
8 | |||
9 | Signed-off-by: Denys Dmytriyenko <denys@ti.com> | ||
10 | --- | ||
11 | gbm.c | 1 + | ||
12 | 1 file changed, 1 insertion(+) | ||
13 | |||
14 | diff --git a/gbm.c b/gbm.c | ||
15 | index c046b1a..9356d7b 100644 | ||
16 | --- a/gbm.c | ||
17 | +++ b/gbm.c | ||
18 | @@ -35,6 +35,7 @@ | ||
19 | #include <stdint.h> | ||
20 | |||
21 | #include <sys/types.h> | ||
22 | +#include <sys/sysmacros.h> | ||
23 | #include <sys/stat.h> | ||
24 | #include <unistd.h> | ||
25 | #include <errno.h> | ||
26 | -- | ||
27 | 2.7.4 | ||
28 | |||
diff --git a/recipes-graphics/gbm/libgbm_10.0.0.bb b/recipes-graphics/gbm/libgbm_10.0.0.bb index 848a5f66..38715ccf 100644 --- a/recipes-graphics/gbm/libgbm_10.0.0.bb +++ b/recipes-graphics/gbm/libgbm_10.0.0.bb | |||
@@ -12,6 +12,7 @@ BRANCH = "next" | |||
12 | 12 | ||
13 | SRCREV = "96f37555c7e82a417b02051661377b10e6b3966e" | 13 | SRCREV = "96f37555c7e82a417b02051661377b10e6b3966e" |
14 | 14 | ||
15 | SRC_URI = "git://git.ti.com/glsdk/libgbm.git;protocol=git;branch=${BRANCH}" | 15 | SRC_URI = "git://git.ti.com/glsdk/libgbm.git;protocol=git;branch=${BRANCH} \ |
16 | file://0001-gbm.c-include-sys-sysmacros.h-for-minor-major-in-new.patch" | ||
16 | 17 | ||
17 | S = "${WORKDIR}/git" | 18 | S = "${WORKDIR}/git" |