diff options
author | Denys Dmytriyenko <denys@ti.com> | 2013-11-21 21:03:16 -0500 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2013-11-21 21:52:02 -0500 |
commit | cc4221a10045c333fe558a49b50edd62bb443b5f (patch) | |
tree | 0659891af28b3d0e23822b452d6ac76ae6c4f1cf /recipes-graphics | |
parent | e1351fa79908e257baf6f22082ca23d992d537fc (diff) | |
download | meta-ti-cc4221a10045c333fe558a49b50edd62bb443b5f.tar.gz |
libgles-omap3: update cputype to support 3.12 and AM43x device
Signed-off-by: Franklin S. Cooper Jr <fcooper@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-graphics')
-rwxr-xr-x | recipes-graphics/libgles/libgles-omap3/cputype | 18 | ||||
-rw-r--r-- | recipes-graphics/libgles/libgles-omap3_5.00.00.01.bb | 2 |
2 files changed, 14 insertions, 6 deletions
diff --git a/recipes-graphics/libgles/libgles-omap3/cputype b/recipes-graphics/libgles/libgles-omap3/cputype index 4448c300..35268a80 100755 --- a/recipes-graphics/libgles/libgles-omap3/cputype +++ b/recipes-graphics/libgles/libgles-omap3/cputype | |||
@@ -1,17 +1,25 @@ | |||
1 | #!/bin/sh | 1 | #!/bin/sh |
2 | 2 | ||
3 | machine_id() { # return the machine ID | 3 | legacy_machine_id() { # return the machine ID |
4 | awk 'BEGIN { FS=": " } /Hardware/ \ | 4 | awk 'BEGIN { FS=": " } /Hardware/ \ |
5 | { gsub(" ", "_", $2); print tolower($2) } ' </proc/cpuinfo | 5 | { gsub(" ", "_", $2); print tolower($2) } ' </proc/cpuinfo |
6 | } | 6 | } |
7 | 7 | ||
8 | if [ "$(machine_id)" = "ti8168evm" ] ; then | 8 | machine_id() { # return the machine ID |
9 | cat /proc/cpuinfo | grep Hardware | awk -F" " '{ print $4 }' | ||
10 | } | ||
11 | |||
12 | if [ "$(machine_id)" = "ti8168evm" -o "$(legacy_machine_id)" = "ti8168evm" ] ; then | ||
9 | echo TI816x | 13 | echo TI816x |
10 | elif [ "$(machine_id)" = "am335xevm" ] ; then | 14 | elif [ "$(machine_id)" = "AM33XX" -o "$(legacy_machine_id)" = "am335xevm" ] ; then |
11 | echo TI33XX | 15 | echo TI33XX |
16 | elif [ "$(machine_id)" = "AM43" ] ; then | ||
17 | echo TI43XX | ||
12 | else | 18 | else |
13 | devmem2 0x4800244c | \ | 19 | devmem2 0x4800244c | \ |
14 | grep 'Read at address' | \ | 20 | grep 'Read at address' | \ |
15 | sed -e 's/.*): //' | \ | 21 | sed -e 's/.*): //' | \ |
16 | sed -e 's/0x00005C00/OMAP3503/' -e 's/0x00001C00/OMAP3515/' -e 's/0x00004C00/OMAP3525/' -e 's/0x00000C00/OMAP3530/' -e 's/0x00005E00/OMAP3503/' -e 's/0x00001E00/OMAP3515/' -e 's/0x00004E00/OMAP3525/' -e 's/0x00000E00/OMAP3530/' -e 's/0x00000CC0/OMAP3530/' | 22 | sed -e 's/0x00005C00/OMAP3503/' -e 's/0x00001C00/OMAP3515/' -e 's/0x00004C00/OMAP3525/' -e 's/0x00000C00/OMAP3530/' \ |
23 | -e 's/0x00005E00/OMAP3503/' -e 's/0x00001E00/OMAP3515/' -e 's/0x00004E00/OMAP3525/' -e 's/0x00000E00/OMAP3530/' \ | ||
24 | -e 's/0x00000CC0/OMAP3530/' | ||
17 | fi | 25 | fi |
diff --git a/recipes-graphics/libgles/libgles-omap3_5.00.00.01.bb b/recipes-graphics/libgles/libgles-omap3_5.00.00.01.bb index be09ffa6..7af67eb6 100644 --- a/recipes-graphics/libgles/libgles-omap3_5.00.00.01.bb +++ b/recipes-graphics/libgles/libgles-omap3_5.00.00.01.bb | |||
@@ -2,7 +2,7 @@ require libgles-omap3-no-x.inc | |||
2 | 2 | ||
3 | LICENSE = "TSPA" | 3 | LICENSE = "TSPA" |
4 | 4 | ||
5 | PR = "${INC_PR}.0" | 5 | PR = "${INC_PR}.1" |
6 | 6 | ||
7 | DEFAULT_PREFERENCE = "-1" | 7 | DEFAULT_PREFERENCE = "-1" |
8 | 8 | ||