diff options
author | Gou, Hongmei <h-gou@ti.com> | 2015-08-29 03:07:32 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2015-08-28 20:03:54 -0400 |
commit | 483a8ce22c6c120272f6eeffb4ea7e07aca1bda1 (patch) | |
tree | 5792137182cb98fe91ac3aa63a27609ab669d5b9 /recipes-graphics | |
parent | 2b585314cc76895a1481ad22f16d95d0837d7c17 (diff) | |
download | meta-ti-483a8ce22c6c120272f6eeffb4ea7e07aca1bda1.tar.gz |
omap5-sgx-ddk-um-linux: add AM3 and AM4, and pvr-init to initialization
* Add AM3 and AM4 which use null_windown DRM
* Add pvr-init to /etc/init.d
Signed-off-by: Hongmei Gou <h-gou@ti.com>
v2 changes:
1) Use 8 as the initialization number for pvr-init, since pvr-init needs to be done before starting weston which uses number 9
2) Create empty powervr.ini as the default, and place ti33x and ti43x specific ones in their corresponding directories
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-graphics')
5 files changed, 49 insertions, 3 deletions
diff --git a/recipes-graphics/libgles/omap5-sgx-ddk-um-linux/powervr.ini b/recipes-graphics/libgles/omap5-sgx-ddk-um-linux/powervr.ini new file mode 100644 index 00000000..e69de29b --- /dev/null +++ b/recipes-graphics/libgles/omap5-sgx-ddk-um-linux/powervr.ini | |||
diff --git a/recipes-graphics/libgles/omap5-sgx-ddk-um-linux/rc.pvr b/recipes-graphics/libgles/omap5-sgx-ddk-um-linux/rc.pvr new file mode 100644 index 00000000..2711d6b7 --- /dev/null +++ b/recipes-graphics/libgles/omap5-sgx-ddk-um-linux/rc.pvr | |||
@@ -0,0 +1,17 @@ | |||
1 | #!/bin/bash | ||
2 | |||
3 | case "$1" in | ||
4 | start) | ||
5 | |||
6 | echo "Initializing the graphics driver ..." | ||
7 | pvrsrvinit | ||
8 | |||
9 | ;; | ||
10 | stop) | ||
11 | # Nothing to be done. | ||
12 | ;; | ||
13 | *) | ||
14 | echo "Usage: $0 {start|stop}" | ||
15 | exit 1 | ||
16 | ;; | ||
17 | esac | ||
diff --git a/recipes-graphics/libgles/omap5-sgx-ddk-um-linux/ti33x/powervr.ini b/recipes-graphics/libgles/omap5-sgx-ddk-um-linux/ti33x/powervr.ini new file mode 100644 index 00000000..0657ab87 --- /dev/null +++ b/recipes-graphics/libgles/omap5-sgx-ddk-um-linux/ti33x/powervr.ini | |||
@@ -0,0 +1,3 @@ | |||
1 | [default] | ||
2 | WindowSystem=null_libdrm.so | ||
3 | DisableHWTQTextureUpload=1 | ||
diff --git a/recipes-graphics/libgles/omap5-sgx-ddk-um-linux/ti43x/powervr.ini b/recipes-graphics/libgles/omap5-sgx-ddk-um-linux/ti43x/powervr.ini new file mode 100644 index 00000000..0657ab87 --- /dev/null +++ b/recipes-graphics/libgles/omap5-sgx-ddk-um-linux/ti43x/powervr.ini | |||
@@ -0,0 +1,3 @@ | |||
1 | [default] | ||
2 | WindowSystem=null_libdrm.so | ||
3 | DisableHWTQTextureUpload=1 | ||
diff --git a/recipes-graphics/libgles/omap5-sgx-ddk-um-linux_1.9.0.12.bb b/recipes-graphics/libgles/omap5-sgx-ddk-um-linux_1.9.0.12.bb index c29b91db..a97f88bf 100644 --- a/recipes-graphics/libgles/omap5-sgx-ddk-um-linux_1.9.0.12.bb +++ b/recipes-graphics/libgles/omap5-sgx-ddk-um-linux_1.9.0.12.bb | |||
@@ -3,12 +3,23 @@ HOMEPAGE = "http://downloads.ti.com/dsps/dsps_public_sw/gfxsdk" | |||
3 | LICENSE = "TI-TSPA" | 3 | LICENSE = "TI-TSPA" |
4 | LIC_FILES_CHKSUM = "file://OMAP5-Linux-Graphics-DDK-UM-Manifest.doc;md5=360d293df455e4f2d363bb4014a49603" | 4 | LIC_FILES_CHKSUM = "file://OMAP5-Linux-Graphics-DDK-UM-Manifest.doc;md5=360d293df455e4f2d363bb4014a49603" |
5 | 5 | ||
6 | BRANCH = "master" | 6 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
7 | |||
8 | BRANCH_omap-a15 = "master" | ||
9 | BRANCH_ti33x = "am4/k4.1" | ||
10 | BRANCH_ti43x = "am4/k4.1" | ||
7 | 11 | ||
8 | SRC_URI = "git://git.ti.com/graphics/omap5-sgx-ddk-um-linux.git;protocol=git;branch=${BRANCH}" | 12 | SRC_URI = "git://git.ti.com/graphics/omap5-sgx-ddk-um-linux.git;protocol=git;branch=${BRANCH}" |
9 | SRCREV = "d63cd6469fff610317a8e1c986f227bb3e7922f6" | 13 | SRCREV_omap-a15 = "d63cd6469fff610317a8e1c986f227bb3e7922f6" |
14 | SRCREV_ti33x = "c30d4b35701e1b88d58a9ae713b2e679298d1a37" | ||
15 | SRCREV_ti43x = "c30d4b35701e1b88d58a9ae713b2e679298d1a37" | ||
16 | |||
17 | INITSCRIPT_NAME = "pvr-init" | ||
18 | INITSCRIPT_PARAMS = "defaults 8" | ||
19 | |||
20 | inherit update-rc.d | ||
10 | 21 | ||
11 | PR = "r9" | 22 | PR = "r10" |
12 | PROVIDES += "virtual/egl virtual/libgles1 virtual/libgles2" | 23 | PROVIDES += "virtual/egl virtual/libgles1 virtual/libgles2" |
13 | 24 | ||
14 | RREPLACES_${PN} = "libegl libgles1 libgles2" | 25 | RREPLACES_${PN} = "libegl libgles1 libgles2" |
@@ -17,13 +28,25 @@ RREPLACES_${PN}-dbg = "libegl-dbg" | |||
17 | 28 | ||
18 | S = "${WORKDIR}/git" | 29 | S = "${WORKDIR}/git" |
19 | 30 | ||
31 | SRC_URI_append = " \ | ||
32 | file://rc.pvr \ | ||
33 | file://powervr.ini \ | ||
34 | " | ||
35 | |||
20 | do_install () { | 36 | do_install () { |
21 | oe_runmake install DESTDIR=${D} | 37 | oe_runmake install DESTDIR=${D} |
38 | install -d ${D}${sysconfdir}/init.d | ||
39 | install -m 0755 ${WORKDIR}/rc.pvr ${D}${sysconfdir}/init.d/pvr-init | ||
40 | |||
41 | install -d ${D}${sysconfdir} | ||
42 | install -m 0644 ${WORKDIR}/powervr.ini ${D}${sysconfdir}/ | ||
22 | } | 43 | } |
23 | 44 | ||
24 | FILES_${PN} = "${bindir}/*" | 45 | FILES_${PN} = "${bindir}/*" |
25 | FILES_${PN} += " ${libdir}/*" | 46 | FILES_${PN} += " ${libdir}/*" |
26 | FILES_${PN} += "${includedir}/* /usr/share/sgx-lib/" | 47 | FILES_${PN} += "${includedir}/* /usr/share/sgx-lib/" |
48 | FILES_${PN} += "${sysconfdir}/init.d/pvr-init" | ||
49 | FILES_${PN} += "${sysconfdir}/powervr.ini" | ||
27 | 50 | ||
28 | INHIBIT_PACKAGE_STRIP = "1" | 51 | INHIBIT_PACKAGE_STRIP = "1" |
29 | 52 | ||