summaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
authorThomas Perrot <thomas.perrot@tupi.fr>2016-12-08 01:39:49 +0000
committerDenys Dmytriyenko <denys@ti.com>2016-12-20 16:40:50 -0500
commitd8827afedc66b610f1fc9c5990bc4271917643b6 (patch)
tree6efcac2124c283f8c0aaf9316aac6719e44967bd /recipes-graphics
parent1c0dc51920d5b5bb5a0f2496bc9a0b6679d89181 (diff)
downloadmeta-ti-d8827afedc66b610f1fc9c5990bc4271917643b6.tar.gz
recipes: fix build issue due to bb.data.* deprecation
Causes following error: Exception: AttributeError: module 'bb.data' has no attribute 'getVar' Signed-off-by: Thomas Perrot <thomas.perrot@tupi.fr> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/libgal/ti-gc320-libs_5.0.11.p7.bb6
-rw-r--r--recipes-graphics/libgles/ti-sgx-ddk-um_1.14.3699939.bb6
2 files changed, 6 insertions, 6 deletions
diff --git a/recipes-graphics/libgal/ti-gc320-libs_5.0.11.p7.bb b/recipes-graphics/libgal/ti-gc320-libs_5.0.11.p7.bb
index 45c8d519..394d1e4a 100644
--- a/recipes-graphics/libgal/ti-gc320-libs_5.0.11.p7.bb
+++ b/recipes-graphics/libgal/ti-gc320-libs_5.0.11.p7.bb
@@ -14,11 +14,11 @@ SRCREV = "ab0ca5bff345f6c13807fea3c4acabf5f2b9b10a"
14 14
15# There's only hardfp version available 15# There's only hardfp version available
16python __anonymous() { 16python __anonymous() {
17 tunes = bb.data.getVar("TUNE_FEATURES", d, 1) 17 tunes = d.getVar("TUNE_FEATURES", d, 1)
18 if not tunes: 18 if not tunes:
19 return 19 return
20 pkgn = bb.data.getVar("PN", d, 1) 20 pkgn = d.getVar("PN", d, 1)
21 pkgv = bb.data.getVar("PV", d, 1) 21 pkgv = d.getVar("PV", d, 1)
22 if "callconvention-hard" not in tunes: 22 if "callconvention-hard" not in tunes:
23 bb.warn("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv)) 23 bb.warn("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv))
24 raise bb.parse.SkipPackage("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv)) 24 raise bb.parse.SkipPackage("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv))
diff --git a/recipes-graphics/libgles/ti-sgx-ddk-um_1.14.3699939.bb b/recipes-graphics/libgles/ti-sgx-ddk-um_1.14.3699939.bb
index 5903b2e2..301bdd48 100644
--- a/recipes-graphics/libgles/ti-sgx-ddk-um_1.14.3699939.bb
+++ b/recipes-graphics/libgles/ti-sgx-ddk-um_1.14.3699939.bb
@@ -12,11 +12,11 @@ SRCREV = "3c0537748dd283b2de9c5369570aa2aade5a9979"
12 12
13# There's only hardfp version available 13# There's only hardfp version available
14python __anonymous() { 14python __anonymous() {
15 tunes = bb.data.getVar("TUNE_FEATURES", d, 1) 15 tunes = d.getVar("TUNE_FEATURES", d, 1)
16 if not tunes: 16 if not tunes:
17 return 17 return
18 pkgn = bb.data.getVar("PN", d, 1) 18 pkgn = d.getVar("PN", d, 1)
19 pkgv = bb.data.getVar("PV", d, 1) 19 pkgv = d.getVar("PV", d, 1)
20 if "callconvention-hard" not in tunes: 20 if "callconvention-hard" not in tunes:
21 bb.warn("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv)) 21 bb.warn("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv))
22 raise bb.parse.SkipPackage("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv)) 22 raise bb.parse.SkipPackage("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv))