summaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
authorEtheridge, Darren <detheridge@ti.com>2022-03-23 14:37:07 -0500
committerRyan Eatmon <reatmon@ti.com>2022-04-07 07:48:39 -0500
commited94c75b436f2f8c5c3a8a6ebed45d7276cc35e4 (patch)
tree400e4a95765e82581637257d28607fb087357392 /recipes-graphics
parent1ab91bcc154909f5ba8e04a866836773fa9430e4 (diff)
downloadmeta-ti-ed94c75b436f2f8c5c3a8a6ebed45d7276cc35e4.tar.gz
ti-graphics: gpu enable and move all platforms to ddk 1.15
Enable the GPU for am62xx and j721s2 and use IMG DDK 1.15 Migrate Imagination DDK 1.13 to DDK 1.15 for J721e Signed-off-by: Darren Etheridge <detheridge@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/libgles/ti-img-rogue-umlibs_1.15.6133109.bb (renamed from recipes-graphics/libgles/ti-img-rogue-umlibs_1.13.5776728.bb)13
1 files changed, 7 insertions, 6 deletions
diff --git a/recipes-graphics/libgles/ti-img-rogue-umlibs_1.13.5776728.bb b/recipes-graphics/libgles/ti-img-rogue-umlibs_1.15.6133109.bb
index 5194015e..e00dce99 100644
--- a/recipes-graphics/libgles/ti-img-rogue-umlibs_1.13.5776728.bb
+++ b/recipes-graphics/libgles/ti-img-rogue-umlibs_1.15.6133109.bb
@@ -8,17 +8,18 @@ inherit features_check
8REQUIRED_MACHINE_FEATURES = "gpu" 8REQUIRED_MACHINE_FEATURES = "gpu"
9 9
10PACKAGE_ARCH = "${MACHINE_ARCH}" 10PACKAGE_ARCH = "${MACHINE_ARCH}"
11COMPATIBLE_MACHINE = "j7" 11COMPATIBLE_MACHINE = "j7-evm|j721s2-evm|am62xx"
12 12
13PR = "r3" 13PR = "r1"
14 14
15BRANCH = "linuxws/dunfell/k5.10/${PV}" 15BRANCH = "linuxws/dunfell/k5.10/${PV}"
16 16
17SRC_URI = "git://git.ti.com/graphics/ti-img-rogue-umlibs.git;branch=${BRANCH}" 17SRC_URI = "git://git.ti.com/graphics/ti-img-rogue-umlibs.git;branch=${BRANCH}"
18SRCREV = "47c3ffc44f2881397d45c8a2b5dfa7d6c58b79fb"
18 19
19SRCREV = "5ef38353c38d921a65ea6df75c7b6ce710b66034" 20TARGET_PRODUCT_j7-evm = "j721e_linux"
20 21TARGET_PRODUCT_j721s2-evm = "j721s2_linux"
21PVR_SOC ?= "j721e_linux" 22TARGET_PRODUCT_am62xx = "am62_linux"
22PVR_BUILD ?= "release" 23PVR_BUILD ?= "release"
23PVR_WS = "wayland" 24PVR_WS = "wayland"
24 25
@@ -50,7 +51,7 @@ RRECOMMENDS_${PN} += "ti-img-rogue-driver"
50S = "${WORKDIR}/git" 51S = "${WORKDIR}/git"
51 52
52do_install () { 53do_install () {
53 oe_runmake install DESTDIR=${D} TARGET_PRODUCT=${PVR_SOC} BUILD=${PVR_BUILD} WINDOW_SYSTEM=${PVR_WS} 54 oe_runmake install DESTDIR=${D} TARGET_PRODUCT=${TARGET_PRODUCT} BUILD=${PVR_BUILD} WINDOW_SYSTEM=${PVR_WS}
54 chown -R root:root ${D} 55 chown -R root:root ${D}
55} 56}
56 57