diff options
author | Denys Dmytriyenko <denys@ti.com> | 2013-09-12 21:34:47 -0400 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2013-09-13 12:07:52 -0400 |
commit | 499fba5e6c634c061d377971a73d1e0116676257 (patch) | |
tree | 27c2de4335ed32db7ab8a668e54058c37bc26b21 /recipes-graphics | |
parent | bb8ab63ea937951ef4e53b60237319df9bd7822b (diff) | |
download | meta-ti-499fba5e6c634c061d377971a73d1e0116676257.tar.gz |
libgles-omap3: add automatic selection between softfp and hardfp binaries
This is based on the work by Franklin Cooper, with following changes:
* Cleanup and simplify the logic
* Reduce the number of Python calls
* Expand support from Raw to X11 variant
The original description:
* The Graphics SDK includes some binaries that are prebuilt.
* These prebuilt binaries come in two versions of the Graphics SDK. By default
the prebuilt binaries are built using a softfp toolchain. A separate hardfp
Graphics SDK exist that contains binaries that are prebuilt with a hardfp
toolchain.
* Add support for both by checking to see if the toolchain used in the OE build
is using a hardfp or softfp toolchain.
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Cc: Franklin S. Cooper Jr <fcooper@ti.com>
Acked-by: Chase Maupin <chase.maupin@ti.com>
Diffstat (limited to 'recipes-graphics')
-rw-r--r-- | recipes-graphics/libgles/libgles-omap3-x11_4.09.00.01.bb | 23 | ||||
-rw-r--r-- | recipes-graphics/libgles/libgles-omap3_4.09.00.01.bb | 23 |
2 files changed, 36 insertions, 10 deletions
diff --git a/recipes-graphics/libgles/libgles-omap3-x11_4.09.00.01.bb b/recipes-graphics/libgles/libgles-omap3-x11_4.09.00.01.bb index 6b9c5613..df84f9b3 100644 --- a/recipes-graphics/libgles/libgles-omap3-x11_4.09.00.01.bb +++ b/recipes-graphics/libgles/libgles-omap3-x11_4.09.00.01.bb | |||
@@ -2,11 +2,11 @@ require libgles-omap3-x11.inc | |||
2 | 2 | ||
3 | LICENSE = "TSPA" | 3 | LICENSE = "TSPA" |
4 | 4 | ||
5 | PR = "${INC_PR}.0" | 5 | PR = "${INC_PR}.1" |
6 | 6 | ||
7 | DEFAULT_PREFERENCE = "-1" | 7 | DEFAULT_PREFERENCE = "-1" |
8 | 8 | ||
9 | BINLOCATION_omap3 = "${S}/gfx_rel_es3.x" | 9 | BINLOCATION_omap3 = "${S}/gfx_rel_es3.x" |
10 | BINLOCATION_ti816x = "${S}/gfx_rel_es6.x" | 10 | BINLOCATION_ti816x = "${S}/gfx_rel_es6.x" |
11 | BINLOCATION_ti814x = "${S}/gfx_rel_es6.x" | 11 | BINLOCATION_ti814x = "${S}/gfx_rel_es6.x" |
12 | BINLOCATION_ti33x = "${S}/gfx_rel_es8.x" | 12 | BINLOCATION_ti33x = "${S}/gfx_rel_es8.x" |
@@ -20,8 +20,20 @@ PVR_INIT = "pvrsrvctl" | |||
20 | 20 | ||
21 | SGXPV = "4_09_00_01" | 21 | SGXPV = "4_09_00_01" |
22 | IMGPV = "1.9.2188537" | 22 | IMGPV = "1.9.2188537" |
23 | BINFILE = "Graphics_SDK_setuplinux_${SGXPV}_minimal_demos.bin" | 23 | |
24 | TI_BIN_UNPK_WDEXT := "/Graphics_SDK_${SGXPV}" | 24 | TI_BIN_UNPK_WDEXT := "/Graphics_SDK_${SGXPV}" |
25 | |||
26 | # Select the corresponding hardfp/softfp filename and checksums based on tune flags | ||
27 | BINFILE_SOFTFP = "Graphics_SDK_setuplinux_${SGXPV}_minimal_demos.bin" | ||
28 | MD5SUM_SOFTFP = "bd35e9d8843aff3a2aca9d41e7db1c7d" | ||
29 | SHA256SUM_SOFTFP = "eb37f75ddde4640b09e760fa86e689beb394330ecdf68786188c34f249247647" | ||
30 | |||
31 | BINFILE_HARDFP = "Graphics_SDK_setuplinux_${SGXPV}_hardfp_minimal_demos.bin" | ||
32 | MD5SUM_HARDFP = "c9f656dce062d1ab10afffd4dfb71b67" | ||
33 | SHA256SUM_HARDFP = "dbfeba8e1298f139495816334edec1455e6b49b1e11bd1b2aa0a888e5788bb6b" | ||
34 | |||
35 | BINFILE = "${@base_contains('TUNE_FEATURES', 'callconvention-hard', '${BINFILE_HARDFP}', '${BINFILE_SOFTFP}', d)}" | ||
36 | |||
25 | SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gfxsdk/${SGXPV}/exports/${BINFILE} \ | 37 | SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gfxsdk/${SGXPV}/exports/${BINFILE} \ |
26 | file://cputype \ | 38 | file://cputype \ |
27 | file://rc.pvr \ | 39 | file://rc.pvr \ |
@@ -29,8 +41,9 @@ SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gf | |||
29 | file://sample.desktop \ | 41 | file://sample.desktop \ |
30 | file://99-bufferclass.rules \ | 42 | file://99-bufferclass.rules \ |
31 | " | 43 | " |
32 | SRC_URI[md5sum] = "bd35e9d8843aff3a2aca9d41e7db1c7d" | 44 | |
33 | SRC_URI[sha256sum] = "eb37f75ddde4640b09e760fa86e689beb394330ecdf68786188c34f249247647" | 45 | SRC_URI[md5sum] = "${@base_contains('TUNE_FEATURES', 'callconvention-hard', '${MD5SUM_HARDFP}', '${MD5SUM_SOFTFP}', d)}" |
46 | SRC_URI[sha256sum] = "${@base_contains('TUNE_FEATURES', 'callconvention-hard', '${SHA256SUM_HARDFP}', '${SHA256SUM_SOFTFP}', d)}" | ||
34 | 47 | ||
35 | S = "${WORKDIR}/Graphics_SDK_${SGXPV}" | 48 | S = "${WORKDIR}/Graphics_SDK_${SGXPV}" |
36 | 49 | ||
diff --git a/recipes-graphics/libgles/libgles-omap3_4.09.00.01.bb b/recipes-graphics/libgles/libgles-omap3_4.09.00.01.bb index a4da2f99..6899cfc7 100644 --- a/recipes-graphics/libgles/libgles-omap3_4.09.00.01.bb +++ b/recipes-graphics/libgles/libgles-omap3_4.09.00.01.bb | |||
@@ -2,11 +2,11 @@ require libgles-omap3-no-x.inc | |||
2 | 2 | ||
3 | LICENSE = "TSPA" | 3 | LICENSE = "TSPA" |
4 | 4 | ||
5 | PR = "${INC_PR}.0" | 5 | PR = "${INC_PR}.1" |
6 | 6 | ||
7 | DEFAULT_PREFERENCE = "-1" | 7 | DEFAULT_PREFERENCE = "-1" |
8 | 8 | ||
9 | BINLOCATION_omap3 = "${S}/gfx_rel_es3.x" | 9 | BINLOCATION_omap3 = "${S}/gfx_rel_es3.x" |
10 | BINLOCATION_ti816x = "${S}/gfx_rel_es6.x" | 10 | BINLOCATION_ti816x = "${S}/gfx_rel_es6.x" |
11 | BINLOCATION_ti814x = "${S}/gfx_rel_es6.x" | 11 | BINLOCATION_ti814x = "${S}/gfx_rel_es6.x" |
12 | BINLOCATION_ti33x = "${S}/gfx_rel_es8.x" | 12 | BINLOCATION_ti33x = "${S}/gfx_rel_es8.x" |
@@ -20,15 +20,28 @@ PVR_INIT = "pvrsrvctl" | |||
20 | 20 | ||
21 | SGXPV = "4_09_00_01" | 21 | SGXPV = "4_09_00_01" |
22 | IMGPV = "1.9.2188537" | 22 | IMGPV = "1.9.2188537" |
23 | BINFILE = "Graphics_SDK_setuplinux_${SGXPV}_minimal_demos.bin" | 23 | |
24 | TI_BIN_UNPK_WDEXT := "/Graphics_SDK_${SGXPV}" | 24 | TI_BIN_UNPK_WDEXT := "/Graphics_SDK_${SGXPV}" |
25 | |||
26 | # Select the corresponding hardfp/softfp filename and checksums based on tune flags | ||
27 | BINFILE_SOFTFP = "Graphics_SDK_setuplinux_${SGXPV}_minimal_demos.bin" | ||
28 | MD5SUM_SOFTFP = "bd35e9d8843aff3a2aca9d41e7db1c7d" | ||
29 | SHA256SUM_SOFTFP = "eb37f75ddde4640b09e760fa86e689beb394330ecdf68786188c34f249247647" | ||
30 | |||
31 | BINFILE_HARDFP = "Graphics_SDK_setuplinux_${SGXPV}_hardfp_minimal_demos.bin" | ||
32 | MD5SUM_HARDFP = "c9f656dce062d1ab10afffd4dfb71b67" | ||
33 | SHA256SUM_HARDFP = "dbfeba8e1298f139495816334edec1455e6b49b1e11bd1b2aa0a888e5788bb6b" | ||
34 | |||
35 | BINFILE = "${@base_contains('TUNE_FEATURES', 'callconvention-hard', '${BINFILE_HARDFP}', '${BINFILE_SOFTFP}', d)}" | ||
36 | |||
25 | SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gfxsdk/${SGXPV}/exports/${BINFILE} \ | 37 | SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gfxsdk/${SGXPV}/exports/${BINFILE} \ |
26 | file://cputype \ | 38 | file://cputype \ |
27 | file://rc.pvr \ | 39 | file://rc.pvr \ |
28 | file://99-bufferclass.rules \ | 40 | file://99-bufferclass.rules \ |
29 | " | 41 | " |
30 | SRC_URI[md5sum] = "bd35e9d8843aff3a2aca9d41e7db1c7d" | 42 | |
31 | SRC_URI[sha256sum] = "eb37f75ddde4640b09e760fa86e689beb394330ecdf68786188c34f249247647" | 43 | SRC_URI[md5sum] = "${@base_contains('TUNE_FEATURES', 'callconvention-hard', '${MD5SUM_HARDFP}', '${MD5SUM_SOFTFP}', d)}" |
44 | SRC_URI[sha256sum] = "${@base_contains('TUNE_FEATURES', 'callconvention-hard', '${SHA256SUM_HARDFP}', '${SHA256SUM_SOFTFP}', d)}" | ||
32 | 45 | ||
33 | S = "${WORKDIR}/Graphics_SDK_${SGXPV}" | 46 | S = "${WORKDIR}/Graphics_SDK_${SGXPV}" |
34 | 47 | ||