diff options
author | Denys Dmytriyenko <denys@ti.com> | 2016-04-21 00:32:27 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2016-04-20 16:50:28 -0400 |
commit | d82a408e1fddafcdf98d40cb10ba02fd1f52693b (patch) | |
tree | 7b98bad879a52c36574d37715590d3f12f3c319b /recipes-graphics | |
parent | feea83bfaf4c185f6081860df7e29409f7ebbcb0 (diff) | |
download | meta-ti-d82a408e1fddafcdf98d40cb10ba02fd1f52693b.tar.gz |
libdrm: drop outdated custom version, use latest upstream now
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-graphics')
-rw-r--r-- | recipes-graphics/drm/libdrm-2.4.41/installtests-ti.patch | 46 | ||||
-rw-r--r-- | recipes-graphics/drm/libdrm.inc | 41 | ||||
-rw-r--r-- | recipes-graphics/drm/libdrm_2.4.41.bb | 19 |
3 files changed, 0 insertions, 106 deletions
diff --git a/recipes-graphics/drm/libdrm-2.4.41/installtests-ti.patch b/recipes-graphics/drm/libdrm-2.4.41/installtests-ti.patch deleted file mode 100644 index ba325c01..00000000 --- a/recipes-graphics/drm/libdrm-2.4.41/installtests-ti.patch +++ /dev/null | |||
@@ -1,46 +0,0 @@ | |||
1 | tests: also install tests app (adjusted for TI version) | ||
2 | |||
3 | Upstream-Status: Inappropriate [configuration] | ||
4 | |||
5 | Signed-off-by: Denys Dmytriyenko <denys@ti.com> | ||
6 | |||
7 | diff -uNr git-orig/tests/Makefile.am git/tests/Makefile.am | ||
8 | --- git-orig/tests/Makefile.am 2013-08-10 16:26:30.000000000 -0400 | ||
9 | +++ git/tests/Makefile.am 2013-08-10 16:28:53.753855225 -0400 | ||
10 | @@ -6,10 +6,11 @@ | ||
11 | |||
12 | LDADD = $(top_builddir)/libdrm.la | ||
13 | |||
14 | -check_PROGRAMS = \ | ||
15 | +bin_PROGRAMS = \ | ||
16 | dristat \ | ||
17 | drmstat | ||
18 | |||
19 | +check_PROGRAMS = | ||
20 | dristat_LDADD = $(CLOCK_LIB) | ||
21 | |||
22 | SUBDIRS = modeprint | ||
23 | diff -uNr git-orig/tests/modeprint/Makefile.am git/tests/modeprint/Makefile.am | ||
24 | --- git-orig/tests/modeprint/Makefile.am 2013-08-10 16:26:30.000000000 -0400 | ||
25 | +++ git/tests/modeprint/Makefile.am 2013-08-10 16:28:53.753855225 -0400 | ||
26 | @@ -2,7 +2,7 @@ | ||
27 | -I$(top_srcdir)/include/drm \ | ||
28 | -I$(top_srcdir) | ||
29 | |||
30 | -noinst_PROGRAMS = \ | ||
31 | +bin_PROGRAMS = \ | ||
32 | modeprint | ||
33 | |||
34 | modeprint_SOURCES = \ | ||
35 | diff -uNr git-orig/tests/modetest/Makefile.am git/tests/modetest/Makefile.am | ||
36 | --- git-orig/tests/modetest/Makefile.am 2013-08-10 16:26:30.000000000 -0400 | ||
37 | +++ git/tests/modetest/Makefile.am 2013-08-10 16:28:53.753855225 -0400 | ||
38 | @@ -3,7 +3,7 @@ | ||
39 | -I$(top_srcdir)/libkms/ \ | ||
40 | -I$(top_srcdir) | ||
41 | |||
42 | -noinst_PROGRAMS = \ | ||
43 | +bin_PROGRAMS = \ | ||
44 | modetest | ||
45 | |||
46 | modetest_SOURCES = \ | ||
diff --git a/recipes-graphics/drm/libdrm.inc b/recipes-graphics/drm/libdrm.inc deleted file mode 100644 index d3e1e92b..00000000 --- a/recipes-graphics/drm/libdrm.inc +++ /dev/null | |||
@@ -1,41 +0,0 @@ | |||
1 | SUMMARY = "Userspace interface to the kernel DRM services" | ||
2 | DESCRIPTION = "The runtime library for accessing the kernel DRM services. DRM \ | ||
3 | stands for \"Direct Rendering Manager\", which is the kernel portion of the \ | ||
4 | \"Direct Rendering Infrastructure\" (DRI). DRI is required for many hardware \ | ||
5 | accelerated OpenGL drivers." | ||
6 | HOMEPAGE = "http://dri.freedesktop.org" | ||
7 | SECTION = "x11/base" | ||
8 | LICENSE = "MIT" | ||
9 | LIC_FILES_CHKSUM = "file://xf86drm.c;beginline=9;endline=32;md5=c8a3b961af7667c530816761e949dc71" | ||
10 | SRC_URI = "http://dri.freedesktop.org/libdrm/libdrm-${PV}.tar.bz2" | ||
11 | PROVIDES = "drm" | ||
12 | DEPENDS = "libpthread-stubs udev" | ||
13 | |||
14 | # be aware that libdrm_2.4.44.bb ignores this | ||
15 | INC_PR = "r4" | ||
16 | |||
17 | #libpciaccess is required starting from libdrm 2.4.26 | ||
18 | DEPENDS += " libpciaccess" | ||
19 | |||
20 | inherit autotools pkgconfig | ||
21 | |||
22 | EXTRA_OECONF += "--disable-cairo-tests \ | ||
23 | --enable-omap-experimental-api \ | ||
24 | --enable-install-test-programs \ | ||
25 | --disable-manpages \ | ||
26 | " | ||
27 | ALLOW_EMPTY_${PN}-drivers = "1" | ||
28 | PACKAGES =+ "${PN}-tests ${PN}-drivers ${PN}-radeon ${PN}-nouveau ${PN}-omap \ | ||
29 | ${PN}-intel ${PN}-exynos ${PN}-kms ${PN}-freedreno" | ||
30 | |||
31 | RRECOMMENDS_${PN}-drivers = "${PN}-radeon ${PN}-nouveau ${PN}-omap ${PN}-intel \ | ||
32 | ${PN}-exynos ${PN}-freedreno" | ||
33 | |||
34 | FILES_${PN}-tests = "${bindir}/dr* ${bindir}/mode* ${bindir}/*test" | ||
35 | FILES_${PN}-radeon = "${libdir}/libdrm_radeon.so.*" | ||
36 | FILES_${PN}-nouveau = "${libdir}/libdrm_nouveau.so.*" | ||
37 | FILES_${PN}-omap = "${libdir}/libdrm_omap.so.*" | ||
38 | FILES_${PN}-intel = "${libdir}/libdrm_intel.so.*" | ||
39 | FILES_${PN}-exynos = "${libdir}/libdrm_exynos.so.*" | ||
40 | FILES_${PN}-kms = "${libdir}/libkms*.so.*" | ||
41 | FILES_${PN}-freedreno = "${libdir}/libdrm_freedreno.so.*" | ||
diff --git a/recipes-graphics/drm/libdrm_2.4.41.bb b/recipes-graphics/drm/libdrm_2.4.41.bb deleted file mode 100644 index 86a660e3..00000000 --- a/recipes-graphics/drm/libdrm_2.4.41.bb +++ /dev/null | |||
@@ -1,19 +0,0 @@ | |||
1 | require recipes-graphics/drm/libdrm.inc | ||
2 | |||
3 | FILESEXTRAPATHS_append := ":${COREBASE}/meta/recipes-graphics/drm/libdrm" | ||
4 | |||
5 | COMPATIBLE_MACHINE = "ti33x|ti43x|omap-a15" | ||
6 | |||
7 | DEFAULT_PREFERENCE = "-1" | ||
8 | |||
9 | EXTRA_OECONF += "--enable-omap-experimental-api --enable-kms" | ||
10 | |||
11 | SRC_URI = "git://git.ti.com/glsdk/libdrm.git;protocol=git" | ||
12 | SRCREV = "3cb5405084111193cedb8796d259b56560b088f0" | ||
13 | |||
14 | SRC_URI += "file://installtests-ti.patch \ | ||
15 | " | ||
16 | |||
17 | PR = "${INC_PR}.2" | ||
18 | |||
19 | S = "${WORKDIR}/git" | ||