summaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
authore-ruei1@ti.com <e-ruei1@ti.com>2016-12-07 21:00:59 +0000
committerDenys Dmytriyenko <denys@ti.com>2016-12-07 14:50:06 -0500
commit92f46e91b8af67f34c6396bb0bd360181872c072 (patch)
tree4fad76e7db8e5e7b54cbfdd5aef508f364fa3d72 /recipes-graphics
parent76625a437d5180bf9753e7ef2552ab02f2beab0f (diff)
downloadmeta-ti-92f46e91b8af67f34c6396bb0bd360181872c072.tar.gz
ti-sgx-ddk-um: fix a bug at the drmModeAddFB() call at null_drm_ws.c
Both parameter depth and bpp are set to uiPixelWidthInBits at the current implementation, however, the depth may not be the same as bpp for certain pixel format such as XRGB8888. This bug was exposed by the recent DRM driver change introducing strict error checking. To fix this problem, add utility function uiPixelDepthInBits to derive and use depth based on the pixel format. Signed-off-by: Eric Ruei <e-ruei1@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/libgles/ti-sgx-ddk-um_1.14.3699939.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes-graphics/libgles/ti-sgx-ddk-um_1.14.3699939.bb b/recipes-graphics/libgles/ti-sgx-ddk-um_1.14.3699939.bb
index 770cda21..5903b2e2 100644
--- a/recipes-graphics/libgles/ti-sgx-ddk-um_1.14.3699939.bb
+++ b/recipes-graphics/libgles/ti-sgx-ddk-um_1.14.3699939.bb
@@ -8,7 +8,7 @@ PACKAGE_ARCH = "${MACHINE_ARCH}"
8BRANCH = "ti-img-sgx/${PV}" 8BRANCH = "ti-img-sgx/${PV}"
9 9
10SRC_URI = "git://git.ti.com/graphics/omap5-sgx-ddk-um-linux.git;protocol=git;branch=${BRANCH}" 10SRC_URI = "git://git.ti.com/graphics/omap5-sgx-ddk-um-linux.git;protocol=git;branch=${BRANCH}"
11SRCREV = "a5152f0b90bf3916eb1f478ac9fefe7d7ebe8bd9" 11SRCREV = "3c0537748dd283b2de9c5369570aa2aade5a9979"
12 12
13# There's only hardfp version available 13# There's only hardfp version available
14python __anonymous() { 14python __anonymous() {
@@ -31,7 +31,7 @@ INITSCRIPT_PARAMS = "defaults 8"
31 31
32inherit update-rc.d 32inherit update-rc.d
33 33
34PR = "r17" 34PR = "r18"
35PROVIDES += "virtual/egl virtual/libgles1 virtual/libgles2 omap5-sgx-ddk-um-linux" 35PROVIDES += "virtual/egl virtual/libgles1 virtual/libgles2 omap5-sgx-ddk-um-linux"
36 36
37DEPENDS += "libdrm udev libgbm wayland libffi" 37DEPENDS += "libdrm udev libgbm wayland libffi"