summaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-10-18 02:15:56 +0000
committerDenys Dmytriyenko <denys@ti.com>2018-10-17 22:48:34 +0000
commitb2d62f62bb6ecbb07577a0af9438bcaa017bf1da (patch)
tree768143c3403cc6ef78cd44119d25a59898b83483 /recipes-graphics
parent934fed368d0b6f2880d7e9768176a541a9bc189a (diff)
downloadmeta-ti-b2d62f62bb6ecbb07577a0af9438bcaa017bf1da.tar.gz
recipes: Limit ti specific recipes under ti-soc override
This helps in multi-BSP scenario, where other BSP layers are also present in the layermix Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/gbm/libgbm_10.0.0.bb3
-rw-r--r--recipes-graphics/libgal/ti-gc320-libs_5.0.11.p7.bb3
-rw-r--r--recipes-graphics/omapfbplay/omapfbplay.inc2
3 files changed, 8 insertions, 0 deletions
diff --git a/recipes-graphics/gbm/libgbm_10.0.0.bb b/recipes-graphics/gbm/libgbm_10.0.0.bb
index 38715ccf..9e3c7ed0 100644
--- a/recipes-graphics/gbm/libgbm_10.0.0.bb
+++ b/recipes-graphics/gbm/libgbm_10.0.0.bb
@@ -16,3 +16,6 @@ SRC_URI = "git://git.ti.com/glsdk/libgbm.git;protocol=git;branch=${BRANCH} \
16 file://0001-gbm.c-include-sys-sysmacros.h-for-minor-major-in-new.patch" 16 file://0001-gbm.c-include-sys-sysmacros.h-for-minor-major-in-new.patch"
17 17
18S = "${WORKDIR}/git" 18S = "${WORKDIR}/git"
19
20COMPATIBLE_HOST ?= "null"
21COMPATIBLE_HOST_ti-soc = "(.*)"
diff --git a/recipes-graphics/libgal/ti-gc320-libs_5.0.11.p7.bb b/recipes-graphics/libgal/ti-gc320-libs_5.0.11.p7.bb
index dafaac1e..a2f8f192 100644
--- a/recipes-graphics/libgal/ti-gc320-libs_5.0.11.p7.bb
+++ b/recipes-graphics/libgal/ti-gc320-libs_5.0.11.p7.bb
@@ -37,3 +37,6 @@ do_install() {
37} 37}
38 38
39INSANE_SKIP_${PN} += "ldflags" 39INSANE_SKIP_${PN} += "ldflags"
40
41COMPATIBLE_HOST ?= "null"
42COMPATIBLE_HOST_ti-soc = "(.*)"
diff --git a/recipes-graphics/omapfbplay/omapfbplay.inc b/recipes-graphics/omapfbplay/omapfbplay.inc
index df166dd3..744eb8f7 100644
--- a/recipes-graphics/omapfbplay/omapfbplay.inc
+++ b/recipes-graphics/omapfbplay/omapfbplay.inc
@@ -14,6 +14,8 @@ SRC_URI = "git://git.mansr.com/omapfbplay;protocol=git \
14S = "${WORKDIR}/git" 14S = "${WORKDIR}/git"
15 15
16PACKAGE_ARCH = "${MACHINE_ARCH}" 16PACKAGE_ARCH = "${MACHINE_ARCH}"
17COMPATIBLE_HOST ?= "null"
18COMPATIBLE_HOST_ti-soc = "(.*)"
17 19
18# We want a kernel header for armv7a, but we don't want to make mplayer machine specific for that 20# We want a kernel header for armv7a, but we don't want to make mplayer machine specific for that
19STAGING_KERNEL_DIR = "${STAGING_DIR}/${MACHINE_ARCH}${TARGET_VENDOR}-${TARGET_OS}/kernel" 21STAGING_KERNEL_DIR = "${STAGING_DIR}/${MACHINE_ARCH}${TARGET_VENDOR}-${TARGET_OS}/kernel"