summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/libgles
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2018-07-10 07:06:01 +0000
committerDenys Dmytriyenko <denys@ti.com>2018-07-10 18:39:09 +0000
commita5ecd90543b0842555662ea92e129d78e6f8c08b (patch)
treee78c524c27bd0922dbe64879c84fa2405dd6e30e /recipes-graphics/libgles
parentf64a19d3e99027030decbf4ae9760f3a22a4e584 (diff)
downloadmeta-ti-a5ecd90543b0842555662ea92e129d78e6f8c08b.tar.gz
meta-ti: cleanup use of d.getVar()
1. drop use of True as second parameter, which is default, to align with master 2. there were instances of incorrectly passing 'd' as second parameter from previous conversion from bb.data.getVar() usage Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-graphics/libgles')
-rw-r--r--recipes-graphics/libgles/ti-sgx-ddk-um_1.14.3699939.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/recipes-graphics/libgles/ti-sgx-ddk-um_1.14.3699939.bb b/recipes-graphics/libgles/ti-sgx-ddk-um_1.14.3699939.bb
index 282a4ab2..d17411ec 100644
--- a/recipes-graphics/libgles/ti-sgx-ddk-um_1.14.3699939.bb
+++ b/recipes-graphics/libgles/ti-sgx-ddk-um_1.14.3699939.bb
@@ -12,11 +12,11 @@ SRCREV = "358fe42d34a7570896e5d1639869da564ddd0484"
12 12
13# There's only hardfp version available 13# There's only hardfp version available
14python __anonymous() { 14python __anonymous() {
15 tunes = d.getVar("TUNE_FEATURES", d, 1) 15 tunes = d.getVar("TUNE_FEATURES")
16 if not tunes: 16 if not tunes:
17 return 17 return
18 pkgn = d.getVar("PN", d, 1) 18 pkgn = d.getVar("PN")
19 pkgv = d.getVar("PV", d, 1) 19 pkgv = d.getVar("PV")
20 if "callconvention-hard" not in tunes: 20 if "callconvention-hard" not in tunes:
21 bb.warn("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv)) 21 bb.warn("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv))
22 raise bb.parse.SkipPackage("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv)) 22 raise bb.parse.SkipPackage("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv))