summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/libgles/ti-sgx-ddk-um_1.14.3699939.bb
diff options
context:
space:
mode:
authorAnand Balagopalakrishnan <anandb@ti.com>2016-10-25 21:58:28 +0000
committerDenys Dmytriyenko <denys@ti.com>2016-10-25 18:52:43 -0400
commited280351e9a4e69093bd50286db5eb90d86f9761 (patch)
treeeb192fb974816f2952506f6e9b7e9866f8d0a8c7 /recipes-graphics/libgles/ti-sgx-ddk-um_1.14.3699939.bb
parent3f83f7f68a933311bf7a1c38e712cf9f8ed2f00e (diff)
downloadmeta-ti-ed280351e9a4e69093bd50286db5eb90d86f9761.tar.gz
ti-sgx-ddk-um: add support for importing DMABUF as EGLImage
This patch adds support for importing DMABUFs as EGLImages. This work is based on the Spec defined in https://www.khronos.org/registry/egl/extensions/EXT/EGL_EXT_image_dma_buf_import.txt The feature currently supports YUYV and NV12 formats In addition, the following are supported: * YUV full range and narrow range * YUV color space BT709 and BT601 * YUV color space BT2020 is not supported * Chroma siting parameters are ignored For YUYV buffers, user needs to pass the width, height, and a 3-tuple consisting of the dmabuf fd, pitch, and offset=0. For YUV buffers, user needs to pass the width, height and two 3-tuples consisting of the dmabuf fds, pitches, and offsets=0. Please note that multiple dmabuf fds are not supported, and therefore, for NV12, * fd[0] must be equal to fd[1] and * pitch[0] must be equal to pitch[1] Signed-off-by: Anand Balagopalakrishnan <anandb@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-graphics/libgles/ti-sgx-ddk-um_1.14.3699939.bb')
-rw-r--r--recipes-graphics/libgles/ti-sgx-ddk-um_1.14.3699939.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes-graphics/libgles/ti-sgx-ddk-um_1.14.3699939.bb b/recipes-graphics/libgles/ti-sgx-ddk-um_1.14.3699939.bb
index 9d0c4061..15c92323 100644
--- a/recipes-graphics/libgles/ti-sgx-ddk-um_1.14.3699939.bb
+++ b/recipes-graphics/libgles/ti-sgx-ddk-um_1.14.3699939.bb
@@ -8,7 +8,7 @@ PACKAGE_ARCH = "${MACHINE_ARCH}"
8BRANCH = "ti-img-sgx/${PV}" 8BRANCH = "ti-img-sgx/${PV}"
9 9
10SRC_URI = "git://git.ti.com/graphics/omap5-sgx-ddk-um-linux.git;protocol=git;branch=${BRANCH}" 10SRC_URI = "git://git.ti.com/graphics/omap5-sgx-ddk-um-linux.git;protocol=git;branch=${BRANCH}"
11SRCREV = "f65d06843ef21964e266a7618c1529840653d563" 11SRCREV = "fccafce7d0a023e36c064ccbaa7d33e89252ea00"
12 12
13# There's only hardfp version available 13# There's only hardfp version available
14python __anonymous() { 14python __anonymous() {
@@ -31,7 +31,7 @@ INITSCRIPT_PARAMS = "defaults 8"
31 31
32inherit update-rc.d 32inherit update-rc.d
33 33
34PR = "r15" 34PR = "r16"
35PROVIDES += "virtual/egl virtual/libgles1 virtual/libgles2 omap5-sgx-ddk-um-linux" 35PROVIDES += "virtual/egl virtual/libgles1 virtual/libgles2 omap5-sgx-ddk-um-linux"
36 36
37DEPENDS += "libdrm udev libgbm wayland libffi" 37DEPENDS += "libdrm udev libgbm wayland libffi"