diff options
author | Etheridge, Darren <detheridge@ti.com> | 2022-03-23 14:37:07 -0500 |
---|---|---|
committer | Ryan Eatmon <reatmon@ti.com> | 2022-04-07 07:48:39 -0500 |
commit | ed94c75b436f2f8c5c3a8a6ebed45d7276cc35e4 (patch) | |
tree | 400e4a95765e82581637257d28607fb087357392 /recipes-graphics/libgles/ti-img-rogue-umlibs_1.15.6133109.bb | |
parent | 1ab91bcc154909f5ba8e04a866836773fa9430e4 (diff) | |
download | meta-ti-ed94c75b436f2f8c5c3a8a6ebed45d7276cc35e4.tar.gz |
ti-graphics: gpu enable and move all platforms to ddk 1.15
Enable the GPU for am62xx and j721s2 and use IMG DDK 1.15
Migrate Imagination DDK 1.13 to DDK 1.15 for J721e
Signed-off-by: Darren Etheridge <detheridge@ti.com>
Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'recipes-graphics/libgles/ti-img-rogue-umlibs_1.15.6133109.bb')
-rw-r--r-- | recipes-graphics/libgles/ti-img-rogue-umlibs_1.15.6133109.bb | 70 |
1 files changed, 70 insertions, 0 deletions
diff --git a/recipes-graphics/libgles/ti-img-rogue-umlibs_1.15.6133109.bb b/recipes-graphics/libgles/ti-img-rogue-umlibs_1.15.6133109.bb new file mode 100644 index 00000000..e00dce99 --- /dev/null +++ b/recipes-graphics/libgles/ti-img-rogue-umlibs_1.15.6133109.bb | |||
@@ -0,0 +1,70 @@ | |||
1 | DESCRIPTION = "Userspace libraries for PowerVR Rogue GPU on TI SoCs" | ||
2 | HOMEPAGE = "http://git.ti.com/graphics/ti-img-rogue-umlibs" | ||
3 | LICENSE = "TI-TFL" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=7232b98c1c58f99e3baa03de5207e76f" | ||
5 | |||
6 | inherit features_check | ||
7 | |||
8 | REQUIRED_MACHINE_FEATURES = "gpu" | ||
9 | |||
10 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
11 | COMPATIBLE_MACHINE = "j7-evm|j721s2-evm|am62xx" | ||
12 | |||
13 | PR = "r1" | ||
14 | |||
15 | BRANCH = "linuxws/dunfell/k5.10/${PV}" | ||
16 | |||
17 | SRC_URI = "git://git.ti.com/graphics/ti-img-rogue-umlibs.git;branch=${BRANCH}" | ||
18 | SRCREV = "47c3ffc44f2881397d45c8a2b5dfa7d6c58b79fb" | ||
19 | |||
20 | TARGET_PRODUCT_j7-evm = "j721e_linux" | ||
21 | TARGET_PRODUCT_j721s2-evm = "j721s2_linux" | ||
22 | TARGET_PRODUCT_am62xx = "am62_linux" | ||
23 | PVR_BUILD ?= "release" | ||
24 | PVR_WS = "wayland" | ||
25 | |||
26 | INITSCRIPT_NAME = "rc.pvr" | ||
27 | INITSCRIPT_PARAMS = "defaults 8" | ||
28 | |||
29 | inherit update-rc.d | ||
30 | |||
31 | PROVIDES += "virtual/egl virtual/libgles1 virtual/libgles2 virtual/libgbm" | ||
32 | |||
33 | DEPENDS += "libdrm wayland expat" | ||
34 | RDEPENDS_${PN} += "bash" | ||
35 | RDEPENDS_${PN} += "wayland expat" | ||
36 | |||
37 | RPROVIDES_${PN} = "libegl libgles1 libgles2 libgbm" | ||
38 | RPROVIDES_${PN}-dev = "libegl-dev libgles1-dev libgles2-dev libgbm-dev" | ||
39 | RPROVIDES_${PN}-dbg = "libegl-dbg libgles1-dbg libgles2-dbg" | ||
40 | |||
41 | RREPLACES_${PN} = "libegl libgles1 liblges2 libgbm" | ||
42 | RREPLACES_${PN}-dev = "libegl-dev libgles1-dev libgles2-dev libgbm-dev" | ||
43 | RREPLACES_${PN}-dbg = "libegl-dbg libgles1-dbg libgles2-dbg" | ||
44 | |||
45 | RCONFLICTS_${PN} = "libegl libgles1 libgles2 libgbm" | ||
46 | RCONFLICTS_${PN}-dev = "libegl-dev libgles1-dev libgles2-dev libgbm-dev" | ||
47 | RCONFLICTS_${PN}-dbg = "libegl-dbg libgles1-dbg libgles2-dbg" | ||
48 | |||
49 | RRECOMMENDS_${PN} += "ti-img-rogue-driver" | ||
50 | |||
51 | S = "${WORKDIR}/git" | ||
52 | |||
53 | do_install () { | ||
54 | oe_runmake install DESTDIR=${D} TARGET_PRODUCT=${TARGET_PRODUCT} BUILD=${PVR_BUILD} WINDOW_SYSTEM=${PVR_WS} | ||
55 | chown -R root:root ${D} | ||
56 | } | ||
57 | |||
58 | FILES_${PN} += " ${base_libdir}/firmware/" | ||
59 | FILES_${PN} += " ${datadir}/" | ||
60 | |||
61 | PACKAGES =+ "${PN}-plugins" | ||
62 | FILES_${PN}-plugins = "${libdir}/libGLESv2.so ${libdir}/libGLESv1_CM.so ${libdir}/libEGL.so ${libdir}/dri/pvr_dri.so" | ||
63 | RDEPENDS_${PN} += "${PN}-plugins" | ||
64 | |||
65 | ALLOW_EMPTY_${PN}-plugins = "1" | ||
66 | |||
67 | INSANE_SKIP_${PN} += "ldflags arch already-stripped" | ||
68 | INSANE_SKIP_${PN}-plugins = "dev-so" | ||
69 | |||
70 | CLEANBROKEN = "1" | ||