summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/libgles/libgles-omap3_5.00.00.01.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2013-11-21 20:53:50 -0500
committerDenys Dmytriyenko <denys@ti.com>2013-11-21 21:51:49 -0500
commitafcfeba4e6e01206952cbdbbc5805b416eb17491 (patch)
treedf0258c98111a0b098568f275c1dec8de6506516 /recipes-graphics/libgles/libgles-omap3_5.00.00.01.bb
parent767fd6ec4075eddb4c3d8c4c653f1ac77b4464e1 (diff)
downloadmeta-ti-afcfeba4e6e01206952cbdbbc5805b416eb17491.tar.gz
libgles-omap3: add new Graphics SDK 5.00.00.01 alpha release
* Adds initial support for AM43x platform * Supports 3.12 kernel for AM335x and AM43x Signed-off-by: Franklin S. Cooper Jr <fcooper@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-graphics/libgles/libgles-omap3_5.00.00.01.bb')
-rw-r--r--recipes-graphics/libgles/libgles-omap3_5.00.00.01.bb52
1 files changed, 52 insertions, 0 deletions
diff --git a/recipes-graphics/libgles/libgles-omap3_5.00.00.01.bb b/recipes-graphics/libgles/libgles-omap3_5.00.00.01.bb
new file mode 100644
index 00000000..be09ffa6
--- /dev/null
+++ b/recipes-graphics/libgles/libgles-omap3_5.00.00.01.bb
@@ -0,0 +1,52 @@
1require libgles-omap3-no-x.inc
2
3LICENSE = "TSPA"
4
5PR = "${INC_PR}.0"
6
7DEFAULT_PREFERENCE = "-1"
8
9BINLOCATION_omap3 = "${S}/gfx_rel_es3.x"
10BINLOCATION_ti816x = "${S}/gfx_rel_es6.x"
11BINLOCATION_ti814x = "${S}/gfx_rel_es6.x"
12BINLOCATION_ti33x = "${S}/gfx_rel_es8.x"
13BINLOCATION_ti43x = "${S}/gfx_rel_es9.x"
14
15PLATFORM = "LinuxARMV7"
16PVR_INIT = "pvrsrvctl"
17
18SGXPV = "5_00_00_01"
19IMGPV = "1.10.2359475"
20
21TI_BIN_UNPK_WDEXT := "/Graphics_SDK_${SGXPV}"
22
23BINFILE_HARDFP = "Graphics_SDK_setuplinux_${SGXPV}_alpha_hardfp_minimal_demos.bin"
24MD5SUM_HARDFP = "ae6125d7f8a313ea5c02afded893052d"
25SHA256SUM_HARDFP = "c2782a2f85024741722b936ec9dca66b858ae8561aa71b693f11e12d8c0385e0"
26
27# For now we only have hardfp version
28python __anonymous() {
29 tunes = bb.data.getVar("TUNE_FEATURES", d, 1)
30 if not tunes:
31 return
32 pkgn = bb.data.getVar("PN", d, 1)
33 pkgv = bb.data.getVar("PV", d, 1)
34 if "callconvention-hard" not in tunes:
35 bb.warn("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv))
36 raise bb.parse.SkipPackage("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv))
37}
38
39BINFILE := "${BINFILE_HARDFP}"
40
41SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/gfxsdk/${SGXPV}/exports/${BINFILE} \
42 file://cputype \
43 file://rc.pvr \
44 file://99-bufferclass.rules \
45"
46
47SRC_URI[md5sum] := "${MD5SUM_HARDFP}"
48SRC_URI[sha256sum] := "${SHA256SUM_HARDFP}"
49
50S = "${WORKDIR}/Graphics_SDK_${SGXPV}"
51
52LIBGLESWINDOWSYSTEM ?= "libpvrPVR2D_FRONTWSEGL.so.1"