diff options
author | Thomas Perrot <thomas.perrot@tupi.fr> | 2016-12-08 01:39:49 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2016-12-20 16:40:50 -0500 |
commit | d8827afedc66b610f1fc9c5990bc4271917643b6 (patch) | |
tree | 6efcac2124c283f8c0aaf9316aac6719e44967bd /recipes-graphics/libgal/ti-gc320-libs_5.0.11.p7.bb | |
parent | 1c0dc51920d5b5bb5a0f2496bc9a0b6679d89181 (diff) | |
download | meta-ti-d8827afedc66b610f1fc9c5990bc4271917643b6.tar.gz |
recipes: fix build issue due to bb.data.* deprecation
Causes following error:
Exception: AttributeError: module 'bb.data' has no attribute 'getVar'
Signed-off-by: Thomas Perrot <thomas.perrot@tupi.fr>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-graphics/libgal/ti-gc320-libs_5.0.11.p7.bb')
-rw-r--r-- | recipes-graphics/libgal/ti-gc320-libs_5.0.11.p7.bb | 6 |
1 files changed, 3 insertions, 3 deletions
diff --git a/recipes-graphics/libgal/ti-gc320-libs_5.0.11.p7.bb b/recipes-graphics/libgal/ti-gc320-libs_5.0.11.p7.bb index 45c8d519..394d1e4a 100644 --- a/recipes-graphics/libgal/ti-gc320-libs_5.0.11.p7.bb +++ b/recipes-graphics/libgal/ti-gc320-libs_5.0.11.p7.bb | |||
@@ -14,11 +14,11 @@ SRCREV = "ab0ca5bff345f6c13807fea3c4acabf5f2b9b10a" | |||
14 | 14 | ||
15 | # There's only hardfp version available | 15 | # There's only hardfp version available |
16 | python __anonymous() { | 16 | python __anonymous() { |
17 | tunes = bb.data.getVar("TUNE_FEATURES", d, 1) | 17 | tunes = d.getVar("TUNE_FEATURES", d, 1) |
18 | if not tunes: | 18 | if not tunes: |
19 | return | 19 | return |
20 | pkgn = bb.data.getVar("PN", d, 1) | 20 | pkgn = d.getVar("PN", d, 1) |
21 | pkgv = bb.data.getVar("PV", d, 1) | 21 | pkgv = d.getVar("PV", d, 1) |
22 | if "callconvention-hard" not in tunes: | 22 | if "callconvention-hard" not in tunes: |
23 | bb.warn("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv)) | 23 | bb.warn("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv)) |
24 | raise bb.parse.SkipPackage("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv)) | 24 | raise bb.parse.SkipPackage("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv)) |