diff options
author | Denys Dmytriyenko <denys@konsulko.com> | 2021-11-03 18:17:09 -0400 |
---|---|---|
committer | Yogesh Siraswar <yogeshs@ti.com> | 2021-11-12 12:23:40 +0000 |
commit | 4c6598f599ddd6e9678819449bd6be1fbdf338a7 (patch) | |
tree | 826e573278b2d22b487200552b752f34441e39c2 /recipes-devtools | |
parent | d209ac535fa9048364324976e8782628f8c7fe0e (diff) | |
download | meta-ti-4c6598f599ddd6e9678819449bd6be1fbdf338a7.tar.gz |
recipes: update github SRC_URIs
https://github.blog/2021-09-01-improving-git-protocol-security-github/
GitHub is deprecating unauthenticated protocols, including git:// so update
SRC_URIs with protocol=https
Explicitly pass branch=master where omitted, as bitbake now requires it.
While at it, update libion to the latest to eliminate upstreamed patch.
Signed-off-by: Denys Dmytriyenko <denys@konsulko.com>
Signed-off-by: Yogesh Siraswar <yogeshs@ti.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r-- | recipes-devtools/ion/libion/0001-cmake-Use-GNUInstallDirs-module-to-detect-install-pa.patch | 48 | ||||
-rw-r--r-- | recipes-devtools/ion/libion_git.bb | 6 |
2 files changed, 2 insertions, 52 deletions
diff --git a/recipes-devtools/ion/libion/0001-cmake-Use-GNUInstallDirs-module-to-detect-install-pa.patch b/recipes-devtools/ion/libion/0001-cmake-Use-GNUInstallDirs-module-to-detect-install-pa.patch deleted file mode 100644 index bf63ed32..00000000 --- a/recipes-devtools/ion/libion/0001-cmake-Use-GNUInstallDirs-module-to-detect-install-pa.patch +++ /dev/null | |||
@@ -1,48 +0,0 @@ | |||
1 | From 51eece2c291e121f9ae67c9b812617b885e76a64 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Wed, 18 Dec 2019 20:31:52 -0800 | ||
4 | Subject: [PATCH] cmake: Use GNUInstallDirs module to detect install paths | ||
5 | |||
6 | This helps it to calculate directories as per platform instead of | ||
7 | hardcoding them, helps compile it for arches which use /lib64 and | ||
8 | /usr/lib64 for libpaths | ||
9 | |||
10 | Upstream-Status: Submitted [https://github.com/glneo/libion/pull/2] | ||
11 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
12 | --- | ||
13 | CMakeLists.txt | 10 ++++++---- | ||
14 | 1 file changed, 6 insertions(+), 4 deletions(-) | ||
15 | |||
16 | diff --git a/CMakeLists.txt b/CMakeLists.txt | ||
17 | index 6e5928c..5b7c0de 100644 | ||
18 | --- a/CMakeLists.txt | ||
19 | +++ b/CMakeLists.txt | ||
20 | @@ -3,6 +3,8 @@ PROJECT(ion) | ||
21 | set(PROJECT_DESCRIPTION "ION Userspace Memory Allocator Library") | ||
22 | set(PROJECT_VERSION 1.0.0) | ||
23 | |||
24 | +INCLUDE(GNUInstallDirs) | ||
25 | + | ||
26 | add_library(ion | ||
27 | SHARED | ||
28 | src/libion.c | ||
29 | @@ -23,12 +25,12 @@ target_include_directories(ion | ||
30 | configure_file(libion.pc.in libion.pc @ONLY) | ||
31 | |||
32 | install(TARGETS ion | ||
33 | - LIBRARY DESTINATION lib | ||
34 | - PUBLIC_HEADER DESTINATION include/ion) | ||
35 | + LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR} | ||
36 | + PUBLIC_HEADER DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/ion) | ||
37 | |||
38 | install(DIRECTORY include/kernel-headers/4.19/ | ||
39 | - DESTINATION include | ||
40 | + DESTINATION ${CMAKE_INSTALL_INCLUDEDIR} | ||
41 | FILES_MATCHING PATTERN "*.h") | ||
42 | |||
43 | install(FILES ${CMAKE_BINARY_DIR}/libion.pc | ||
44 | - DESTINATION lib/pkgconfig) | ||
45 | + DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig) | ||
46 | -- | ||
47 | 2.24.1 | ||
48 | |||
diff --git a/recipes-devtools/ion/libion_git.bb b/recipes-devtools/ion/libion_git.bb index 4cf03afa..f5ca8e82 100644 --- a/recipes-devtools/ion/libion_git.bb +++ b/recipes-devtools/ion/libion_git.bb | |||
@@ -6,10 +6,8 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" | |||
6 | PV = "1.0.0" | 6 | PV = "1.0.0" |
7 | 7 | ||
8 | BRANCH = "master" | 8 | BRANCH = "master" |
9 | SRC_URI = "git://github.com/glneo/libion.git;protocol=git;branch=${BRANCH} \ | 9 | SRC_URI = "git://github.com/glneo/libion.git;protocol=https;branch=${BRANCH}" |
10 | file://0001-cmake-Use-GNUInstallDirs-module-to-detect-install-pa.patch \ | 10 | SRCREV = "7e138fc31febbb67734792c1a911439bfd6d23eb" |
11 | " | ||
12 | SRCREV = "813bd63e2f2118e17cb1c5d38505a1e572a2381c" | ||
13 | 11 | ||
14 | S = "${WORKDIR}/git" | 12 | S = "${WORKDIR}/git" |
15 | 13 | ||