summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorJacob Stiffler <j-stiffler@ti.com>2015-05-20 19:38:23 +0000
committerDenys Dmytriyenko <denys@ti.com>2015-05-22 12:37:41 -0400
commit63f1954c616ea32a0fbc6f5408ad3dd330a6c324 (patch)
tree1ba364bca59c3c35e8a222761fbdc2218ee3cd74 /recipes-devtools
parent5f79e6fcaff436ef484ceb22571d84088b35478f (diff)
downloadmeta-ti-63f1954c616ea32a0fbc6f5408ad3dd330a6c324.tar.gz
gdbserverproxy-module-drv: Add version 1.1.0
Signed-off-by: Jacob Stiffler <j-stiffler@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/gdbc6x/gdbc6x.inc8
-rw-r--r--recipes-devtools/gdbc6x/gdbserverproxy-module-drv_git.bb32
2 files changed, 40 insertions, 0 deletions
diff --git a/recipes-devtools/gdbc6x/gdbc6x.inc b/recipes-devtools/gdbc6x/gdbc6x.inc
new file mode 100644
index 00000000..8256127a
--- /dev/null
+++ b/recipes-devtools/gdbc6x/gdbc6x.inc
@@ -0,0 +1,8 @@
1# This corresponds to version 1.1.0
2SRCREV = "1ab06f8bcfe7540754558bac331a0312c4b59142"
3PV = "1.1.0"
4INC_PR = "r0"
5
6SRC_URI = "git://git.ti.com/sdo-emu/gdbc6x.git;protocol=git;branch=${BRANCH}"
7
8BRANCH = "master"
diff --git a/recipes-devtools/gdbc6x/gdbserverproxy-module-drv_git.bb b/recipes-devtools/gdbc6x/gdbserverproxy-module-drv_git.bb
new file mode 100644
index 00000000..4dedb83b
--- /dev/null
+++ b/recipes-devtools/gdbc6x/gdbserverproxy-module-drv_git.bb
@@ -0,0 +1,32 @@
1DESCRIPTION = "Interface for GDB to commincate witha TI C66X DSP"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING.txt;md5=75859989545e37968a99b631ef42722e"
4
5# This package builds a kernel module, use kernel PR as base and append a local
6MACHINE_KERNEL_PR_append = "a"
7PR = "${MACHINE_KERNEL_PR}"
8PV_append = "+git${SRCPV}"
9
10S = "${WORKDIR}/git/kernel_module/gdbproxy-mod"
11
12inherit module
13
14PLATFORM = ""
15PLATFORM_dra7xx = "DRA7xx_PLATFORM"
16PLATFORM_keystone = "KEYSTONE_PLATFORM"
17
18EXTRA_OEMAKE = "PLATFORM=${PLATFORM}"
19
20# The following is to prevent an unused configure.ac from erroneously
21# triggering the QA check for gettext.
22EXTRA_OECONF = "--disable-nls"
23do_configure() {
24 :
25}
26
27COMPATIBLE_MACHINE = "dra7xx|keystone"
28PACKAGE_ARCH = "${MACHINE_ARCH}"
29
30include gdbc6x.inc
31
32module_autoload_gdbserverproxy = "gdbserverproxy"