summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2019-09-13 09:21:44 +0000
committerDenys Dmytriyenko <denys@ti.com>2019-09-13 03:32:12 +0000
commit4c3b6121713b5c2caeedc374fd68044902faccd9 (patch)
tree348dd0ae4a69559588d1aef6ceb6d2ad95c30e98 /recipes-devtools
parente1757509f9e73dcacf5e033aa0910e61bd215289 (diff)
downloadmeta-ti-4c3b6121713b5c2caeedc374fd68044902faccd9.tar.gz
ion: add libion and ion-tests packages for ION support
ION Userspace Memory Allocator Library and tests Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/ion/ion-tests/0001-CMakeLists.txt-disable-phys-addr-for-now.patch34
-rw-r--r--recipes-devtools/ion/ion-tests_git.bb18
-rw-r--r--recipes-devtools/ion/libion_git.bb14
3 files changed, 66 insertions, 0 deletions
diff --git a/recipes-devtools/ion/ion-tests/0001-CMakeLists.txt-disable-phys-addr-for-now.patch b/recipes-devtools/ion/ion-tests/0001-CMakeLists.txt-disable-phys-addr-for-now.patch
new file mode 100644
index 00000000..7cf5895c
--- /dev/null
+++ b/recipes-devtools/ion/ion-tests/0001-CMakeLists.txt-disable-phys-addr-for-now.patch
@@ -0,0 +1,34 @@
1From 85264fc72a261d20107a50ea2fad0258900a132b Mon Sep 17 00:00:00 2001
2From: Denys Dmytriyenko <denys@ti.com>
3Date: Sat, 20 Apr 2019 16:54:03 +0000
4Subject: [PATCH] CMakeLists.txt: disable phys-addr for now
5
6Signed-off-by: Denys Dmytriyenko <denys@ti.com>
7---
8 CMakeLists.txt | 13 -------------
9 1 file changed, 13 deletions(-)
10
11diff --git a/CMakeLists.txt b/CMakeLists.txt
12index 1d60003..eca6ba7 100644
13--- a/CMakeLists.txt
14+++ b/CMakeLists.txt
15@@ -54,16 +54,3 @@ target_link_libraries(ion-print-heaps
16 target_include_directories(ion-print-heaps PUBLIC ${LIBION_INCLUDE_DIRS})
17
18 install(TARGETS ion-print-heaps RUNTIME DESTINATION bin)
19-
20-# phys-addr
21-
22-add_executable(phys-addr
23- src/phys-addr.c
24-)
25-
26-target_link_libraries(phys-addr
27- ${LIBION_LIBRARIES}
28-)
29-target_include_directories(phys-addr PUBLIC ${LIBION_INCLUDE_DIRS})
30-
31-install(TARGETS phys-addr RUNTIME DESTINATION bin)
32--
332.17.1
34
diff --git a/recipes-devtools/ion/ion-tests_git.bb b/recipes-devtools/ion/ion-tests_git.bb
new file mode 100644
index 00000000..831f5e8c
--- /dev/null
+++ b/recipes-devtools/ion/ion-tests_git.bb
@@ -0,0 +1,18 @@
1SUMMARY = "Test cases for ION"
2HOMEPAGE = "https://github.com/glneo/ion-tests"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://src/ion_test.c;beginline=1;endline=15;md5=b225db900869a4cd31461606e55a3ec5"
5
6PV = "1.0"
7
8BRANCH = "master"
9SRC_URI = "git://github.com/glneo/ion-tests.git;protocol=git;branch=${BRANCH} \
10 file://0001-CMakeLists.txt-disable-phys-addr-for-now.patch \
11"
12SRCREV = "70d730cebca29e6fd37b21d9beac82ae645f3900"
13
14DEPENDS = "libion gtest"
15
16S = "${WORKDIR}/git"
17
18inherit cmake pkgconfig
diff --git a/recipes-devtools/ion/libion_git.bb b/recipes-devtools/ion/libion_git.bb
new file mode 100644
index 00000000..7c93ed3f
--- /dev/null
+++ b/recipes-devtools/ion/libion_git.bb
@@ -0,0 +1,14 @@
1SUMMARY = "ION Userspace Memory Allocator Library"
2HOMEPAGE = "https://github.com/glneo/libion"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
5
6PV = "1.0.0"
7
8BRANCH = "master"
9SRC_URI = "git://github.com/glneo/libion.git;protocol=git;branch=${BRANCH}"
10SRCREV = "11dad7977ec3ecba37c013da7ec0408c01413000"
11
12S = "${WORKDIR}/git"
13
14inherit cmake pkgconfig