diff options
author | Denys Dmytriyenko <denys@ti.com> | 2017-12-19 12:01:29 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2017-12-19 13:42:34 -0500 |
commit | 59e8f8a70e4e148bdba61cfceed009ab340898a6 (patch) | |
tree | 49e94694a3f1a0f6bff6553223b1e5ee98c395a3 /recipes-devtools | |
parent | 0ef857ab31f82a2ea03a96011009f92076e8fddf (diff) | |
download | meta-ti-59e8f8a70e4e148bdba61cfceed009ab340898a6.tar.gz |
doxygen: import from meta-arago
Many LLD and RTOS components in meta-ti use doxygen during build.
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r-- | recipes-devtools/doxygen/doxygen/patch-flex_2_6_0.diff | 66 | ||||
-rw-r--r-- | recipes-devtools/doxygen/doxygen_1.8.9.1.bb | 34 |
2 files changed, 100 insertions, 0 deletions
diff --git a/recipes-devtools/doxygen/doxygen/patch-flex_2_6_0.diff b/recipes-devtools/doxygen/doxygen/patch-flex_2_6_0.diff new file mode 100644 index 00000000..36d73798 --- /dev/null +++ b/recipes-devtools/doxygen/doxygen/patch-flex_2_6_0.diff | |||
@@ -0,0 +1,66 @@ | |||
1 | --- src/code.l.orig | ||
2 | +++ src/code.l | ||
3 | @@ -3695,7 +3695,7 @@ void codeFreeScanner() | ||
4 | extern "C" { // some bogus code to keep the compiler happy | ||
5 | void codeYYdummy() { yy_flex_realloc(0,0); } | ||
6 | } | ||
7 | -#elif YY_FLEX_SUBMINOR_VERSION<33 | ||
8 | +#elif YY_FLEX_MAJOR_VERSION<=2 && YY_FLEX_MINOR_VERSION<=5 && YY_FLEX_SUBMINOR_VERSION<33 | ||
9 | #error "You seem to be using a version of flex newer than 2.5.4 but older than 2.5.33. These versions do NOT work with doxygen! Please use version <=2.5.4 or >=2.5.33 or expect things to be parsed wrongly!" | ||
10 | #endif | ||
11 | |||
12 | --- src/commentscan.l.orig | ||
13 | +++ src/commentscan.l | ||
14 | @@ -1098,7 +1098,7 @@ RCSTAG "$"{ID}":"[^\n$]+"$" | ||
15 | // but we need to know the position in the input buffer where this | ||
16 | // rule matched. | ||
17 | // for flex 2.5.33+ we should use YY_CURRENT_BUFFER_LVALUE | ||
18 | -#if YY_FLEX_MINOR_VERSION>=5 && YY_FLEX_SUBMINOR_VERSION>=33 | ||
19 | +#if YY_FLEX_MAJOR_VERSION>=2 && (YY_FLEX_MINOR_VERSION>5 || (YY_FLEX_MINOR_VERSION==5 && YY_FLEX_SUBMINOR_VERSION>=33)) | ||
20 | inputPosition=prevPosition + (int)(yy_bp - YY_CURRENT_BUFFER_LVALUE->yy_ch_buf); | ||
21 | #else | ||
22 | inputPosition=prevPosition + (int)(yy_bp - yy_current_buffer->yy_ch_buf); | ||
23 | @@ -1160,7 +1160,7 @@ RCSTAG "$"{ID}":"[^\n$]+"$" | ||
24 | g_memberGroupHeader.resize(0); | ||
25 | parseMore=TRUE; | ||
26 | needNewEntry = TRUE; | ||
27 | -#if YY_FLEX_MINOR_VERSION>=5 && YY_FLEX_SUBMINOR_VERSION>=33 | ||
28 | +#if YY_FLEX_MAJOR_VERSION>=2 && (YY_FLEX_MINOR_VERSION>5 || (YY_FLEX_MINOR_VERSION==5 && YY_FLEX_SUBMINOR_VERSION>=33)) | ||
29 | inputPosition=prevPosition + (int)(yy_bp - YY_CURRENT_BUFFER_LVALUE->yy_ch_buf) + strlen(yytext); | ||
30 | #else | ||
31 | inputPosition=prevPosition + (int)(yy_bp - yy_current_buffer->yy_ch_buf) + strlen(yytext); | ||
32 | |||
33 | --- src/fortrancode.l.orig | ||
34 | +++ src/fortrancode.l | ||
35 | @@ -1289,7 +1289,7 @@ void parseFortranCode(CodeOutputInterfac | ||
36 | extern "C" { // some bogus code to keep the compiler happy | ||
37 | void fortrancodeYYdummy() { yy_flex_realloc(0,0); } | ||
38 | } | ||
39 | -#elif YY_FLEX_SUBMINOR_VERSION<33 | ||
40 | +#elif YY_FLEX_MAJOR_VERSION<=2 && YY_FLEX_MINOR_VERSION<=5 && YY_FLEX_SUBMINOR_VERSION<33 | ||
41 | #error "You seem to be using a version of flex newer than 2.5.4 but older than 2.5.33. These versions do NOT work with doxygen! Please use version <=2.5.4 or >=2.5.33 or expect things to be parsed wrongly!" | ||
42 | #else | ||
43 | extern "C" { // some bogus code to keep the compiler happy | ||
44 | |||
45 | --- src/pycode.l.orig | ||
46 | +++ src/pycode.l | ||
47 | @@ -1503,7 +1503,7 @@ void parsePythonCode(CodeOutputInterface | ||
48 | extern "C" { // some bogus code to keep the compiler happy | ||
49 | void pycodeYYdummy() { yy_flex_realloc(0,0); } | ||
50 | } | ||
51 | -#elif YY_FLEX_SUBMINOR_VERSION<33 | ||
52 | +#elif YY_FLEX_MAJOR_VERSION<=2 && YY_FLEX_MINOR_VERSION<=5 && YY_FLEX_SUBMINOR_VERSION<33 | ||
53 | #error "You seem to be using a version of flex newer than 2.5.4. These are currently incompatible with 2.5.4, and do NOT work with doxygen! Please use version 2.5.4 or expect things to be parsed wrongly! A bug report has been submitted (#732132)." | ||
54 | #endif | ||
55 | |||
56 | --- src/vhdlcode.l | ||
57 | +++ src.a/vhdlcode.l | ||
58 | @@ -1613,7 +1613,7 @@ void codeFreeVhdlScanner() | ||
59 | extern "C" { // some bogus code to keep the compiler happy | ||
60 | void vhdlcodeYYdummy() { yy_flex_realloc(0,0); } | ||
61 | } | ||
62 | -#elif YY_FLEX_SUBMINOR_VERSION<33 | ||
63 | +#elif YY_FLEX_MAJOR_VERSION<=2 && YY_FLEX_MINOR_VERSION<=5 && YY_FLEX_SUBMINOR_VERSION<33 | ||
64 | #error "You seem to be using a version of flex newer than 2.5.4 but older than 2.5.33. These versions do NOT work with doxygen! Please use version <=2.5.4 or >=2.5.33 or expect things to be parsed wrongly!" | ||
65 | #endif | ||
66 | |||
diff --git a/recipes-devtools/doxygen/doxygen_1.8.9.1.bb b/recipes-devtools/doxygen/doxygen_1.8.9.1.bb new file mode 100644 index 00000000..27560fdd --- /dev/null +++ b/recipes-devtools/doxygen/doxygen_1.8.9.1.bb | |||
@@ -0,0 +1,34 @@ | |||
1 | SUMMARY = "Utilities for generating documentation from source code" | ||
2 | HOMEPAGE = "http://www.doxygen.org/" | ||
3 | SECTION = "console/utils" | ||
4 | LICENSE = "GPLv2" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=b380c86cea229fa42b9e543fc491f5eb" | ||
6 | |||
7 | DEPENDS = "flex-native bison-native" | ||
8 | |||
9 | SRC_URI = "http://ftp.stack.nl/pub/users/dimitri/${BP}.src.tar.gz \ | ||
10 | file://patch-flex_2_6_0.diff;striplevel=0" | ||
11 | |||
12 | SRC_URI[md5sum] = "3d1a5c26bef358c10a3894f356a69fbc" | ||
13 | SRC_URI[sha256sum] = "d4ab6e28d4d45d8956cad17470aade3fbe2356e8f64b92167e738c1887feccec" | ||
14 | |||
15 | EXTRA_OECONF = "--prefix ${prefix}" | ||
16 | |||
17 | do_configure () { | ||
18 | ./configure ${EXTRA_OECONF} | ||
19 | |||
20 | # TODO on rebuilds will repeatedly append. Change logic to include a | ||
21 | # separate file and overwrite that file? | ||
22 | echo "TMAKE_CC=${CC}" >> tmake/lib/linux-g++/tmake.conf | ||
23 | echo "TMAKE_CXX=${CXX}" >> tmake/lib/linux-g++/tmake.conf | ||
24 | echo "TMAKE_CFLAGS=${CFLAGS}" >> tmake/lib/linux-g++/tmake.conf | ||
25 | echo "TMAKE_CXXFLAGS=${CXXFLAGS}" >> tmake/lib/linux-g++/tmake.conf | ||
26 | echo "TMAKE_LINK=${CXX}" >> tmake/lib/linux-g++/tmake.conf | ||
27 | echo "TMAKE_LFLAGS=${LDFLAGS}" >> tmake/lib/linux-g++/tmake.conf | ||
28 | } | ||
29 | |||
30 | do_install() { | ||
31 | oe_runmake install DESTDIR=${D} MAN1DIR=share/man/man1 | ||
32 | } | ||
33 | |||
34 | BBCLASSEXTEND = "native nativesdk" | ||