summaryrefslogtreecommitdiffstats
path: root/recipes-core
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-04-20 11:45:25 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2011-05-15 15:59:17 +0200
commit2ee953b6273fcf06e1fd1a327e35f2c161448791 (patch)
treec9aedaf98977ebb7a113b4f68fb795583e6ea953 /recipes-core
parentfb0766aa6f7977a7c6e8a2acf8d97fb65574f997 (diff)
downloadmeta-ti-2ee953b6273fcf06e1fd1a327e35f2c161448791.tar.gz
netbase: automatically bring up usb0 on BeagleBoard xM
Avoids manual configuration of the BeagleBoard xM's ethernet port (which shows up as usb0). Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/netbase/netbase-4.45/beagleboard/interfaces27
-rw-r--r--recipes-core/netbase/netbase_4.45.bbappend3
2 files changed, 30 insertions, 0 deletions
diff --git a/recipes-core/netbase/netbase-4.45/beagleboard/interfaces b/recipes-core/netbase/netbase-4.45/beagleboard/interfaces
new file mode 100644
index 00000000..b6935c11
--- /dev/null
+++ b/recipes-core/netbase/netbase-4.45/beagleboard/interfaces
@@ -0,0 +1,27 @@
1# /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)
2
3# The loopback interface
4auto lo
5iface lo inet loopback
6
7# Wireless interfaces
8iface wlan0 inet dhcp
9 wireless_mode managed
10 wireless_essid any
11 wpa-driver wext
12 wpa-conf /etc/wpa_supplicant.conf
13
14iface atml0 inet dhcp
15
16# Wired or wireless interfaces
17auto eth0
18iface eth0 inet dhcp
19iface eth1 inet dhcp
20
21# Ethernet/RNDIS gadget (g_ether) or LAN9514 on BeagleBoard xM
22auto usb0
23iface usb0 inet dhcp
24
25# Bluetooth networking
26iface bnep0 inet dhcp
27
diff --git a/recipes-core/netbase/netbase_4.45.bbappend b/recipes-core/netbase/netbase_4.45.bbappend
new file mode 100644
index 00000000..4b8d0e65
--- /dev/null
+++ b/recipes-core/netbase/netbase_4.45.bbappend
@@ -0,0 +1,3 @@
1THISDIR := "${@os.path.dirname(bb.data.getVar('FILE', d, True))}"
2FILESPATH =. "${@base_set_filespath(["${THISDIR}/${PN}"], d)}:"
3