diff options
author | Denys Dmytriyenko <denys@ti.com> | 2015-02-26 14:51:40 -0500 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2015-02-26 20:32:28 -0500 |
commit | 4ce69eff28103778508d23af766e6204c95595d3 (patch) | |
tree | 3e083c36513d1ee6243dfa8887776dd6ef545a5d /recipes-core | |
parent | bf4ea2414381de75f712deab54dcaea7e557e8b5 (diff) | |
download | meta-ti-4ce69eff28103778508d23af766e6204c95595d3.tar.gz |
udev: rules for seamless transition to 8250_omap serial driver
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-core')
-rw-r--r-- | recipes-core/udev/udev/omap-tty.rules | 17 | ||||
-rw-r--r-- | recipes-core/udev/udev_%.bbappend | 9 |
2 files changed, 26 insertions, 0 deletions
diff --git a/recipes-core/udev/udev/omap-tty.rules b/recipes-core/udev/udev/omap-tty.rules new file mode 100644 index 00000000..989d60f8 --- /dev/null +++ b/recipes-core/udev/udev/omap-tty.rules | |||
@@ -0,0 +1,17 @@ | |||
1 | # There are a number of modifiers that are allowed to be used in some | ||
2 | # of the different fields. They provide the following subsitutions: | ||
3 | # | ||
4 | # %n the "kernel number" of the device. | ||
5 | # For example, 'sda3' has a "kernel number" of '3' | ||
6 | # %e the smallest number for that name which does not matches an existing node | ||
7 | # %k the kernel name for the device | ||
8 | # %M the kernel major number for the device | ||
9 | # %m the kernel minor number for the device | ||
10 | # %b the bus id for the device | ||
11 | # %c the string returned by the PROGRAM | ||
12 | # %s{filename} the content of a sysfs attribute | ||
13 | # %% the '%' char itself | ||
14 | # | ||
15 | |||
16 | # Backward compatibility with old OMAP UART-style ttyO0 naming | ||
17 | SUBSYSTEM=="tty", ATTR{uartclk}!="0", KERNEL=="ttyS[0-9]", SYMLINK+="ttyO%n" | ||
diff --git a/recipes-core/udev/udev_%.bbappend b/recipes-core/udev/udev_%.bbappend new file mode 100644 index 00000000..fd0d99bc --- /dev/null +++ b/recipes-core/udev/udev_%.bbappend | |||
@@ -0,0 +1,9 @@ | |||
1 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | ||
2 | |||
3 | SRC_URI_append = " file://omap-tty.rules" | ||
4 | |||
5 | PR_append = ".0" | ||
6 | |||
7 | do_install_append() { | ||
8 | install -m 0644 ${WORKDIR}/omap-tty.rules ${D}${sysconfdir}/udev/rules.d/ | ||
9 | } | ||