summaryrefslogtreecommitdiffstats
path: root/recipes-connectivity
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2012-05-07 17:57:40 +0200
committerDenys Dmytriyenko <denys@ti.com>2012-05-10 15:36:11 -0400
commit285aeaee513969ca7a79a344c75d0f590b722cb9 (patch)
tree05007f9c65f75dc9534f87a36631f6b72d2537fe /recipes-connectivity
parentaefc6c8c3c2d49ef0338004ed90da987f7cf6101 (diff)
downloadmeta-ti-285aeaee513969ca7a79a344c75d0f590b722cb9.tar.gz
uim: userspace app to manage wl12xx firmware loading
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-connectivity')
-rw-r--r--recipes-connectivity/uim/uim_git.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes-connectivity/uim/uim_git.bb b/recipes-connectivity/uim/uim_git.bb
new file mode 100644
index 00000000..c8265e92
--- /dev/null
+++ b/recipes-connectivity/uim/uim_git.bb
@@ -0,0 +1,19 @@
1DESCRIPTION = "User Mode Initialization Manager for wl12xx devices"
2LICENSE = "GPLv2+"
3LIC_FILES_CHKSUM = "file://uim.c;startline=4;endline=12;md5=16a9d6e829218481f8a61797fe2be2e2"
4
5# Doesn't have a version, so we'll make one up
6PV = "0.0"
7
8SRCREV = "c73894456df5def97111cb33d2106b684b8b7959"
9SRC_URI = "git://gitorious.org/uim/uim.git"
10
11S= "${WORKDIR}/git"
12
13do_install() {
14 oe_runmake install DESTDIR=${D}
15}
16
17# connman has a plugin to handle all this
18RCONFLICTS_${PN} += "connman-plugin-tist"
19RRECOMMENDS_${PN} = "linux-firmware-wl12xx"