summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-10-11 10:31:02 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-10-11 10:31:02 +0200
commitb7e2fa7952dc80c93c5cff3fffd54ed067318229 (patch)
tree6bfe4226c9ec4a3662d65fa2b229f2c29c8003ed /recipes-bsp
parent7a45605f91536519a53e6f18dedee5f1f62d88e0 (diff)
downloadmeta-ti-b7e2fa7952dc80c93c5cff3fffd54ed067318229.tar.gz
u-boot 2011.09: switch to proper 2011.09 tag and add support for TCT beaconboard
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/u-boot/u-boot/2011.09/0001-beagleboard-add-support-for-TCT-Beacon-board.patch42
-rw-r--r--recipes-bsp/u-boot/u-boot_2011.09.bb11
2 files changed, 37 insertions, 16 deletions
diff --git a/recipes-bsp/u-boot/u-boot/2011.09/0001-beagleboard-add-support-for-TCT-Beacon-board.patch b/recipes-bsp/u-boot/u-boot/2011.09/0001-beagleboard-add-support-for-TCT-Beacon-board.patch
index bf828f69..819c6233 100644
--- a/recipes-bsp/u-boot/u-boot/2011.09/0001-beagleboard-add-support-for-TCT-Beacon-board.patch
+++ b/recipes-bsp/u-boot/u-boot/2011.09/0001-beagleboard-add-support-for-TCT-Beacon-board.patch
@@ -5,14 +5,23 @@ Subject: [PATCH] beagleboard: add support for TCT Beacon board
5 5
6Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> 6Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
7--- 7---
8 board/ti/beagle/beagle.c | 8 ++++++++ 8 board/ti/beagle/beagle.c | 59 ++++++++++++++++++++++++++++++++++++++++
9 1 files changed, 8 insertions(+), 0 deletions(-) 9 board/ti/beagle/beagle.h | 7 +++++
10 include/configs/omap3_beagle.h | 7 +++++
11 3 files changed, 73 insertions(+), 0 deletions(-)
10 12
11diff --git a/board/ti/beagle/beagle.c b/board/ti/beagle/beagle.c 13diff --git a/board/ti/beagle/beagle.c b/board/ti/beagle/beagle.c
12index 8cdceaf..be40e96 100644 14index 8cdceaf..f4e986c 100644
13--- a/board/ti/beagle/beagle.c 15--- a/board/ti/beagle/beagle.c
14+++ b/board/ti/beagle/beagle.c 16+++ b/board/ti/beagle/beagle.c
15@@ -62,6 +62,7 @@ extern volatile struct ehci_hcor *hcor; 17@@ -57,11 +57,14 @@ extern volatile struct ehci_hcor *hcor;
18 #define TWL4030_I2C_BUS 0
19 #define EXPANSION_EEPROM_I2C_BUS 1
20 #define EXPANSION_EEPROM_I2C_ADDRESS 0x50
21+#define DVI_EDID_I2C_BUS 2
22+#define DVI_EDID_I2C_ADDRESS 0x50
23
24 #define TINCANTOOLS_ZIPPY 0x01000100
16 #define TINCANTOOLS_ZIPPY2 0x02000100 25 #define TINCANTOOLS_ZIPPY2 0x02000100
17 #define TINCANTOOLS_TRAINER 0x04000100 26 #define TINCANTOOLS_TRAINER 0x04000100
18 #define TINCANTOOLS_SHOWDOG 0x03000100 27 #define TINCANTOOLS_SHOWDOG 0x03000100
@@ -20,7 +29,7 @@ index 8cdceaf..be40e96 100644
20 #define KBADC_BEAGLEFPGA 0x01000600 29 #define KBADC_BEAGLEFPGA 0x01000600
21 #define LW_BEAGLETOUCH 0x01000700 30 #define LW_BEAGLETOUCH 0x01000700
22 #define BRAINMUX_LCDOG 0x01000800 31 #define BRAINMUX_LCDOG 0x01000800
23@@ -290,6 +291,13 @@ int misc_init_r(void) 32@@ -290,6 +331,13 @@ int misc_init_r(void)
24 setenv("defaultdisplay", "showdoglcd"); 33 setenv("defaultdisplay", "showdoglcd");
25 setenv("buddy", "showdog"); 34 setenv("buddy", "showdog");
26 break; 35 break;
@@ -28,12 +37,27 @@ index 8cdceaf..be40e96 100644
28+ printf("Recognized Tincantools Beacon board (rev %d %s)\n", 37+ printf("Recognized Tincantools Beacon board (rev %d %s)\n",
29+ expansion_config.revision, 38+ expansion_config.revision,
30+ expansion_config.fab_revision); 39+ expansion_config.fab_revision);
31+ /* Place holder for DSS2 definition for showdog lcd */ 40+ MUX_TINCANTOOLS_BEACON();
32+ setenv("buddy", "beacon"); 41+ setenv("buddy", "beacon");
33+ break; 42+ break;
34 case KBADC_BEAGLEFPGA: 43 case KBADC_BEAGLEFPGA:
35 printf("Recognized KBADC Beagle FPGA board\n"); 44 printf("Recognized KBADC Beagle FPGA board\n");
36 MUX_KBADC_BEAGLEFPGA(); 45 MUX_KBADC_BEAGLEFPGA();
37-- 46diff --git a/board/ti/beagle/beagle.h b/board/ti/beagle/beagle.h
381.6.6.1 47index 18bfaa8..6a9ad73 100644
39 48--- a/board/ti/beagle/beagle.h
49+++ b/board/ti/beagle/beagle.h
50@@ -456,6 +456,13 @@ const omap3_sysinfo sysinfo = {
51 MUX_VAL(CP(MCBSP3_CLKX), (IEN | PTU | EN | M4)) /*GPIO_141*/\
52 MUX_VAL(CP(MCBSP1_CLKX), (IEN | PTU | EN | M4)) /*GPIO_162*/
53
54+#define MUX_TINCANTOOLS_BEACON() \
55+ MUX_VAL(CP(MMC2_DAT3), (IEN | PTU | EN | M4)) /*GPIO_135*/\
56+ MUX_VAL(CP(MMC2_DAT4), (IEN | PTU | EN | M4)) /*GPIO_136*/\
57+ MUX_VAL(CP(MMC2_DAT5), (IEN | PTU | EN | M4)) /*GPIO_137*/\
58+ MUX_VAL(CP(MMC2_DAT6), (IEN | PTU | EN | M4)) /*GPIO_138*/\
59+ MUX_VAL(CP(MMC2_DAT7), (IEN | PTU | EN | M4)) /*GPIO_139*/\
60+
61 #define MUX_KBADC_BEAGLEFPGA() \
62 MUX_VAL(CP(MCBSP1_CLKR), (IEN | PTU | DIS | M1)) /*MCSPI4_CLK*/\
63 MUX_VAL(CP(MCBSP1_DX), (IDIS | PTU | DIS | M1)) /*MCSPI4_SIMO*/\
diff --git a/recipes-bsp/u-boot/u-boot_2011.09.bb b/recipes-bsp/u-boot/u-boot_2011.09.bb
index d250f71e..10e02691 100644
--- a/recipes-bsp/u-boot/u-boot_2011.09.bb
+++ b/recipes-bsp/u-boot/u-boot_2011.09.bb
@@ -1,6 +1,6 @@
1require u-boot.inc 1require u-boot.inc
2 2
3PR = "r1" 3PR = "r2"
4 4
5# No patches for other machines yet 5# No patches for other machines yet
6COMPATIBLE_MACHINE = "(beagleboard)" 6COMPATIBLE_MACHINE = "(beagleboard)"
@@ -9,14 +9,11 @@ SRC_URI = "git://www.denx.de/git/u-boot.git;protocol=git \
9 file://2011.09/0001-HACK-beagleboard-config-disable-cache-for-USB.patch \ 9 file://2011.09/0001-HACK-beagleboard-config-disable-cache-for-USB.patch \
10 file://2011.09/0002-beagleboard-config-enable-gpio-command.patch \ 10 file://2011.09/0002-beagleboard-config-enable-gpio-command.patch \
11 file://2011.09/0003-Increased-some-timeout-durations-for-MMC-and-EHCI.patch \ 11 file://2011.09/0003-Increased-some-timeout-durations-for-MMC-and-EHCI.patch \
12 file://2011.09/0001-beagleboard-probe-DDC-bus-for-expansionboard-EEPROMS.patch \ 12 file://2011.09/0001-beagleboard-add-support-for-TCT-Beacon-board.patch \
13 file://fw_env.config \ 13 file://fw_env.config \
14 " 14 "
15# v2011.09 tag -> 6ceb0135f96d73063ffbaab5be7ce23933367388 15
16# The tag below is from the master tree, but 21 patches after. 16SRCREV = "1d5e7fb403257d62f0f2419cb83fdf6b0f02f215"
17# $ git log 6ceb0135f..56fa45d58 | grep commit | wc -l
18# 21
19SRCREV = "56fa45d58116f86f343a9c45ce6d1110f50b8d70"
20 17
21LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb" 18LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb"
22 19