summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2013-03-18 18:07:18 -0400
committerDenys Dmytriyenko <denys@ti.com>2013-03-18 21:31:33 -0400
commit48673d8784c36184a9e4b3d2c81cfe74d1fa9953 (patch)
tree813a13528b0f6c9ec6c1c4f1cd55a1bb434e2bed /recipes-bsp
parent7c9f57083ec3e0e06d5ef0d390c12f1a79cc85fd (diff)
downloadmeta-ti-48673d8784c36184a9e4b3d2c81cfe74d1fa9953.tar.gz
u-boot-am33x: modify am33x specific version to use new namespace feature
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/u-boot/u-boot-am33x_2012.10.bb17
-rw-r--r--recipes-bsp/u-boot/u-boot_2012.10.bb32
2 files changed, 17 insertions, 32 deletions
diff --git a/recipes-bsp/u-boot/u-boot-am33x_2012.10.bb b/recipes-bsp/u-boot/u-boot-am33x_2012.10.bb
new file mode 100644
index 00000000..7320e021
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-am33x_2012.10.bb
@@ -0,0 +1,17 @@
1require u-boot-ti.inc
2
3DESCRIPTION = "u-boot bootloader for ARM MPU devices"
4
5COMPATIBLE_MACHINE = "ti33x|omap3"
6
7DEFAULT_PREFERENCE = "-1"
8
9PR = "r7+gitr${SRCPV}"
10
11SRC_URI = "git://arago-project.org/git/projects/u-boot-am33x.git;protocol=git;branch=${BRANCH}"
12
13BRANCH = "amsdk-05.06.00.00"
14
15SRCREV = "6536bfa6b7f16bb49fdea8c72959e3ed54e77a82"
16
17SPL_BINARY = "MLO"
diff --git a/recipes-bsp/u-boot/u-boot_2012.10.bb b/recipes-bsp/u-boot/u-boot_2012.10.bb
deleted file mode 100644
index 89d646c6..00000000
--- a/recipes-bsp/u-boot/u-boot_2012.10.bb
+++ /dev/null
@@ -1,32 +0,0 @@
1# Use the version of u-boot.inc in oe-core not the meta-ti version
2require ${COREBASE}/meta/recipes-bsp/u-boot/u-boot.inc
3
4# Reset OEMAKE. Current u-boot.inc sets -02 which breaks this version of u-boot's build.
5# This issue was fixed in oe-core master by removing the -02 statement.
6EXTRA_OEMAKE = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS}"'
7
8DESCRIPTION = "u-boot bootloader for ARM MPU devices"
9LICENSE = "GPLv2+"
10LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb"
11
12COMPATIBLE_MACHINE = "ti33x|omap3"
13
14DEFAULT_PREFERENCE = "-1"
15
16PACKAGE_ARCH = "${MACHINE_ARCH}"
17
18PR = "r7+gitr${SRCPV}"
19
20SRC_URI = "git://arago-project.org/git/projects/u-boot-am33x.git;protocol=git;branch=${BRANCH} \
21"
22
23BRANCH = "amsdk-05.06.00.00"
24
25SRCREV = "6536bfa6b7f16bb49fdea8c72959e3ed54e77a82"
26
27S = "${WORKDIR}/git"
28
29UBOOT_SUFFIX = "img"
30
31# Set the name of the SPL that will built so that it is also packaged with u-boot.
32SPL_BINARY = "MLO"