summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-10-13 12:50:34 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-10-13 12:50:34 +0200
commit453576ad81ca3a8cf5daaa02e2749aff3254a2a3 (patch)
treeebee2210229563e45a733bee3eabf59af83ccb6f /recipes-bsp
parent244e8398923aab44d75fc9aac79a65141bb4e502 (diff)
downloadmeta-ti-453576ad81ca3a8cf5daaa02e2749aff3254a2a3.tar.gz
u-boot 2010rc: switch to Toms latest branch, rediff env patches
This fixes the boot slowdown regression Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/u-boot/u-boot/2011.09git/0001-am335x_evm-boot-kernel-from-ext2-3-filesystem.patch27
-rw-r--r--recipes-bsp/u-boot/u-boot/2011.09git/0002-am335x_evm-read-uEnv.txt-instead-of-boot.scr.patch57
-rw-r--r--recipes-bsp/u-boot/u-boot/2011.09git/0002-am335x_evm-set-bootdelay-to-0.patch (renamed from recipes-bsp/u-boot/u-boot/2011.09git/0001-am335x_evm-reduced-bootdelay-to-1.patch)18
-rw-r--r--recipes-bsp/u-boot/u-boot/2011.09git/0003-am335x_evm-boot-kernel-from-ext2-filesystem.patch34
-rw-r--r--recipes-bsp/u-boot/u-boot_2011.10rc.bb12
5 files changed, 42 insertions, 106 deletions
diff --git a/recipes-bsp/u-boot/u-boot/2011.09git/0001-am335x_evm-boot-kernel-from-ext2-3-filesystem.patch b/recipes-bsp/u-boot/u-boot/2011.09git/0001-am335x_evm-boot-kernel-from-ext2-3-filesystem.patch
new file mode 100644
index 00000000..1ed68ea8
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot/2011.09git/0001-am335x_evm-boot-kernel-from-ext2-3-filesystem.patch
@@ -0,0 +1,27 @@
1From 30c5198d37863d4f1598f7fe2b8f690b6cf6ae53 Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Thu, 13 Oct 2011 12:15:25 +0200
4Subject: [PATCH 1/2] am335x_evm: boot kernel from ext2/3 filesystem
5
6Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
7---
8 include/configs/am335x_evm.h | 3 ++-
9 1 files changed, 2 insertions(+), 1 deletions(-)
10
11diff --git a/include/configs/am335x_evm.h b/include/configs/am335x_evm.h
12index f1cc2b2..9ce360d 100755
13--- a/include/configs/am335x_evm.h
14+++ b/include/configs/am335x_evm.h
15@@ -74,7 +74,8 @@
16 "loadbootenv=fatload mmc ${mmc_dev} ${loadaddr} ${bootenv}\0" \
17 "importbootenv=echo Importing environment from mmc ...; " \
18 "env import -t $loadaddr $filesize\0" \
19- "mmc_load_uimage=fatload mmc ${mmc_dev} ${loadaddr} ${bootfile}\0" \
20+ "mmc_load_uimage_fat=fatload mmc ${mmc_dev} ${loadaddr} ${bootfile}\0" \
21+ "mmc_load_uimage=ext2load mmc 0:2 ${loadaddr} /boot/${bootfile}\0" \
22 "bootargs_defaults=setenv bootargs " \
23 "console=${console}\0" \
24 "mmc_args=run bootargs_defaults;" \
25--
261.6.6.1
27
diff --git a/recipes-bsp/u-boot/u-boot/2011.09git/0002-am335x_evm-read-uEnv.txt-instead-of-boot.scr.patch b/recipes-bsp/u-boot/u-boot/2011.09git/0002-am335x_evm-read-uEnv.txt-instead-of-boot.scr.patch
deleted file mode 100644
index a2e0f6d1..00000000
--- a/recipes-bsp/u-boot/u-boot/2011.09git/0002-am335x_evm-read-uEnv.txt-instead-of-boot.scr.patch
+++ /dev/null
@@ -1,57 +0,0 @@
1From 527309ca11da0a258479da8443f00de0003c4bf9 Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Wed, 12 Oct 2011 10:50:51 +0200
4Subject: [PATCH 2/2] am335x_evm: read uEnv.txt instead of boot.scr
5
6Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
7---
8 include/configs/am335x_evm.h | 25 ++++++++++++++-----------
9 1 files changed, 14 insertions(+), 11 deletions(-)
10
11diff --git a/include/configs/am335x_evm.h b/include/configs/am335x_evm.h
12index dbb412a..5a28724 100755
13--- a/include/configs/am335x_evm.h
14+++ b/include/configs/am335x_evm.h
15@@ -116,6 +116,10 @@
16 "loadbootscript=fatload mmc 0 ${script_addr} boot.scr\0" \
17 "bootscript= echo Running bootscript from MMC/SD to set the ENV...; " \
18 "source ${script_addr}\0" \
19+ "bootenv=uEnv.txt\0" \
20+ "loadbootenv=fatload mmc 0 ${loadaddr} ${bootenv}\0" \
21+ "importbootenv=echo Importing environment from mmc ...; " \
22+ "env import -t $loadaddr $filesize\0" \
23 "mmc_load_uimage_fat=fatload mmc 0 ${loadaddr} ${bootfile}\0" \
24 "mmc_load_uimage=ext2load mmc 0:2 ${loadaddr} /boot/${bootfile}\0" \
25 "bootargs_defaults=setenv bootargs " \
26@@ -167,18 +171,17 @@
27
28 #define CONFIG_BOOTCOMMAND \
29 "if mmc rescan; then " \
30- "if run loadbootscript; then " \
31- "run bootscript; " \
32- "else " \
33- "if run mmc_load_uimage; then " \
34- "run mmc_boot; " \
35- "else " \
36- "run nand_boot; " \
37- "fi; " \
38+ "if run loadbootenv; then " \
39+ "echo Loaded environment from ${bootenv};" \
40+ "run importbootenv; " \
41 "fi; " \
42- "else " \
43- "run nand_boot; " \
44- "fi"
45+ "if test -n $uenvcmd; then " \
46+ "echo Running uenvcmd ...;" \
47+ "run uenvcmd;" \
48+ "fi;" \
49+ "run mmc_boot; " \
50+ "fi; " \
51+ "run nand_boot; " \
52
53 #define CONFIG_DISPLAY_BOARDINFO
54 #define CONFIG_MISC_INIT_R
55--
561.6.6.1
57
diff --git a/recipes-bsp/u-boot/u-boot/2011.09git/0001-am335x_evm-reduced-bootdelay-to-1.patch b/recipes-bsp/u-boot/u-boot/2011.09git/0002-am335x_evm-set-bootdelay-to-0.patch
index 126806de..f3ca6807 100644
--- a/recipes-bsp/u-boot/u-boot/2011.09git/0001-am335x_evm-reduced-bootdelay-to-1.patch
+++ b/recipes-bsp/u-boot/u-boot/2011.09git/0002-am335x_evm-set-bootdelay-to-0.patch
@@ -1,7 +1,7 @@
1From 722fc7ad06a0353c1c1d168804747c5c56614ae3 Mon Sep 17 00:00:00 2001 1From 481457db4fe870fcbab47fe29cb768daf235fd1f Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net> 2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Wed, 12 Oct 2011 10:45:17 +0200 3Date: Thu, 13 Oct 2011 12:17:27 +0200
4Subject: [PATCH 1/2] am335x_evm: reduced bootdelay to 1 4Subject: [PATCH 2/2] am335x_evm: set bootdelay to 0
5 5
6Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> 6Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
7--- 7---
@@ -9,18 +9,18 @@ Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
9 1 files changed, 1 insertions(+), 1 deletions(-) 9 1 files changed, 1 insertions(+), 1 deletions(-)
10 10
11diff --git a/include/configs/am335x_evm.h b/include/configs/am335x_evm.h 11diff --git a/include/configs/am335x_evm.h b/include/configs/am335x_evm.h
12index ddadc3e..dbb412a 100755 12index 9ce360d..78c823b 100755
13--- a/include/configs/am335x_evm.h 13--- a/include/configs/am335x_evm.h
14+++ b/include/configs/am335x_evm.h 14+++ b/include/configs/am335x_evm.h
15@@ -24,7 +24,7 @@ 15@@ -38,7 +38,7 @@
16 #define CONFIG_AM335X_HSMMC_INSTANCE 0 /* 0 - MMC0, 1 - MMC1 */ 16 #define CONFIG_INITRD_TAG /* Required for ramdisk support */
17 17
18 /* set to negative value for no autoboot */ 18 /* set to negative value for no autoboot */
19-#define CONFIG_BOOTDELAY 3 19-#define CONFIG_BOOTDELAY 3
20+#define CONFIG_BOOTDELAY 1 20+#define CONFIG_BOOTDELAY 0
21 21
22 # if defined(CONFIG_SPI_BOOT) 22 #define CONFIG_MMC
23 # define CONFIG_SPI 1 23 #define CONFIG_NAND
24-- 24--
251.6.6.1 251.6.6.1
26 26
diff --git a/recipes-bsp/u-boot/u-boot/2011.09git/0003-am335x_evm-boot-kernel-from-ext2-filesystem.patch b/recipes-bsp/u-boot/u-boot/2011.09git/0003-am335x_evm-boot-kernel-from-ext2-filesystem.patch
deleted file mode 100644
index 47fa7aa1..00000000
--- a/recipes-bsp/u-boot/u-boot/2011.09git/0003-am335x_evm-boot-kernel-from-ext2-filesystem.patch
+++ /dev/null
@@ -1,34 +0,0 @@
1From 9de8f53dea91169f3b8a9473ad2b5c9c0fdd0eb1 Mon Sep 17 00:00:00 2001
2From: Jason Kridner <jdk@ti.com>
3Date: Sat, 8 Oct 2011 16:22:53 -0400
4Subject: [PATCH 3/5] am335x_evm: boot kernel from ext2 filesystem
5
6---
7 include/configs/am335x_evm.h | 4 +++-
8 1 files changed, 3 insertions(+), 1 deletions(-)
9
10diff --git a/include/configs/am335x_evm.h b/include/configs/am335x_evm.h
11index c5e608c..a2e4564 100755
12--- a/include/configs/am335x_evm.h
13+++ b/include/configs/am335x_evm.h
14@@ -112,7 +112,8 @@
15 "loadbootscript=fatload mmc 0 ${script_addr} boot.scr\0" \
16 "bootscript= echo Running bootscript from MMC/SD to set the ENV...; " \
17 "source ${script_addr}\0" \
18- "mmc_load_uimage=fatload mmc 0 ${loadaddr} ${bootfile}\0" \
19+ "mmc_load_uimage_fat=fatload mmc 0 ${loadaddr} ${bootfile}\0" \
20+ "mmc_load_uimage=ext2load mmc 0:2 ${loadaddr} /boot/${bootfile}\0" \
21 "bootargs_defaults=setenv bootargs " \
22 "console=${console}\0 " \
23 "mmc_args=run bootargs_defaults;" \
24@@ -403,6 +404,7 @@
25 # define CONFIG_CMD_MMC 1
26 # define CONFIG_DOS_PARTITION 1
27 # define CONFIG_CMD_FAT 1
28+# define CONFIG_CMD_EXT2 1
29 #endif
30
31 /* Unsupported features */
32--
331.6.6.1
34
diff --git a/recipes-bsp/u-boot/u-boot_2011.10rc.bb b/recipes-bsp/u-boot/u-boot_2011.10rc.bb
index 8c3384e6..44ebeb63 100644
--- a/recipes-bsp/u-boot/u-boot_2011.10rc.bb
+++ b/recipes-bsp/u-boot/u-boot_2011.10rc.bb
@@ -4,19 +4,19 @@ require u-boot.inc
4COMPATIBLE_MACHINE = "beaglebone" 4COMPATIBLE_MACHINE = "beaglebone"
5DEFAULT_PREFERENCE_beaglebone = "99" 5DEFAULT_PREFERENCE_beaglebone = "99"
6PV = "2011.09+git" 6PV = "2011.09+git"
7PR = "r4" 7PR = "r5"
8 8
9# SPL build 9# SPL build
10UBOOT_BINARY = "u-boot.img" 10UBOOT_BINARY = "u-boot.img"
11UBOOT_IMAGE = "u-boot-${MACHINE}-${PV}-${PR}.img" 11UBOOT_IMAGE = "u-boot-${MACHINE}-${PV}-${PR}.img"
12UBOOT_SYMLINK = "u-boot-${MACHINE}.img" 12UBOOT_SYMLINK = "u-boot-${MACHINE}.img"
13 13
14SRC_URI = "git://github.com/joelagnel/u-boot.git;protocol=git;branch=bone-bringup \ 14SRC_URI = "git://github.com/trini/u-boot.git;protocol=git;branch=int_am335xpsp_04.06.00.01-v2011.09-for-sdk-05.03.00.00 \
15 file://2011.09git/0003-am335x_evm-boot-kernel-from-ext2-filesystem.patch \ 15 file://2011.09git/0001-am335x_evm-boot-kernel-from-ext2-3-filesystem.patch \
16 file://2011.09git/0001-am335x_evm-reduced-bootdelay-to-1.patch \ 16 file://2011.09git/0002-am335x_evm-set-bootdelay-to-0.patch \
17 file://2011.09git/0002-am335x_evm-read-uEnv.txt-instead-of-boot.scr.patch \
18 " 17 "
19SRCREV = "fb3043c07bc05df83d38bfd2b303f2c9a96779c6" 18
19SRCREV = "456880b203bc44c025c374c98fa327b804a9cf64"
20 20
21LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb" 21LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb"
22 22