summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-10-18 02:15:56 +0000
committerDenys Dmytriyenko <denys@ti.com>2018-10-17 22:48:34 +0000
commitb2d62f62bb6ecbb07577a0af9438bcaa017bf1da (patch)
tree768143c3403cc6ef78cd44119d25a59898b83483 /recipes-bsp
parent934fed368d0b6f2880d7e9768176a541a9bc189a (diff)
downloadmeta-ti-b2d62f62bb6ecbb07577a0af9438bcaa017bf1da.tar.gz
recipes: Limit ti specific recipes under ti-soc override
This helps in multi-BSP scenario, where other BSP layers are also present in the layermix Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/cm3-pm-firmware/amx3-cm3_git.bb2
-rw-r--r--recipes-bsp/cmem/cmem.inc2
-rw-r--r--recipes-bsp/cuia/cuia_1.0.0.13.bb3
-rw-r--r--recipes-bsp/gc320-drivers/ti-gc320-driver_5.0.11.p7.bb3
-rw-r--r--recipes-bsp/x-load/x-load_git.bb3
5 files changed, 13 insertions, 0 deletions
diff --git a/recipes-bsp/cm3-pm-firmware/amx3-cm3_git.bb b/recipes-bsp/cm3-pm-firmware/amx3-cm3_git.bb
index 93cebd71..b9a3b0fa 100644
--- a/recipes-bsp/cm3-pm-firmware/amx3-cm3_git.bb
+++ b/recipes-bsp/cm3-pm-firmware/amx3-cm3_git.bb
@@ -24,3 +24,5 @@ do_install() {
24} 24}
25 25
26FILES_${PN} += "${base_libdir}/firmware" 26FILES_${PN} += "${base_libdir}/firmware"
27COMPATIBLE_HOST ?= "null"
28COMPATIBLE_HOST_ti-soc = "(.*)"
diff --git a/recipes-bsp/cmem/cmem.inc b/recipes-bsp/cmem/cmem.inc
index 11cebe8d..abbf2492 100644
--- a/recipes-bsp/cmem/cmem.inc
+++ b/recipes-bsp/cmem/cmem.inc
@@ -12,3 +12,5 @@ PV = "4.15.00.02+git${SRCPV}"
12SRC_URI = "git://git.ti.com/ipc/ludev.git;protocol=git;branch=${BRANCH}" 12SRC_URI = "git://git.ti.com/ipc/ludev.git;protocol=git;branch=${BRANCH}"
13 13
14S = "${WORKDIR}/git" 14S = "${WORKDIR}/git"
15COMPATIBLE_HOST ?= "null"
16COMPATIBLE_HOST_ti-soc = "(.*)"
diff --git a/recipes-bsp/cuia/cuia_1.0.0.13.bb b/recipes-bsp/cuia/cuia_1.0.0.13.bb
index e048f6aa..a7caf504 100644
--- a/recipes-bsp/cuia/cuia_1.0.0.13.bb
+++ b/recipes-bsp/cuia/cuia_1.0.0.13.bb
@@ -23,3 +23,6 @@ do_install() {
23 cd ${S} 23 cd ${S}
24 oe_runmake DESTDIR=${D} libdir=${libdir} includedir=${includedir} install 24 oe_runmake DESTDIR=${D} libdir=${libdir} includedir=${includedir} install
25} 25}
26
27COMPATIBLE_HOST ?= "null"
28COMPATIBLE_HOST_ti-soc = "(.*)"
diff --git a/recipes-bsp/gc320-drivers/ti-gc320-driver_5.0.11.p7.bb b/recipes-bsp/gc320-drivers/ti-gc320-driver_5.0.11.p7.bb
index 94485b6a..d29b6496 100644
--- a/recipes-bsp/gc320-drivers/ti-gc320-driver_5.0.11.p7.bb
+++ b/recipes-bsp/gc320-drivers/ti-gc320-driver_5.0.11.p7.bb
@@ -22,3 +22,6 @@ do_install() {
22 install -d ${D}/${base_libdir}/modules/${KERNEL_VERSION}/extra 22 install -d ${D}/${base_libdir}/modules/${KERNEL_VERSION}/extra
23 install -m 644 ${S}/galcore.ko ${D}/${base_libdir}/modules/${KERNEL_VERSION}/extra 23 install -m 644 ${S}/galcore.ko ${D}/${base_libdir}/modules/${KERNEL_VERSION}/extra
24} 24}
25
26COMPATIBLE_HOST ?= "null"
27COMPATIBLE_HOST_ti-soc = "(.*)"
diff --git a/recipes-bsp/x-load/x-load_git.bb b/recipes-bsp/x-load/x-load_git.bb
index dd8bce2d..1ce1b0f0 100644
--- a/recipes-bsp/x-load/x-load_git.bb
+++ b/recipes-bsp/x-load/x-load_git.bb
@@ -17,3 +17,6 @@ CONFIG_HEADER_beagleboard = "1"
17XLOAD_MACHINE_omap3-touchbook = "omap3530beagle_config" 17XLOAD_MACHINE_omap3-touchbook = "omap3530beagle_config"
18 18
19PACKAGE_ARCH = "${MACHINE_ARCH}" 19PACKAGE_ARCH = "${MACHINE_ARCH}"
20
21COMPATIBLE_HOST ?= "null"
22COMPATIBLE_HOST_ti-soc = "(.*)"